1. This forum is obsolete and read-only. Feel free to contact us at support.keenswh.com

Update 01.130 - Re-enabled Cargo Ships & Server Side Ship Control

Discussion in 'Change Log' started by Drui, Apr 14, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Crash 3

    Crash 3 Trainee Engineer

    Messages:
    4
    ok, nope it did not fix, server will not even restart now
     
  2. Zanzikahn

    Zanzikahn Trainee Engineer

    Messages:
    46
    QQ before testing.. Gj on the fail...
     
    • Disagree Disagree x 1
  3. rexxar

    rexxar Senior Engineer

    Messages:
    1,532
    We didn't expect anyone to want this behavior, so there isn't any way to turn it off; it's integral to the spawn logic.

    edit: I suddenly got a whole bunch of requests, so I'll talk to the devs, and look into adding a flag to the ship sbc.
     
    • Friendly Friendly x 1
  4. Deepflame

    Deepflame Apprentice Engineer

    Messages:
    395
    You had me seriously worried for a while there. :(
     
    • Like Like x 3
    • Funny Funny x 3
    • Friendly Friendly x 1
  5. Zanzikahn

    Zanzikahn Trainee Engineer

    Messages:
    46
    Planets do have procedural generation... You need to either mod a planet or read the planet data files.. It would take a ridiculous long time if there was no procedural generation. In fact I use procedural in all my planet mods.
     
    • Agree Agree x 1
  6. Commander Rotal

    Commander Rotal Master Engineer

    Messages:
    4,979
    Yeeeeah i'm sorry :woot:
    Next goal: keeping SimSpeed up when she moves!
     
    • Funny Funny x 1
  7. Rabidmongoose

    Rabidmongoose Trainee Engineer

    Messages:
    7
    I wont be able to get on the game until later. has anyone else had the problem where they have to turn on/off lcd to have them update the text they are showing since the last update? and if so does anyone know if it is fixed
     
  8. Zanzikahn

    Zanzikahn Trainee Engineer

    Messages:
    46
    I will look, but I don't think it'll be possible to spawn in gravity wells
    Edit: guess Rexxar gots the answer for you.
     
  9. Mr Engineer

    Mr Engineer Apprentice Engineer

    Messages:
    467
    I like those fixes. That new Piston feature interests me alot. Could have done with that feature a few weeks back...never mind, its here now. I like those fixes, thanks Keen!
     
  10. Anders142536

    Anders142536 Trainee Engineer

    Messages:
    1
    With this update broke two things, I don't know if they were intended.

    [​IMG]
    There are those white party all over terrain that is not the originally the form of the planet (holes of ships crashing on the planet, drilled holes like this one, etc). They were there when I opened up SE again after the update and keep coming when I keep drilling.

    Secondly, for some reason when I fly in third person I cant look below my ship anymore and the point my camera circles around when I press the ALT-key seems to be a little higher. It makes drilling a lot harder because I just can not know if there is something below my ship I scratch my ship with. When I flew a ship of similar length this effect did not happen, I could look around like I was used to.



    (forgot to mute the vid)
     
    Last edited: Apr 15, 2016
    • Agree Agree x 1
  11. Zanzikahn

    Zanzikahn Trainee Engineer

    Messages:
    46
    I need to check, but it's respawndistribution.sbc or something like that.
     
  12. Kham

    Kham Apprentice Engineer

    Messages:
    478
    Tested now. It's awful.
     
  13. -=Ripps=-

    -=Ripps=- Trainee Engineer

    Messages:
    83
    would be nice to have air vents that save their actions for blueprints :/

    really putting me off working on large spaceships that need intricit airlock systems
     
    • Agree Agree x 1
  14. Baconfist

    Baconfist Apprentice Engineer

    Messages:
    175
    I've just played around a little bit on our DS.
    Stuff I can do after this update:
    • driving around without exploding caused by to dense air
    • moving my character
    • simspeed increase from 0.1 to around 70
    ah and did you mention: you can move now! :woot:

    I like this update :)
     
    • Friendly Friendly x 2
    • Like Like x 1
  15. Echillion

    Echillion Senior Engineer

    Messages:
    1,334
    They may have fixed the piston heads but they need to fix the pistons from spontaneously exploding both on SP and MP even when their off and locked down? Nice job on the cargo ships but are they still in the space pirate faction? and thanks to Rexxar,Malware.Phoenix and Co for their hard work and solutions to the game :tu:
     
  16. Stardriver907

    Stardriver907 Master Engineer

    Messages:
    3,368
    I'm wondering if the cockpit toolbars are reporting the status of functional blocks again. It's always nice to know what's on and off and what setting they're on.
     
    • Agree Agree x 1
  17. -=Ripps=-

    -=Ripps=- Trainee Engineer

    Messages:
    83
    yes they do :p

    [​IMG]
     
    • Friendly Friendly x 2
    • Agree Agree x 1
  18. Carlosmaid

    Carlosmaid Apprentice Engineer

    Messages:
    177
    All right! it seems my server returned to have good simspeed and there are no more rubberbanding on clients! good job keen developpers!
    Everything feels more fluid. Apparently they solved the ships and players braking problem when the game is saved or when a new player tries to enter the server. :carlton:
    We see what happens tonight with 20 players on the server, but for now ... all ok! :tu::tu::tu::tu:
     
    • Like Like x 3
  19. Scorpion00021

    Scorpion00021 Senior Engineer

    Messages:
    1,411
    Kham, I dont think its yet optimized enough for huge worlds like yours. Maybe take a break from your current would and work on designs in SP for a while until it gets resolved?
     
  20. Zanzikahn

    Zanzikahn Trainee Engineer

    Messages:
    46
    That's better.
     
    • Like Like x 1
  21. Kham

    Kham Apprentice Engineer

    Messages:
    478
    Yeah, not interested in single player really. I feel they should never have implemented this system to begin with, but if they were going to then they should have first ironed out the kinks with the character movement system before trying to implement it for ships too. I can't even rotate on the spot with a high sim speed without the ship jittering all over the place. Tried connecting a ship to a station and it took a while for it to even recognise there were two connectors lined up and then when it did it started freaking out all over the place and I had to move away to prevent both the ship and station being destroyed. Got videos of it in action to send on.
     
  22. Stardriver907

    Stardriver907 Master Engineer

    Messages:
    3,368
    Well, then, my only response to that has to be:

    :D:carlton::woot::carlton::)
     
    • Like Like x 1
  23. Ricktor87

    Ricktor87 Trainee Engineer

    Messages:
    49
    Huzzah! Cargo ships have returned, thanks KSH, and Rexxar "since what I was told you had a hand in this feature"

    Time to make my dessy planetary and interstellar. Hypetrain is sated.....for now.... ;)
     
  24. CQ

    CQ Trainee Engineer

    Messages:
    2
    Just tested the game with some friends on server. New world start is ok. Even when we flew at 100m/s it seem to be ok, people don't jiggle and don't drop out though the wall. Keep up the good work!
    Keenswh, when you fix the pistons, rotors and landing gears, i'll buy 3rd copy of the game (second one i bought when you did planets) :p Keep it coming!
    And YAY for the cargo ships :)
     
  25. Nailbomb83

    Nailbomb83 Trainee Engineer

    Messages:
    45
    Yea! Cargo ships are great. A little random factor that they crash on a planet would be cool. I played a survival game a while ago with enabled cargo ships. Was realy fun to see an Cargo hauler hitting an Icelake! Balance was gone off course, I never had to mine again ;-)-

    But what I encountert: I'm building a racetrack on the earth like planet. The performance gets better and better every wheek (SP). Now I added a big skyscrapper from the workshop for a little town part, and it worked realy smooth! last week It took me 1h only to place one of the big skyscappers fromm the workshoop.
     
  26. OfftheRails

    OfftheRails Trainee Engineer

    Messages:
    10
    Am I the only one getting stuttering since the patch? Like this:



    Also, the conveyor system on my saved game has stopped working completely. Fine this afternoon.
     
    Last edited: Apr 14, 2016
  27. Manticore

    Manticore Apprentice Engineer

    Messages:
    189
    Not interested in first. Thanks KSH!
     
    • Like Like x 1
  28. Sigurd Hansen

    Sigurd Hansen Trainee Engineer

    Messages:
    21
    Still 5 seconds delay for solar panel data in the programming block.
     
  29. Nielson

    Nielson Trainee Engineer

    Messages:
    4
    Gotta say that the new patch fixed a lot of problems on our DS server and made it a whole lot more stable. Thanks!

    But as mentioned in the previous patch thread, I really think you guys should aknowledge a bug if you know it's there. I guess it's okay to fix it in the next update, since the game is in alpha, but it would really be nice to hear some aknowledgement from the developers or just a "We're investigating the issues with the recent update", would be sufficient. /rant

    Thanks anyway! :)
     
    • Agree Agree x 2
  30. jc_smo

    jc_smo Trainee Engineer

    Messages:
    2
    Autopilot enable!

    This problem haunts me!
    Now he decided to "activate alone" in the stations, even without having anything that makes them fly!
    HELPPPPPPPPPPPPPPPPPPPPP :(:(:(:(:(:(:(:(
     
    • Funny Funny x 1
Thread Status:
This last post in this thread was made more than 31 days old.