Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[0.1044] World file is corrupted and cannot be loaded

Discussion in 'Bug Reports' started by zorrobyte, Aug 21, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. zorrobyte Trainee Engineer

    Messages:
    13
    World file is corrupted and cannot be loaded on all saves and new game including "Empty World".

    Verified Steam Cache

    Disabled all mods

    Issue persists

    ----
    Reported FIX by MrKoronas (Thanks for the possible solution and report!)

    1. <ol style="line-height: 20.7999992370605px; background-color: #f7f7f7;">
    2. Goto C:\Program Files (x86)\Steam\SteamApps\common\SpaceEngineers\Content or wherever you stored it
    3. Delete folder named Data
    4. Verify game cache to redownload missing files
    </ol>MODS reported to cause a crash
    1. <ol style="line-height: 20.7999992370605px;">
    2. Small Ship Glass: http://steamcommunity.com/sharedfiles/filedetails/?id=297538470&amp;searchtext=small+ship+glass
    3. Endless cargo ships
    4. more ships mod
    </ol>Reported replacement mods (working)
    1. Small Ship Glass: http://steamcommunity.com/sharedfiles/filedetails/?id=302919740&amp;searchtext=small+ship+glass
    ---
    Nuclear option (if nothing seems to work). This WILL delete ALL saves and other data!
    1. Delete (or move to desktop for backup) C:\Users\USERNAME\AppData\Roaming\SpaceEngineers
    2. Delete (or move to desktop for backup) C:\Users\USERNAME\Roaming\SpaceEngineersDedicated
    3. Uninstall SE via Steam (Right click SE, Delete Local Content)
    4. Delete C:\Program Files (x86)\Steam\SteamApps\common\SpaceEngineers
    5. Reinstall SE and play
    Additionally, you may choose to unsubscribe from any Steam Workshop/Mods before/during/after reinstalling if issue not resolved.
    ---
    Please upload logs!
    1. The logs are located here: "C:\Users\[YOURCOMPUTERNAME]\AppData\Roaming\SpaceEngineers\SpaceEngineers.log" or simply paste this into your Explorer: %appdata%\SpaceEngineers\SpaceEngineers.log
    2. Copy+Paste SpaceEngineers.log contents into Pastebin at http://pastebin.com/
    3. Post link to log in this thread
    If log too large to copy/paste into pastebin, feel free to put on Dropbox/Skydrive/Google Drive and share link in post OR delete SpaceEngineers.log and restart the game, get the error and check newly created log file. It should be much smaller and able to be pasted into pastebin.
     
  2. aoikazega Trainee Engineer

    Messages:
    5
    Same issue, even on new maps
     
  3. DanDuncombe Apprentice Engineer

    Messages:
    333
    Yep, happens to me.
     
  4. Wolf76200 Trainee Engineer

    Messages:
    68
  5. zorrobyte Trainee Engineer

    Messages:
    13
    Resolved by reinstalling Space Engineers from Steam. Saves are still present and loading correctly.

    Wonder if this will resolve my issue with joining MP games and "World file corrupted" issues I have been having as well.
     
  6. GreenStepper Trainee Engineer

    Messages:
    52
    lol ive got the same :woot:D
     
  7. aoikazega Trainee Engineer

    Messages:
    5
    Thanks zorro, downloading the 828mb file from steam.
     
  8. DanDuncombe Apprentice Engineer

    Messages:
    333
  9. GreenStepper Trainee Engineer

    Messages:
    52
    Reinstalling arent working, i mean the error appears every time on every map
     
  10. Littleturn Trainee Engineer

    Messages:
    61
    I get the same error. And I thought I broke it when modding the game ^^
     
  11. Tipiak Apprentice Engineer

    Messages:
    367
    You must be kinding me.

    How can you EVEN release an update with such a MASSIVE break?! What the hell?!


    DO YOU EVEN TRY YOUR F*CKING UPDATES before releasing them???

    Do not blame yourself, I said myself after the crappy 1.043 release that I would disable the auto-updates from steam. Guess what? I forgot.
     
  12. Koenigstiger Trainee Engineer

    Messages:
    4
    Same error on every World,even without mods. Hotfix please :D

    @Tipiak : Calm down please.
     
  13. Capsuna Apprentice Engineer

    Messages:
    117
    Same problem... Woot
     
  14. aoikazega Trainee Engineer

    Messages:
    5
    Issue still persisting, even after deleted steam local files and appdata/roaming files and re-downloaded.
     
  15. Tipiak Apprentice Engineer

    Messages:
    367

    No.

    I waited 19 hours to came back to play, 5 days to have time to play.

    Now, I can't play at ALL. I can't EVEN launch a new game. F*ck it. And f*ck your "that's an alpha". That game was running 20 hours ago.



    Why does an update whose job is to improve the performances corrupt every games?! That's really, really shitty.
     
  16. Koenigstiger Trainee Engineer

    Messages:
    4
    First world problems...

    I'm sure they will fix this as soon as possible,they are humans as we are and they're making mistakes,as we are making them.

    "If debugging is the process of removing bugs. Then programming must be the process of putting them in."
    - Edsger Dijkstra
     
  17. Mortisfire Apprentice Engineer

    Messages:
    148
    Question: did all of us add and use the spherical gravity mod?

    Perhaps that changed some files? Anyone try a clean install yet?
     
  18. Naut Apprentice Engineer

    Messages:
    113
    Same issue here, even after reinstalling.
     
  19. Floki Apprentice Engineer

    Messages:
    247
    Dude, it literally is an Alpha, this is just how things go. Feature completion does take priority over playability.
    This is Early Access though, and Keen has a good record of releasing hotfixes for bugs like this within a day.
     
  20. Naut Apprentice Engineer

    Messages:
    113
    No mods at all here.
     
  21. Koenigstiger Trainee Engineer

    Messages:
    4
    No,I didn't

    Yes,but dont solve the problem.
     
  22. Doc Trout Trainee Engineer

    Messages:
    11
    These things happen you know, to literally EVERY developer. There's no way they're going to just leave it either, these guys know what's going on. Seriously, I bet its one simple line of code they gotta just go in and change one value or something.
    You're really over reacting and really being a whiny jerk because of a simple honest mistake. And yeah it is in alpha and if you expect to play a game in alpha without bugs you might as well try cutting a tree down with a piece of paper, then blaming the paper for not being strong and able to do the impossible.
    Grow up kid, your the only one screaming about this.
     
  23. DuneD Junior Engineer

    Messages:
    948
    They'll probably release a hotfix in a few hours, be patient.
     
  24. Gooplux6 Apprentice Engineer

    Messages:
    161
    same issue, i can wait i just dont want to lose my worlds, and tipiak, i understand where your coming from but yelling won't solve anything and it could have been a problem with uploading to steam, or some glitch in the code that they changed last minuet, we just need to be patient. And i know yes this isn't an excuse for you but it is an alpha, alpha is when they add features, then beta is when they do bug fixes to ensure this, its done this way to make the bug fixing later to ensure that more bugs don't arouse. if it were beta i would agree 100% with you
     
  25. Naut Apprentice Engineer

    Messages:
    113
    Just get out of here. Thats a bug report section, not kindergarden.
     
  26. Mortisfire Apprentice Engineer

    Messages:
    148
    Also, related:

    [​IMG]
     
  27. Lyndeno Apprentice Engineer

    Messages:
    115
    I'm having this issue too, but only on some existing worlds. Would it be because the world that won't load has a small ship gravity generator mod?
     
  28. Tipiak Apprentice Engineer

    Messages:
    367

    Oh yeah, so I'll build a car, sell it, but without even trying it to see if the motor launch. Don't care, you paid. So get your sh*t yourself. Right?





    Alpha? "Dude", that game is way far from an alpha. It has reach the Beta level for a long time.
     
  29. Naut Apprentice Engineer

    Messages:
    113
    No.

    I didnt use any mods in my save.
     
  30. Cheesey Trainee Engineer

    Messages:
    11
    My friend, if you wish to play a stable game without bugs then read the description of it before buying. This game has the early access status, this means it is still in development, and those who join the Alpha/Beta are meant to do those tests you where talking about. And of course they test the updates before releasing, but even then there is no promise that there are not going to be any bugs. Those who are familiar with software development will understand. So keep calm and patient.
     
Thread Status:
This last post in this thread was made more than 31 days old.