Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[01.043.015] Refinery/assemler/connector inventories loosing items

Discussion in 'Bug Reports' started by Ouchtime, Aug 16, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. MegaMiner Junior Engineer

    Messages:
    625
    Also havng this problem. When moving stacks from back of queue to front it just deletes the item.
     
  2. squisher Trainee Engineer

    Messages:
    88
    1. dont touch the front of the queue in a refinery while its running (or just turn the refinery off before you move the items)
    2. dont touch any ingots in the assembler that are being used (or just turn the assembler off before you move the items)
    3. dont drag a stack of items to any container if the resulting volume is more than the container can hold
    4. dont drag a stack of items to the same container if the volume of the stack you are moving is more than the free volume in the container.
    5. never double click to transfer items. (if your mouse moves a pixel, problem 4 can occur.)
     
  3. mredge73 Apprentice Engineer

    Messages:
    104
    Explains why I lost thousands of construction components moving them when I accidentally tried to put them in a fullish small container instead of a large container.
     
  4. RavynKnight Apprentice Engineer

    Messages:
    317
    Thank you for this list.. so if you turn the refineries off you can put ore into the first slot without it deleting the ore? I still have yet to test this (no stone to test it with yet) mainly because i have been too busy building and welding my base lol

    I highly doubt it.. its too close to patchmas we just need to watch ourselves while moving inventory around till it gets fixed.. hopefully the patch this thursday will fix it cause i'm sure its going to be in the bux fix portion.. but yeah.. they tend to do "hotfixes" fri, sat, and sun and that seems to be it..
     
  5. Vervekke Trainee Engineer

    Messages:
    3
    I got the same issue here too.
     
  6. Spacedweller Trainee Engineer

    Messages:
    45
    Can confirm this bug also, noticed that my ship welders consume double the parts. Load up 64 solar panel component, proceed to weld with welding ship. You only have 32 parts installed, rest are disappeared into bit heaven.
     
  7. Bolisaris Trainee Engineer

    Messages:
    89
    Yeah I thought this was normal but 20,000 steel panels for a small floor (heavy Armour) seemed excessive. Must be a bug.
     
  8. And1 Trainee Engineer

    Messages:
    19
    Tested on actual Patch (1.044.XXX) and the refinery problem is fixed! (first Test)



    False!!

    Stuff moving lets disappear it!

    Sucks...
     
  9. Rioclaw Apprentice Engineer

    Messages:
    132
    Can anyone else confirm if this bug is still happening or not?
     
  10. Syncaidius Junior Engineer

    Messages:
    824
    Its still happening...
     
  11. JUUD0LF Trainee Engineer

    Messages:
    18
    I can. It does still happen and it has been happening since Update 01.043. Just tested it and when I tried moving ore around in a Refinery, the ore I moved was in fact disappearing. I did some testing and I noticed that the bug is occurring only in Survival mode, both in single- and multiplayer games.

    I tried to replicate the bug in Creative mode, but the ores I had in the Refinery didn't disappear, they worked perfectly. But back in Survival, the bug was there again, both in old and new Survival games. I also tested if the disappearing of ore was related to ores in inventories waiting for free space in Refineries. The answer to that is no. Even when there's no ore in any inventory that can hold ores, the bug occurs. Simply trying to move ore to any slot in Refinery makes the ore vanish, including when trying to put two stacks of same ore to one slot. This includes having only one type of ore in a Refinery and then trying to move even just that one type of ore alone.

    As for the Assembler losing items, can't say, hasn't happened to me yet. My inventories aren't full so I can't say if the items made in Assemblers disappear when there's no more room. But I do know that when the inventory for finished items in Assemblers run low/out, it moves the created items to an inventory that can hold such items and has free space. But what if losing items is related to just that? As in when there's no free space left at all in the system but the Assembler still tries to move finished items out of the Assembler, resulting to items just vanishing? If that's not what's happening to others, then I can't say what's wrong. Moving items directly in inventories does not make them disappear for me.

    Additionally, I tested if mods had anything to do with this issue and the answer is no. The bug occurs even in vanilla games.

    I hope this info helps.
     
  12. Hyomoto Apprentice Engineer

    Messages:
    244
    It appears to have been fixed at least partially in my world. Considering how ready it is to reproduce, at least moving items within the same inventory doesn't seem to cause it anymore.
     
  13. FishyFrags Trainee Engineer

    Messages:
    26
    I didn't see this thread. I created one this week

    http://forums.keenswh.com/post/iron-disappears-when-in-refinery-single-playersurvival-7046041?pid=1283995181#post1283995181
     
  14. Robinson C. Senior Engineer

    Messages:
    1,135
    <div>I can confirm the bug is still (Update 01.044.10) present ...

    </div>
     
  15. Syncaidius Junior Engineer

    Messages:
    824
    Bump to make sure this gets fixed sooner rather than later. Latest follow-up patch doesn't mention any fix for it.
     
  16. JUUD0LF Trainee Engineer

    Messages:
    18
    Well this IS an issue that makes the game very frustrating, maybe even partially unplayable.

    Why?

    Imagine this scenario: you are in your large ship or base. Then you decide to add a new Reactor. But as you start making the components, there's not enough materials to make all the components, for example, Gravel to make Reactor Components. So then you check your Refinery. The Stones are last in the Refinery queue. So what now? Either you make ALL the other ores in the queue disappear or simply wait that all the ores are finished being processed. Or imagine that scenario, but instead of needing Gravel, you're running out of Uranium Ingots and you have no other power sources.

    Unless moving the ore(s) to another inventory out of the Refinery keeps them from disappearing (which I haven't actually tested, might look in to that), you're going to have to play the waiting game.

    Period.
     
  17. Perriax Trainee Engineer

    Messages:
    8


    I can confirm I still have this bug happen with this new update.
     
  18. FishyFrags Trainee Engineer

    Messages:
    26
    Looks like it's still here.

    I'm only going on the game to check if this bug is still here or not!

    Now one of my other refineries doesn't work!!!!! I'm beginning to think that I wasted my money on this game Keen !!! FIX IT
     
  19. ZGralewski Trainee Engineer

    Messages:
    15
    I stopped playing too.
     
  20. swiify Trainee Engineer

    Messages:
    33
    Any news on a fix?

    Currently our server lives on 1.42 which is nice and stable, so while a feature update is nice theres not much purpose if the community cant use it.
     
  21. JUUD0LF Trainee Engineer

    Messages:
    18
    Well it IS possible to play with the bug bugging us (pun intended), but it's rather tedious. What I've heard is that having the Refinery/Refineries turned off, them MANUALLY fill them up with ores you need and then turning them on again. After that, it's just keeping an eye that the Refineries don't get empty enough to take in other ores.

    I should also mention that the bug is so frustrating that most of my friends stopped playing the game and they'll probably stay out until the bug is fixed. So yeah, it IS a notable bug and frustrating especially when you start a new Survival game and have to work with only one Refinery.

    Hoping to see this bug fixed in the next update!
     
  22. Phand Master Engineer

    Messages:
    9,650
    Hi,

    it was believed that it is fixed already. Seems like the fix did not work. Going to investigate more. Sorry for inconvenience. :(
     
  23. JUUD0LF Trainee Engineer

    Messages:
    18
    Hey wait a minute, NOW it's fixed! That's a bit weird, since earlier today the bug was still happening to me and Steam hasn't notified me of any updates. Either way, the bug is gone now! http://tinyurl.com/m9m6v79

    Just out of curiosity, do you use rolling updates (as in only a certain amount of people get the update to keep the servers from being overloaded) or does everyone get the updates right away? Or are updates something Steam handles in their own magical ways? Rolling updates could explain why the bug was still occurring for me.

    Either way, anyway, any hay, the bug is gone! Now I can get my peeps back in the game! Thank you!
     
  24. FishyFrags Trainee Engineer

    Messages:
    26
    Still not fixed. Also the when I place items first in the refinery the already placed item which was first just carry's on getting refined instead of the item you placed in the first box

    I feel like I've wasted money on this game. What's the point in playing it when it's been like this for quite a few weeks.
     
  25. spamenigma Trainee Engineer

    Messages:
    93
    The game isn't finished yet! Yes there are a few broken things, and things that need attention..there's also a very good game we can play that's still a work in progress. Stop bitching that an unfinished game doesn't play like it is finished!?!?
     
  26. FishyFrags Trainee Engineer

    Messages:
    26
    Shut up
     
  27. spamenigma Trainee Engineer

    Messages:
    93
    :rolleyes:
     
  28. JUUD0LF Trainee Engineer

    Messages:
    18
    You must be new to EAGs. But you must admit that spamenigma is right: the game is not yet officially complete. Think it like Minecraft. MC also started with Alpha- and Beta-stages until Mojang officially launched the game, as in before it could have been called "Minecraft 1.0." Same thing is happening with Space Engineers: the game is in alpha-stage which means it's being developed as time goes on. Each patch add or changes something, which means there's bound to be some bugs.

    Now, as for the Refinery problem, are you playing in an old game? Trying to make a new game MIGHT fix it if the old server was made before the bug showed up. Another thing you could try is uninstalling any mods you have, run the SE and the save file where the bug occurs, then reinstall the mods (not going to guarantee that would work tho). If those won't help, then maybe give some info for the developers, other than just telling that "it's not fixed?"

    No offence, I understand your frustration, but acting rude and just demanding the developers to fix the bug for you without giving them any place to start from is certainly not going to fix the bug.
     
  29. Leanes Trainee Engineer

    Messages:
    2
    Playing on local singleplayer and bug is fixed for me :thumb:
     
  30. Spamasaurus Trainee Engineer

    Messages:
    16
    Same thing happens to me. (01.063.008) 64-bit 2015.01.02 08:37 Win7 while playing on a dedicated server

    Have various ores in refinery
    click and drag ore from anywhere in the queue and place it at the front
    ore stack gets deleted
     
    Last edited by a moderator: Jan 4, 2015
Thread Status:
This last post in this thread was made more than 31 days old.