Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[01.053] [Large drills] [Lag]

Discussion in 'Bug Reports' started by Royco_nl, Oct 23, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. demolish50 Senior Engineer

    Messages:
    1,434
    I'm testing this on my testing Dedicated Server which is a physical I7 4790K with only me on it. I'll report back shortly.
     
  2. Kuu Lightwing Senior Engineer

    Messages:
    1,503
    Well, I'm not sure if it's possible to move to SSD SE only, and my SSD is not quite big to move the entire Steam library to it. Either way, it seems like we kinda found the bottleneck and I hope that devs could fix it later.
     
  3. Coreinsanity Apprentice Engineer

    Messages:
    188
    lol, I have enough ram I could try that for the game and see what happens later, I guess. I know you're mostly joking, but I am curious.


    Also I just noticed you said it didn't have much disk IO when you tried my world, so I'm at a loss as to what it might be now.
     
  4. Xakthos Apprentice Engineer

    Messages:
    220
    I tried this as well. I used his drill without issue. Then I copy and pasted a blueprint for one of mine. It started well then died after about 20 seconds. I think the asteroid is too small to see the problem on the stronger systems for the 25 drill ship. With more drills I see the problem, without more drills I think we'd have to increase size of asteroid.
     
  5. demolish50 Senior Engineer

    Messages:
    1,434
    Reporting Back:
    With my world I was able to cause "no response from server" after mining for about 20 seconds with a 27 drill miner. Received KB close or near 0.0. Even after I stop mining it takes a few seconds for things to "catch up". Could not exit cockpit for about 30 seconds. I was the only one on my test server and I had just done a fresh restart. My Floating Objects count is set to 48 yet I can produce thousands before they clean up. I am on an SSD (I don't think this is an IO issue anyway). As they clean up the server becomes responsive again.

    I have just tested with my world copy from my live with mods and SESE and I have also tested vanilla, no mods and no SESE and the issue occurs with both and behaves the exact same way. I can provide fraps, access to the servers, whatever is needed.

    Again:
    Test Server specs:
    Physical Computer:
    I7 4790:
    8GB ram
    SSD

    Client:
    I7 2600k @ 4.6
    16GB RAM
    SSD
     
    Last edited by a moderator: Oct 28, 2014
  6. Coreinsanity Apprentice Engineer

    Messages:
    188

    See that's odd, though. My CPU isn't the best these days, but an i7 950 is still pretty good.

    I'll try it again after cleaning up some of the stuff running. Admittedly, I had another game running during that test, out of necessity, but it barely uses any resources (It's like a 15 year old game in window mode, an old MMO).
     
  7. lord-boo Trainee Engineer

    Messages:
    94
    as i posted before, i already had a ramdrive running with SE and the save, both symlinked to my ssd


    i am going to increase the drill amount on the 1 asteroid testworld to give a ~ amount of what my computer can handle
     
  8. Soulthule Apprentice Engineer

    Messages:
    362
    I didn't see this thread so I basically started a different one. My server experienced the same issue.

    It is clearly not CPU related as I never saw over 23% utilization of the cpu.

    We had it with a smaller drill. 3 x 6 and several other smaller miners.

    However, I don't know if it is just coincidence, but I had also made changes in the server configuration utility on the map size. I put it back to default map size and the issue stopped with the hang and communication stall between the server and the client. Granted most of the posts I see here are using a higher number of drills and I haven't tested that. For now it seems ok. Might be another rabbit hole...

    I notice on some screen shots there appears to be game information running at the top left corner. What is the command to turn that on?

    Core I7 2600 8 Cores running @ 4.0ghz
    16 gigs of G. Skill PC3-12800

    By the way - The server rarely using more than 1.2 gigs of memory. The I/O is anemic.

    I thought the purpose of paying $20.00 was our pay to help the developer give accurate bug information to improve the game. It is clearly not because of "low core cpus" and by mass posting changes from this version to the last along with all of the other bugs

    -Sensors with doors don't work
    -Doors are cracked and not closed all the way
    -Sounds missing along with sound degradation
    -Group Blocks (My favorite) - Nice to have 30 of them in a ship disappear only to have you recreate them and then disappear after 10 minutes.
    -Cooperative mode doesn't work

    ~But we did get the spot lights and lights light source location fixed. :D
     
  9. Xakthos Apprentice Engineer

    Messages:
    220
    The command for the data screen is Shift-F11.

    The door issue is Render interpolation issue. If you turn that off it goes away.

    Can't help with the rest unfortunately.
     
  10. lord-boo Trainee Engineer

    Messages:
    94
    i increased floating ammount extremely to about 30.000 and it may have taken longer until sim speed started to drop... but i am not sure..... with SE and EmptyWorld with 1 Asteroid both stored on a Ramdrive and symlinked to the normal folders on my SSD, i was able to handle 35 drills with horrible simulation speed of 0.1-0.2 (still cpu and i/o rate and gpu no peaks) so i still dont get it :) i am done with testing for today and i hope for useful keen response SOON!

    btw. i dont care for rocket launchers, doors, messed up assembler inventorys and not working coop, rotators or whatever is bugging too... this MUST be priority to fix! its a real pain!

    (cooperative mode works for me when u build a new assembler and have the old set on coop and cleared all the inventorys, the new one is working as a master and producing like shit... another bad move is that cooperating assemblers take the first item of the qeue which means the master assembler always stops producing when he is in the middle or even ready with 1 item and gives the work away)
     
    Last edited by a moderator: Oct 28, 2014
  11. Grombutz Trainee Engineer

    Messages:
    10
    So, what you say is that my 4 core (8 threads) FX 8120 with 3,1Ghz is not enough for 49 small (!!!) drills, where it was perfectly enough and went absolutely smoothly before that recent update?
    Sorry, but that is an absolutely unreasonable post of yours.
    Edit: I may not know much about IT-Stuff, but I do know one thing for sure: The only thing that changed between working fine and not working at all was the latest build and what you told in your post was therefore not helpful nor reasonable at all.
     
    Last edited by a moderator: Oct 28, 2014
  12. demolish50 Senior Engineer

    Messages:
    1,434
    Here is a screen shot of my "test" server. To the left of the red line is pre mining cpu activity to the right is after mining has started, its not in the exact position but you get the idea. Every drop in the CPU the client receives "server not responding..." This is 100% vanilla, no mods, vanilla server. Received KB in game from shift-f11 shows less then .5 a few seconds after mining has started. The ship is a large ship with 27 drills.

    Nothing else is running on this machine I can replicate this on demand.

    [​IMG]
     
    Last edited by a moderator: Oct 28, 2014
  13. hellokeith Apprentice Engineer

    Messages:
    335
    I have been playing with this on my local LAN. Dedicated Server is a i7-860 (quad w/ HT), 16GB RAM, and an SSD.

    Easystart 2 with all defaults in Creative mode. Just 1 client connecting.

    With 21, 25, and 49 large drill configurations, three times had same result: after a while of drilling I start getting No Response messages, and then eventually (10-20 mins into game) the Server exe crashes.

    Code:
    [2014-10-28 12:24:17] Log session started
    [2014-10-28 12:24:17] [2,2] Log session ended
    
    Code:
    [2014-10-28 12:24:17] [3,2] LogOff()
    [2014-10-28 12:24:17] [2,2] AsyncDisconnect()
    
    Code:
    2014-10-28 12:24:17.505 - Thread:   1 ->  Exception occured: System.AccessViolationException: Attempted to read or write protected memory. This is often an indication that other memory is corrupt.
       at hkpWorld.stepDeltaTime(hkpWorld* , Single )
       at Havok.HkWorld.StepSimulation(Single timeInSec)
       at D1B6432AAEEF40F9D99F69835A7B23F5.553E5847558E9D51837A1071E2207F67.Simulate()
       at AAC05F537A6F0F6775339593FBDFC564.D580AE7552E79DAB03A3D64B1F7B67F9.F672BBF9E192151CE8FD7E91E62B997D()
       at AAC05F537A6F0F6775339593FBDFC564.D580AE7552E79DAB03A3D64B1F7B67F9.EC90B1C44E3C361983D093F355FF0CC8(MyTimeSpan 9916A9BA14FB0BB1A36908E2E8C15A74)
       at B337879D0C82A5F9C44D51D954769590.B3531963E948FB4FA1D057C4340C61B4.C5B38F0893BB80ADC59B7419C552DAC2()
       at 168638249D29224100DB50BB468E7C07.7BAD4AFD06B91BCD63EA57F7C0D4F408.2457E95BE2F0D1F1A4A009B2B1DBBDA4()
       at 168638249D29224100DB50BB468E7C07.398AD1E315E6E4D570C424BD0D168FC1.858DA51EB20785A82D9A03614304088A.0187A29A24275EC024A192E7E235CC2E.9C41E76459B99591F991CBA0833BD17E()
       at 168638249D29224100DB50BB468E7C07.6E0E814918D8AD6B2DC9CA5005102256.2A59CEF86AFCC8A50BB274B38ABC812B(9AA159E6C22F64A542015EED199D04B9 148A5BA193EB90E55F5E805EF96CAD48)
       at 168638249D29224100DB50BB468E7C07.398AD1E315E6E4D570C424BD0D168FC1.2A59CEF86AFCC8A50BB274B38ABC812B(9AA159E6C22F64A542015EED199D04B9 148A5BA193EB90E55F5E805EF96CAD48)
       at B337879D0C82A5F9C44D51D954769590.B3531963E948FB4FA1D057C4340C61B4.246E732EE67F7F6F88C4FF63B3901107(Boolean FF8E4184144DE7049FF5EC07D594DAB6)
       at 83BCBFA49B3A2A6EC1BC99583DA2D399.49BCFF86BA276A9C7C0D269C2924DE2D.523C8831DA5DAB3A19F6D33A2C6437B5()
       at 83BCBFA49B3A2A6EC1BC99583DA2D399.49BCFF86BA276A9C7C0D269C2924DE2D.26A7ABEA729FAE1F24679E21470F8E98(String 8BF03A34188889479CB413E58490FC37, String 48C45E39212AAA2B19C972DA9195F48A, Boolean 7AC487C1B445CD9F481CF5FE695A7CEA, Boolean 4292A7A4DACAF323E558B7E11DD3CF00)
       at 83BCBFA49B3A2A6EC1BC99583DA2D399.49BCFF86BA276A9C7C0D269C2924DE2D.0D8AAA624C2EEA412F85ABB3AEFAF743(String[] 954514EA42AFFE4302240CE14E5D6683)
    2014-10-28 12:24:17.506 - Thread:   1 ->  Hiding window
    2014-10-28 12:24:17.716 - Thread:   1 ->  Network readers disposed
    2014-10-28 12:24:17.716 - Thread:   1 ->  Logging off Steam...
    2014-10-28 12:24:17.716 - Thread:   1 ->  Shutting down server...
    2014-10-28 12:24:17.758 - Thread:   1 ->  Done
    2014-10-28 12:24:17.763 - Thread:   1 ->  Hiding window done
    2014-10-28 12:24:17.763 - Thread:   1 ->  Showing message
    
     
  14. demolish50 Senior Engineer

    Messages:
    1,434
    oh look its the same crash I get sometimes although I had not made a connection to someone mining...
     
  15. Xakthos Apprentice Engineer

    Messages:
    220
    Well honestly a lot of things can trigger that type of error message but right now drilling seems to be one of the more common reasons.
     
  16. NathanTheSpaceSurvivor Apprentice Engineer

    Messages:
    228
    Tested with my advanced mining craft. Small ship, 20 drills in total. They are set up with 2 on the front and 2 on each side.With all the 20 drills drilling, I can get a bit of lag, but I still get 15-20 FPS. I have a 1.70GHz core, but for some reason it never uses more then 0.70GHz. Didn't test with large drills.

    Factors that probably cause it:
    Regular drill lag
    Asteroid editing lagNew sound bug(01.053), that certainly also affects drills, which is the main reason of all the lag while using hand tools too.

    edit:
    Wait a second.... This means..... I CAN GET ALL THE ORES!!! HAHAHAHAHAHAHA!!! "evil laugh"
     
    Last edited by a moderator: Oct 28, 2014
  17. Morilibus Apprentice Engineer

    Messages:
    199
    Just wanted to add. I have my OS, steam, the game, and the save file all running off a SSD and still have this issue. I'm not sure if that is the only factor here. Doesn't the game load the save to memory? and only writes to the disc during a save? So if it is accessing the Hard drive I don't think it would be to modify the save would it?
    I'm not noticing any part of my system that is struggling during my freeze ups, other than one core of my CPU which goes to about 80%. Other than that I'm only seeing a spike to 100KB/sec on the SSD, which is practically nothing. When my GPU is stressed my computer sounds like a jet engine, so I don't think it's the GPU or I would notice it try to take off. I'm noticing a bit of network activity from Space Engineers. Not quite sure why it has to be sending/ receiving anything when I have an 'offline' world loaded... Perhaps:
    "Hey http://www.spaceengineersgame.com/, this is SpaceEngineers.exe, how are you?"
    "I'm fine, feeling buggy today?"
    "yeah just a bit :("
    "Awe, :("
    Hmmm, probably not.
    Here are my specs. Log has been submitted many times through the automated crash window that pops up after a crash. available here via pastebin. http://pastebin.com/3bADK55j
    CPU: i7-4770K @ 3.5 GHz
    Ram: 16.0 GB
    GPU: AMD Radeon HD 7790
    Game Installed on: SSD
    Save location: SSD
    Experienced in: SP 64bit using about 25 Large Drills on an asteroid in a new world created to test this issue.
     
  18. NathanTheSpaceSurvivor Apprentice Engineer

    Messages:
    228

    :rof: yeah. Mine now sounds like a jet engine even if it is at 30% CPU and 40% Disk usage

    (source=task manager)

    But when I launch SE the sound it priduces spikes up and it sometimes overheats, as in the outer surface becomes hot. I should put a radiator on it one day(when we finally will be able to do so)
     
  19. demolish50 Senior Engineer

    Messages:
    1,434
    holy crap this needs to be fixed.
     
  20. iansan Trainee Engineer

    Messages:
    2
    I agree. Very game breaking for anybody who plays survival.
     
  21. jaaz81 Trainee Engineer

    Messages:
    2
    I got curious, so I took my large driller out and purposefully induced the "lag" in a local game. I watched the inventories of the drills to see I was getting next to nothing.

    Next I took the driller and drilled until the frame rate was affected, switched off, pulled away, then got out of the pilot seat and flew into the hole. It would seem all the resources I was supposed to be getting were floating there in the crater, ignoring the objects in space limit (I turned it down after discovering the lag issue and seeing glints of ingots in the large drill hole), and disappearing at a tremendous rate.

    So it's less lag and the game putting resources where they used to not go? The drills do grab some ingots, but a vast majority of them end up floating, thus why the CPU spikes and the game slows down. While I did generally get good hauls with little to no problem using hand and small ship drills, the large ones obviously break survival now by their (failed) handling of the ingots.
     
  22. lord-boo Trainee Engineer

    Messages:
    94
    my 49 small drills ship which was working laggfree in .52 ist just freezing @ local test without bringing any cpu core to 100% and having everythign stored on an ssd and the ammount of floating stones is not too big i think.

    and dont tell me 49 is not reasonable... this is my main drill ship... i loved it :(
     
    Last edited by a moderator: Oct 29, 2014
  23. ObjectZero Apprentice Engineer

    Messages:
    361
    49 is a lot of drills but I have a small drill ship with large drills on it and even it causes LAG. sure it does not take the server that long to start back up but means if I drill everyone else on the server can't place blocks while I'm drilling. Everyone on my server has not drill for this week unless it's small ship drills and very few of them. Which really isn't all that much fun some of use since we've worked hard to get our larger drilling rigs built.
     
  24. demolish50 Senior Engineer

    Messages:
    1,434
    Can I have 52 back?
     
  25. Royco_nl Trainee Engineer

    Messages:
    29
    So, tomorrow is patchday usually, I sure hope they found a fix by then, eventhough I'm allready really dissapointed it has taken this long, I hope they acknowlege this is something that needs top priority...
     
  26. NathanTheSpaceSurvivor Apprentice Engineer

    Messages:
    228
    my small miner with 10 drills works perfect:

    reminder to self: do not scrap the little tiny ships when you make the huge ones. put them in your space museum ready to serve as backup.
     
  27. Xakthos Apprentice Engineer

    Messages:
    220
    Or they do like a lot of sysadmins in my business; quietly fix it then go 'what bug? there was never any bug, it must have been your fault'.
     
  28. Soulthule Apprentice Engineer

    Messages:
    362
    Hmm...odd...I hear crickets in the background from the developer.

    I hope they borrowed IBM's Deep Blue Supercomputer to work with large drills as we know its as simple as not having enough cores to play the game correctly. :rolleyes:
     
  29. PT Trainee Engineer

    Messages:
    60
    Yesterday I have checked what is actually happening when huge lag spikes happened. The first thing to point fingers at was "a big miner".
    So I tested it out on a server running which runs on a system that outperforms most servers.

    The miner had 31 large drills (not big miner at all), scraped off the first layer of rock in a pulsing way (right click), this works for a little, but if you do it too fast, lag appears for anyone accept the one mining. Then just a normal hole, like constant for 5 seconds.. and you saw the sim speed drop to 0.7 and sometimes even 0.65 (normal is 0,8 with 12 players online doing stuff at that time) and after the 5 seconds it wouldn't drill anymore, and the sim speed started to raise up quite fast. People starting to have nonstop lag, and the sim speed of me (the miner) went to 1.10. All clients would freeze for quite some time.

    After 5 to 10 seconds the sim speed would go back to normal again, and everything functioned like normal.

    So 5 seconds mining ends up in about 30 seconds lag for everyone. Even when the miner stops mining, it will continue to lag for a while until all is fine again.

    My FPS didn't really drop (between 50 to 60 fps when mining, High settings)


    Does this sound like they changed stuff so not every client updates the astroids when someone mines an astroid (meaning the huge sim speed drop for everyone like we had before)?

    It hasn't been this shitty before for sure.
     
    Last edited by a moderator: Oct 29, 2014
  30. demolish50 Senior Engineer

    Messages:
    1,434
    A lot more floating objects are hanging about. If that is because they are not deleting fast enough or not being sucked into the drills I don't know.
     
Thread Status:
This last post in this thread was made more than 31 days old.