Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[01.153] "Stable" - Random crashes (memory related)

Discussion in 'Bug Reports' started by V_quinha, Oct 4, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. V_quinha Trainee Engineer

    Messages:
    61
    Basically what the title says, when placing blocks the game crashes. Can someone at least confirm this? Repaired the save with SE toolbox. Copy pasted my ship into a new blank world... still happening.

    Sometimes there's logs, sometimes there isn't.

     
  2. Kagee Trainee Engineer

    Messages:
    81
    I had the same issue. Game crashed to desktop, having this line in LogFile. It happened first ~4 Days ago in different time intervals and I couldn't determine a specific action causing it.
    At first I didn't want to start a Thread, because this seems to be a Hardware-Problem on my PC, but maybe it isn't.
     
  3. I23I7 ME Tester

    Messages:
    3,827

    Hello so the crash is happening when copy pasting your blueprint into your world correct?

    Thanks!
     
  4. V_quinha Trainee Engineer

    Messages:
    61
    Thank you for the response.

    No. This is happening when placing vanilla armor blocks onto my ship in creative mode, singleplayer. Not every time, but happening more and more and more. At this point I had to stop playing since I was staring at the loading screen more than I spent time in game.

    Hope you'll manage to find out why the game tries to access memory it shouldn't when nearing the limit of the RAM (that's what it looks like at least).
     
  5. I23I7 ME Tester

    Messages:
    3,827
    Would you kindly share your ship please? You can upload it to the workshop and i will see if i can reproduce your issue with it.

    Thanks!
     
  6. V_quinha Trainee Engineer

    Messages:
    61
  7. I23I7 ME Tester

    Messages:
    3,827
  8. V_quinha Trainee Engineer

    Messages:
    61
    So how do I pronounce your name? Is it Ren? Since I'm guessing you'll be my new favourite person on these forums.

    Anyway, it seems I've hit some sort of complexity limit in the game:

    In the original save (modded), so with engines, gyros, etc. Functional ship. It crashes when adding armour blocks.

    In the save I've uploaded (no mods), so ship not functional. I can add armour blocks still. After that I tried to add about 500 gyro's to up the complexity and managed to recreate the problem three times in a row now.

    I'm not running out of memory by the way. I get that too sometimes and the game freezes, but that's usually after an hour or so of play. This error seems unrelated to that.

    http://steamcommunity.com/sharedfiles/filedetails/?id=775396938
     
  9. I23I7 ME Tester

    Messages:
    3,827

    Hey,

    You can call me RED i write my name in L33t which was a old geek/nerd lingo used in 90s anyway i was able to boot up your save. That ship is really huge and i was able to add around 1000 gyros on the new develop version perhaps link the fully modded ship i would be more intersted to see if i will also crash before loading it.

    Thanks!
     
  10. V_quinha Trainee Engineer

    Messages:
    61
    The 90s. When geeks were still cool. Coax LAN parties... AoE I and II... How I miss those days...

    Aaaaanyways....

    http://steamcommunity.com/sharedfiles/filedetails/?id=775890506

    The problem is a bugger to recreate. I first had the crashes when my ship had 7000/8000 vanilla gyro's (still wouldn't turn though). I could still add armour at that point, but adding 100 more gyro's at that point would crash the game 100%.

    Which forced me to move on to EEZO modded gyro's. I also copy pasted the ship into a new empty world, and ran SE toolbox cleanup. That allowed me to play for a bit again and add the nose bit to the ship.

    Above world crashes for me within 10 minutes of playing and adding any type of blocks to the ship. Copy pasting to a new world and SE toolbox cleanup no longer do the trick.

    Interesting note perhaps: I do always build with mirror mode on, might be related, might be nothing at all....
     
  11. V_quinha Trainee Engineer

    Messages:
    61
    So I played for a while without this issue, having gutted my ship and removed a lot of it's mass.

    Now rebuilding for a few days and voila, the error is back... Maybe this info is useful. Look at Blocks and Grid Mass.


     
  12. V_quinha Trainee Engineer

    Messages:
    61
    Latest update was supposed to be about performance right?

    Now getting this (or similar) error before world finishes loading.

    To be clear: The day before the update I managed to load that world up and copy-paste the Amanda Tapping in there just for laughs.


    Nothing in any of the other logs.
     
  13. I23I7 ME Tester

    Messages:
    3,827
    T
    The new dev has still not rolled around to dev public are you talking about stable?
     
  14. V_quinha Trainee Engineer

    Messages:
    61
    Yup, definitely stable! Do you need another world upload?
    --- Automerge ---
    Scratch that. Now getting the same errors and crashes while playing on a multiplayer world.

    Ran two different memory diagnostics, no issues there.

    Log seems a bit more detailed this time:

     
  15. I23I7 ME Tester

    Messages:
    3,827
    Hey,

    Just reproduce the issue. So reporting the crash but my crash was a bit different and it happened the moment i tried to paste 2000 gyros. To be honest i think the problem might be related to the fact you are having quite big expectations for your ship i would recommend scaling it down a little if possible. If you have another world to upload i would be glad to as this might help us reduce the number of crashes. I would like to also ask are you running windows 7? Would you mind downloading the latest update it has directX 11.1 and it would help you avoid the SharpDX crash.

    Thanks!
     
  16. V_quinha Trainee Engineer

    Messages:
    61
    I'm running DX11.1 yes. Updated it to get rid of the graphics card error.

    To be honest it's not likely to be a world issue. I joined a random multiplayer server I had never joined before, flew out of orbig in the starter ship, started drilling a tiny hole in an asteroid... crash.

    I'll create another world and crash it for you tonight, but I doubt that's the way to go :).
     
    • Agree Agree x 1
  17. I23I7 ME Tester

    Messages:
    3,827
    I know but after drilling tons of holes into many different asteroids i did not crash so every little bit helps.

    Thanks!
     
  18. Red Corsair Trainee Engineer

    Messages:
    81
    if you playing with high presets, change it to low. i have gtx970 (4gb) and forced to play low quality, cus if i change textures from low to high i get out of memory crash. (8gb ram)
     
    • Informative Informative x 1
  19. I23I7 ME Tester

    Messages:
    3,827
    So you are getting out memory crashes on 8g ram?
     
  20. Red Corsair Trainee Engineer

    Messages:
    81
    yes. with high textures game works some amount of time, then windows shows me alert that memory is full and then game crash. i have 1gb free memory (my OS uses 1.8-2 gb), while start playing on server, then this amount decreaces and game crash. it takes 2-5 minutes.
     
  21. I23I7 ME Tester

    Messages:
    3,827
    And what about free disk space left on your PC? If its not over 10 or 15 Gigs i would try and clean up some of the clutter or old files that you dont use. I had to do the same last week with my PC being cluttered up with about 1000 save files.
     
  22. Red Corsair Trainee Engineer

    Messages:
    81
    oh, really! there is only 8gb free disk space left! thanks a lot, ill write if it helps!
     
  23. I23I7 ME Tester

    Messages:
    3,827
    Well tell me if it improves it or not (not sure if you are being sarcastic) I hope it helps.
     
  24. Red Corsair Trainee Engineer

    Messages:
    81
    i am not sarcastic. free up to 20gb memory on drive C:, same issue.

     
  25. I23I7 ME Tester

    Messages:
    3,827
    Sorry if i got a bit personal that was not the intention. I just was really confused by your reply :). Ummm not sure if i mentioned this to you but you know about that directx 11.1 issue right? I mean did you update or never had a issue like that ? Or never heard of it? Because that error:branch name cannot be resolved was a indicator you were missing the DX 11.1. What about deleting the shaderx file? Frankly if it does not help just go ahead and send me a save file with your mods so i can see if its the mods or something in the map causing the issue.

    Thanks!
     
  26. Red Corsair Trainee Engineer

    Messages:
    81
    np :)

    i have a (KB2670838) update (with partial support of dx 11.1) on my win7 ultimate sp1

    but for some reasons dxdiag shows me that i have dx11, not dx11.1

    upd. it happens on any server with planets, but sometimes it is exception, sometimes just crash "app stopped working". Can you tell me more about "deleting the shaderx file"?
     
    Last edited: Oct 27, 2016
  27. I23I7 ME Tester

    Messages:
    3,827
    Of course. First i would probably look around https://msdn.microsoft.com/en-us/library/windows/desktop/hh404562(v=vs.85).aspx here if you can update from there.
    Afterward the shadercache file can be found in C:\Users\WINDOWSUSERNAME\AppData\Roaming\SpaceEngineers. Just delete and attempt to launch it again.
     
  28. Red Corsair Trainee Engineer

    Messages:
    81
    i tried to delete shader cache, no result. so, it hard to say, but with pain i say: i need to update to win10. rip win7(((
     
  29. I23I7 ME Tester

    Messages:
    3,827
    Hey,

    Before you do update to w10 send me your full log maybe i can figure out what the hell is wrong and why it wont start.
     
  30. Red Corsair Trainee Engineer

    Messages:
    81
    there is full log before my game stuck.

    http://www.filedropper.com/spaceengineers_3
     
Thread Status:
This last post in this thread was made more than 31 days old.