Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

1.066 (and beyond?) 64bit DS, the infamous creeping ore bug, now on video!--CONFIRMED and ticketed!

Discussion in 'Bug Reports' started by Ulfsark, Jan 28, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Razapheal Trainee Engineer

    Messages:
    14
    From my tests it looks as if it's caused by ore clipping through the voxel texture map, specifically mined asteroids or, in the case of the world save I uploaded, deformed armor blocks due to damage. If you look at my world save, you'll notice that several of the floor plates are damaged fairly close to the generator.
     
  2. Ulfsark Master Engineer

    Messages:
    3,057
    Lukas told me in private message it likely had something to do with the programming. his guess was an error in the 64 bit version that assigned a wrong vector to the ore. Unfortunately, that went clean over my head, so I'll just continue playing the game with a smile on my face. Raz, Thanks :)
     
  3. SchlauFuchs Trainee Engineer

    Messages:
    89
    Can we please escalate the priority of this? I think the floating ore bug just had destroyed one of my docked large ships in a survival Dedicated Server game. the ship was docked at a connector. it must have received a big jolt from the game engine that ripped it off the station and run it into the asteroid wall, half of the ship is destroyed. This was triggered by some mining action on the asteroid where the station was connected into, and I could see floating ore on in the station deck. there was one spherical gravitation generator active. Interestingly the server doesn't do backups of the running game any more, there are no save games left other than some from mid December.
     
  4. ouch Trainee Engineer

    Messages:
    41
    Yeah, this is still happening. Why isn't this fixed yet? You can't play survival mode as you can't mine ore because of this bug. And the glitched rocks can do all sorts of weird stuff if they hit one of your ships/station objects.
     
  5. Ulfsark Master Engineer

    Messages:
    3,057
    Ok, saying you can't play survival is BS, just go to another area; the bug is no so common that you can't simply move to another deposit. And some bugs take more than a day to fix.
     
  6. ouch Trainee Engineer

    Messages:
    41
    How can I go to another area when it affects ALL floating objects in the game world?

    Also it's been far more than a day, Closer to a month...
     
  7. SchlauFuchs Trainee Engineer

    Messages:
    89
    Yes, please, this must be fixed. I need to be very careful with my fleet whenever I dig somewhere.
     
  8. Ulfsark Master Engineer

    Messages:
    3,057
    All floating objects in the game world? Please, record a video.... I've sat there and gone asteroid to asteroid trying to getting this to happen and came up empty, and you're saying its your entire game world?
     
  9. SchlauFuchs Trainee Engineer

    Messages:
    89
    i can't say it for the whole game world, as that might take a while to prove. But when I enable a gravitation source all floating stuff in the visible area starts to float parallel, slow, spooky.
     
  10. Ulfsark Master Engineer

    Messages:
    3,057
    ok, so its just that one area then? It seems to only happen in certain areas. Try flying to another 'roid, or even maybe another part of the asteroid you're on.
     
  11. ouch Trainee Engineer

    Messages:
    41
    So after playing around it seems that the number of collisions determines how often this happens. And my Ore Collector causes A LOT of collisions. But this bug happens to me EVERY TIME I mine. It does not matter where I do it. And once one rock does it, it seems to spread to other rocks. And things that are not even rocks like if I have a steel plate floating in space it effects it too. If I let it continue eventually I'll get a black screen with really high speed numbers. It reminds me of kerbal space program when the notorious kraken bug attacks... But usually the ore collector teleports and explodes before that happens.

    Here is a screen shot of my ore collector:

    [​IMG]

    I'll try to get one of the black screen. Oh, and this is single player... Yes I see the ore collector above teleporting around in my solo map...
     
    Last edited by a moderator: Mar 9, 2015
  12. ouch Trainee Engineer

    Messages:
    41
    This is still happening even after the oxygen patch. Come on guys this game is pointless if you can't mine... It's a massive game breaking bug that should of been fixed long ago when it was confirmed.
     
  13. Ronin1973 Master Engineer

    Messages:
    4,946
    Here's my experience:

    I've been working on map for a few weeks. Asteroids I have already been mining seem to function normally.

    Asteroids that have been in visual range but are virgin (unmined) are experiencing the bug.

    I started a new asteroid the other day and my mining ship gets stuck often and will vibrate itself apart a good portion of the time. The same thing happens to the player.

    I've noticed that small bits of non-collectible ore tend to get absorbed into the surrounding rock rather than disappear. Gravity has no effect on them.

    When I went back to the asteroids I have been working on, and mined them, no symptoms.

    I'm not sure if there's a way to extrapolate the data between mined asteroids and virgin ones, but there seems to be a procedural error in objects that exist, but haven't been explored. I've not tried this with asteroids generated by traveling far out of current visual range. Has anyone taken a field trip 50,000+km in one direction and tried mining?
     
  14. ouch Trainee Engineer

    Messages:
    41
    Still happens as of 01.076.011 Would be nice to have this fixed so I can actually mine things again...

    Would making a video of it help? I don't understand what is taking so long to fix this. Mining is a rather important part of the game, I would think it would have some sort of priority over bounceable space balls...
     
  15. Ulfsark Master Engineer

    Messages:
    3,057
    Its not preventing people from mining. The devs are aware of it and it will be fixed. As for you not understanding why it is taking so long ... that is obviously true.
     
Thread Status:
This last post in this thread was made more than 31 days old.