Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.067.007] Always stuck on loading screen now

Discussion in 'Bug Reports' started by PharmacyLove, Jan 30, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. WhiteWeasel Senior Engineer

    Messages:
    1,086
    Can confirm.
     
  2. Sarekh Senior Engineer

    Messages:
    1,189

    Stuck in endless loading screen - for me that is. I hear sounds but no keyboard interaction will change sounds or the loading screen. The spinning loading sign in the lower mid-section of the screen also does not stop spinning - it usually stopped shortly before loading the world.
     
  3. Thedevistator Senior Engineer

    Messages:
    1,942
    I have noticed this let me take a look into it myself I'll try to help seems to be on empty world or at least creative.
     
  4. joeblack616 Apprentice Engineer

    Messages:
    225
    can you try this ?

    "I have this issue as well. The shift+F10 add asteroid worked. "
     
  5. Thedevistator Senior Engineer

    Messages:
    1,942
    Yup confirmed Shift F10 still works.

    Edit: Oh I see sneaky, spawning in an asteroid takes you out of the loading screen bug
     
    Last edited by a moderator: Jan 31, 2015
  6. Sarekh Senior Engineer

    Messages:
    1,189

    just did as requested - I had to try out multiple F-function screens that overlayed over the loading screen without removing it but appearantly interacting with a loaded world - the fourth screen worked.

    I have tried this six times now and everytime with different options (shift+F10, only F10, etc.) and I had to do it at least three times in order to get the loading screen to go away - but it looks like a decent workaround - thanks for stopping the showstopper ^^
     
  7. SEModder4 Junior Engineer

    Messages:
    667
    Yup, luckily I found that :)

    The loading screen has the blue circle that spins and then usually it stops spinning then I hear my astronaut's jet-pack kick on and then the blue circle starts spinning again.

    Yes spawning an asteroid temporarily drops the loading screen like it should, although you shouldn't have to spawn a asteroid to get the loading screen to drop.

    It's been doing something like this for a few weeks, the audio and stuff would play before the loading screen dropped. I know this was fixed in an update awhile back I just can't figure out which one it was.
     
  8. lyle sonders Apprentice Engineer

    Messages:
    342
    Yes but its only games created in the last week or so the rest of my games are loading fine.

    I used set toolbox to transfer my build to a older game and it loaded fine.
     
  9. lyle sonders Apprentice Engineer

    Messages:
    342
    Can Confirm attempting to span an asteroid will drop the load screen. You can hit escape afterwards to cancel the spawn and the game working fine.....So far.
     
  10. Lynnux Junior Engineer

    Messages:
    881
    It seems to be as you say: no asteroid in the world = stuck in loading screen. Add asteroid (SHIFT+F10), save and the world loads normally.
    Whoever found that SHIFT+F10 workaround, great job !
     
  11. Dwarf-Lord Pangolin Senior Engineer

    Messages:
    2,597
    Spawning an asteroid does, indeed, fix it. Fascinating!
     
  12. Thedevistator Senior Engineer

    Messages:
    1,942
    Here's the big question now why do asteroids drop the loading screen iand none do not that might need to be looked into to.
     
  13. ashein Apprentice Engineer

    Messages:
    103
    I'd also add that while trying to load an older "empty space" world I get multiple checksum errors on every possible stuff, it seems, but Steam's "check integrity" function report everything is fine. The CRC in the logs report something along the line -

    47DEQpj8HBSa+/TImW+5JCeuQeRkm5NMpJWZG3hSuFU=

    - for every file (mwm mostly), which could suggest pathing issues and hashing some empty value or whatnot.

    Joining dedicated servers still works fine :)
     
  14. kdog31 Trainee Engineer

    Messages:
    2
    i am also having this problem i updated a few minutes ago and now cant load any world mods or no mods, it worked fine with the major update last night but with this mornings patch i cant load anything with or without mods. i can here the music playing and if i move my mouse around (even tho i cant see it) i can here the button hover noise. i was so looking forward to playing space engineers this weekend :( i guess i will have to wait for the devs to fix it *cough**cough* keen
     
  15. Gooplux6 Apprentice Engineer

    Messages:
    161
    Thank you this worked for me. hopefully there will be a hotfix for the hotfix. tomorow that won't cause the forums to light up like this.
     
  16. kdog31 Trainee Engineer

    Messages:
    2
    you could create a 4 asteroid world then use ctrl+x to delete them and use shift+f10 and spawn a really small one it might fix it i will test on mine and let you know
     
  17. dariorthan Trainee Engineer

    Messages:
    3
    same for me
     
  18. Thedevistator Senior Engineer

    Messages:
    1,942
    Let me take a farther look into it I want to see if it's asteroids that drop the loading screen or he empty world itself.
     
  19. dariorthan Trainee Engineer

    Messages:
    3
    Probably this big apears because of the Voxel Hands, which has been added 29.1.15. ive noticed that after some time i startet to hear music and sounds of reactors, so i think the Bug occurs when the game tries to load the Voxel Hands, which find no astroids and trie over and over again to find some and so the loading takes a millenium.
    i hope that helps a bit.
    Good Luck
     
  20. kingkrieg Apprentice Engineer

    Messages:
    161
    Bug happening to me as well, the asteroid spawning on loading screen worked tho

    lets hope for a nice hotfix while then, :)
     
    Last edited by a moderator: Jan 31, 2015
  21. clcaptain Trainee Engineer

    Messages:
    5
    i have the same problem but im gonna try to load a normal world instead of an empty one
     
  22. clcaptain Trainee Engineer

    Messages:
    5
    i have the same problem but im gonna try to load a normal world instead of an empty one
     
  23. Thedevistator Senior Engineer

    Messages:
    1,942
    Ok I have tested and it seems to be on any scenerio as long as their are no asteroids, interesting.
     
    Last edited by a moderator: Jan 31, 2015
  24. Thedevistator Senior Engineer

    Messages:
    1,942
    where exactally do you find that log?
     
  25. TidusKlein Apprentice Engineer

    Messages:
    216
    Confirmed spawning a asteroid fixes the problem.....well...how bout that?
     
  26. Thedevistator Senior Engineer

    Messages:
    1,942
    I think I may had found out the problem I don't know how to access the logs for it, but it may be that the game is trying to find and load in asteroids but because their are none it's trying to find some, maybe just maybe. I will say I haven't had too much experience with coding though.
     
  27. Dragonspride Apprentice Engineer

    Messages:
    460
    I know the devs know about this bug, but I can confirm its endless, fell asleep at my desk waiting for it to load... my neck hurts.
     
  28. Killaim Trainee Engineer

    Messages:
    57
    joining the club of people having this problem
     
  29. JJWolf Trainee Engineer

    Messages:
    8
    Adding the same - 64bit SE endless load on creation of Empty World (creative)
     
  30. radam Senior Engineer

    Messages:
    1,207
    shift f10 and try spawning an asteroid. That is a temporary workaround.
     
Thread Status:
This last post in this thread was made more than 31 days old.