Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.149 STABLE] Sim speed issues

Discussion in 'Bug Reports' started by Red Corsair, Sep 18, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Red Corsair Trainee Engineer

    Messages:
    81
    After last patch gamelogic increased from 7-8 to 20, with same online, same map, same mods...

    Tried to off ALL mods, same result, gamelogic 20+
    Needs to be fixed asap :carlton:
     
    • Agree Agree x 1
  2. gornyakmaniac Apprentice Engineer

    Messages:
    186
    Same server sim speed drop on my server after last stable update.
     
    • Agree Agree x 1
  3. Foogs Apprentice Engineer

    Messages:
    123
    Same sim speed drop on DEV version
     
  4. gornyakmaniac Apprentice Engineer

    Messages:
    186
    Monday bump.
     
  5. LocInt Apprentice Engineer

    Messages:
    264
    Same thing on DS stable.
     
  6. Daywalker Hawk Trainee Engineer

    Messages:
    13
    we also have simspeed issues it current between 0.2 abd 0.4 our hoster allready moved us to other hardware but its still a slomo show.
     
  7. gornyakmaniac Apprentice Engineer

    Messages:
    186
    Is there anybody in KSH cares about it? DS performance decreased three times with this update, so give us good game experience and fix it!
    There may be any other issues, but nobody wants to play on laggy server even there is no other issues.
     
    • Agree Agree x 1
  8. I23I7 ME Tester

    Messages:
    3,827

    Hey

    Okay this is something we would like to hotfix as soon as possible can you please give me the world from your DS so that i can we can have save that i can give to someone to at least try and fix it? We are aware of the issue but as noted before the MP and DS is being redone by two teams. If you can get it to me asap please.

    Thanks!
     
    • Like Like x 1
  9. Daywalker Hawk Trainee Engineer

    Messages:
    13
    upload the savegame?
     
    • Like Like x 1
  10. NikolasMarch Junior Engineer

    Messages:
    927
    yes the one that the DS saves
     
    • Agree Agree x 1
  11. I23I7 ME Tester

    Messages:
    3,827
    Yes upload please i am keeping this page open at all times waiting on this.
     
  12. gornyakmaniac Apprentice Engineer

    Messages:
    186
    @I23I7 This is not the save problem, it's DS or client problem. I use stable branch on my DS, Foogs uses develop branch, but after latest update we have same triple times server sim speed drop.

    How to reproduce:
    1) Get not the most powerful hardware for DS ( I use I3-4130 and I can see the difference very good)
    2) Set DS on 1.149 stable with all hotfixes using any world (not empty, but with some ships and stations to give some load)
    3) Connect 10 clients to this DS.
    4) Check server gamelogic time and server sim speed value, save numbers

    Then repeat all of this, but using 1.144 stable and after that - compare results of server gamelogic time and server sim speed value on 1.144 and on 1.149.

    I can give you save and logs, but logs are clear and problem isn't in my server world, it's in some changes in latest game builds.
     
  13. NikolasMarch Junior Engineer

    Messages:
    927
    dedicated servers save the game too... might be a good idea to provide some logs for when the sim speed is low also
     
  14. gornyakmaniac Apprentice Engineer

    Messages:
    186
    @Marc Weavers Logs are clear (as I said), and there is no noticeble changes in world save data. So if I23I7 will be able to reproduce this - he will have examples of data changes as many as he wants.
     
    Last edited: Sep 20, 2016
  15. NikolasMarch Junior Engineer

    Messages:
    927
    and the save can be retrieved from the DS.... just an educated guess but i think they want to look at the save game data at the time of the sim speed being low...
     
    • Like Like x 1
  16. I23I7 ME Tester

    Messages:
    3,827

    Alright we did do a little test run. So i did notice some changes in sim speed after trying to paste in the 2nd large ship but most of the time the sim speed stayed within 0,8 to 1. As i said before even if you think the save will not help i still would like to ask you for it because like that i will have the exact same thing in front me as you do.

    Waiting on your save!
     
  17. gornyakmaniac Apprentice Engineer

    Messages:
    186
    Last edited: Sep 20, 2016
    • Like Like x 1
  18. I23I7 ME Tester

    Messages:
    3,827
    Thank you will investigate further on this
     
  19. gornyakmaniac Apprentice Engineer

    Messages:
    186
    @I23I7 I hope you'll find a reason because for now game on DS is very,very uncomfortable because of lags, especially when more than 5 clients playing same time.
     
  20. Red Corsair Trainee Engineer

    Messages:
    81
    we had 20 clients with STABLE 1 sim speed before update!
     
  21. Hailedbean Trainee Engineer

    Messages:
    97
    We've had the same issue on The Silent Void. Used to run 10 people at 1.0, since the update we get 5 on and drop to 0.8 and the more people on the slower it goes. If Keen would like a copy of our current map, I will provide it. I've also noticed some issues with more Ram usage since the update, my DS used to idle at around 1.5gbs used, now we're closer to 2.5gbs.

    Edit* Sent the map to I2317 via "conversation." Let me know if it is any help to you.
     
    Last edited: Sep 21, 2016
  22. I23I7 ME Tester

    Messages:
    3,827
    Hey

    Thanks this is going to be a hard issue to settle we cannot really back pedal on the whole version but i am right now reporting it and trying to see if we can figure what has changed so drastically since the last update.
     
  23. Hailedbean Trainee Engineer

    Messages:
    97
    You guys do an awesome job! I love the fact that staff is so responsive and that issues are actually looked into. Keep up the great work. #KSWH4life
     
    • Like Like x 1
  24. Daywalker Hawk Trainee Engineer

    Messages:
    13
    also send you our save + log hope it helps you
     
  25. I23I7 ME Tester

    Messages:
    3,827
    Yep i am making some comparision right now its looking promising. So please guys bear with me these lags and sim speed drops.
     
  26. gornyakmaniac Apprentice Engineer

    Messages:
    186
    Actually, If programmers can't figure out what exactly they made which worsened DS work 3 times, you can publish 1.144 stable as separate branch of the game.
    Because for now it looks like nobody from KSH knows what killed server simspeed, and even somebody do - nobody of players wants to wait half of year before you guys will fix it (this is normal period between detection of issue and fixing of it, as far as I can tell with my one-year DS support experience)
     
  27. Red Corsair Trainee Engineer

    Messages:
    81
    response 10/10, result 0/10. KSWH0.4sim
     
    • Agree Agree x 1
  28. Hailedbean Trainee Engineer

    Messages:
    97
    You get more bees with honey than you do vinegar. Don't act entitled because you bought a WIP game and aren't happy with it, you're more than welcome to spend your time on SC or something similar, maybe Minecraft suits you? They are working their butts off but I'm sure if you had some input on things to adjust within the netcode they would appreciate it, otherwise you made your point, either wait patiently or move on.
     
    • Agree Agree x 1
  29. gornyakmaniac Apprentice Engineer

    Messages:
    186
    About "They are working their butts off" - before 2015-2016 New Year they published update after which all dedicated servers began to crash every 30 minutes... and then they just went to celebrate New Year. So there was no multiplayer for all New Year holidays just becasue somebody in KSH desided that to publish update without tests is better than not to publish it or to stay in office a few extra minutes.

    So, nobody in KSH working his butt off, yeah. This is good that they hired more testers and somebody responses on all of this bugreports for now, but testers don't fix bugs.
     
  30. Hailedbean Trainee Engineer

    Messages:
    97
    I bet you had the holiday off too, especially since you are so upset about not getting to play SE. Everyone is human.
     
Thread Status:
This last post in this thread was made more than 31 days old.