Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.173.010][DS] Batteries outputting power while on "recharge"

Discussion in 'Bug Reports' started by lordreaver, Feb 2, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. LeoClarke Trainee Engineer

    As of today's update, problem persists. No bugfixing but you can have mirrored wheel treads and purple emissive lights. All my Christmases have come at once.
    • Funny Funny x 1
  2. NikolasMarch Junior Engineer

    i have noticed something with the Ticks on the battery, before the broken batteries, the battery with no ticks displays green emisives, capable of discharging and recharging, and on dicahrge only it displays light blue emisives. this has now reversed, maybe this will help diagnose the problem

    EDIT: i have just tested something already built on Single Player game on the now renamed 'default' branch, the battery seems reversed in operation, but the emissive lights are ok, when dicharge is ticked, there is no power output, but recharging works... but again this is only if the grid is using less power than the 'power source' is providing
    Last edited: Feb 9, 2017
  3. 4o Apprentice Engineer

    nice. now it's the other way around. fully-charged small battery outputs 0 power independent of settings. i can enable remote control, but thrusters are inactive and (really?) i see that red power statistics that reactors output 0 power, which should never happen with remote control :)
  4. jandraelune Apprentice Engineer

    This bug is still present in [Dev 1.75]
  5. 1stBiker Trainee Engineer

    dingdongdongelong, better not playing with batteries atm ..
    hmmm .. they've done their job once .. weird they dont anymore me thinks
  6. hlws Tester Staff

    Hi guys,
    we are aware of this issue and the batteries will have to be polished a lot.
    Thank you very much for your feedback, it is making the game better :)
  7. NikolasMarch Junior Engineer

    yeah, wipe the dust off, spit polish, will work as new :D
  8. Jack Bartlett Trainee Engineer

    An update on this issue (mods who are reading this please deliver my message :)). A similar but likely different problem arises when disconnecting a small grid from a large grid connector. What happens is initially, the battery on the small grid is set to Recharge and is recharging with power from a large grid reactor. However, when this battery is disconnected from the large grid with Recharge still checked, the battery breaks. No amount of toying with the settings seems to bring it back to life, even partially grinding it and rewelding it. Furthermore the "Missing power" window you get to the right side of your screen indicates the "charging" requirement steadily increasing, when no systems are changing or even on. This was experienced on a multiplayer server today. I have not tried resetting the server (I cannot), but I suspect it will likely fix the issue.

    Perhaps add a way to reload the grid manually to the game, such as in the info tab.
  9. Cohors Trainee Engineer

    So today I loaded up my SP world and continued my work on a solar and battery powered rover. Sun set behind the hills and power died, obviously since batteries were set to recharge. Unticked recharge and now no matter what ticking or tweaking or changing I do power is dead. I'm screwed until the sun comes up. Haven't reloaded yet, I'll fiddle with it later today.
  10. Tigerstripe Apprentice Engineer

    This bug is still affecting all batteries, but it's especially annoying with small-grid ones.

    Also, if a battery fully depletes, it cannot be recharged ever again: it needs to be dismantled and have new power cells installed. That's clearly a bug!
    • Agree Agree x 1
  11. ComradeWithers Trainee Engineer

    Decided to finally signup on the forums because of this problem. Came back to SE after a 5 month break. Straight off I noticed power settings were wonky. After building a small solar farm for my exploration lander I noticed that you cannot charge one battery from another through a connector, among other issues.

    One quick search led me here, and I saw this problem has been going once since Feb 2, 2017. It has almost been two months and still no hotfix. This must be why the Devs just scraped the whole stable and unstable branches. Because every update breaks this damn game. The only acknowledgement I found was the typical. "we know it exists" on March 2. And if they gave two shits, they would have made it more public that they are trying to fix such a major component in the game. Survival is damn near unplayable. If it really is borked beyond repair, make a public sticky about it, or bring it up in one of your weekly "quote" videos.

    They only work around is to make a large wing of solars for every damn vehicle I have, or use reactors. Oh wait, no uranium at the start of survival. And if you start with a basic start shuttle without a reactor, you are royally miffed. After several years of this shit, I could rant for pages. These repeating power issue are getting old, and cumbersome. And inevitably, it is the reason why I take these several month long breaks.
  12. Jack Bartlett Trainee Engineer

    My experience with a dead bat on a small grid was interesting: it went dead with no other power sources, then magically popped back to life with the charge you get after you first make the battery. I'm not really complaining about that though (would have been screwedish). It's worth noting that this is the same bat described in my previous post; a simple reset of the world fixed the first issue
  13. ComradeWithers Trainee Engineer


    I loaded up my word in creative to add a reactor to my starting ship, because of the batteries having all these problems. upon loading my game in survival I tossed the Uranium into the reactor, and the two batteries charged from 500KW to 4 MW 100% instantly. Obviously that was a bug as well. I then shut the reactor off, and now the batteries even though being at 100% charge, the refuse to power the small ship at all. Every combination of settings has been attempted, and several restarts did not make the batteries work either. So it seems the only way to play is with reactors now.
  14. Redbeast180 Trainee Engineer

    I'm going to apologise in advance, as I'm pretty new to this site. However I felt the need to comment as I am a big fan and am having similar issues.
    In space engineers survival I am experiencing a glitch with batteries, they do not want to switch between discharge and recharge modes, even when I manually tell them. To get them to successfully switch I have to manually tell them the desired mode and then refresh the world using F5.
    This has become quite annoying for me personally and I have read up that other players are experiencing these issues as well. Any help would be much appreciated.
    Keep up the great work!
    • Informative Informative x 1
  15. XenoCow Trainee Engineer

    I'm seeing this problem in today's patch as well. After disconnecting a small ship powered with batteries only from a static grid, The ship loses power despite the batteries being full.
Thread Status:
This last post in this thread was made more than 31 days old.