Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.186.2] Remote controls borked

Discussion in 'Bug Reports' started by TEGCQUANTUM, Feb 15, 2018.

?

Are you having the same issue?

  1. Yes

    100.0%
  2. No

    0 vote(s)
    0.0%
Thread Status:
This last post in this thread was made more than 31 days old.
  1. TEGCQUANTUM Trainee Engineer

    Messages:
    2
    So an issue that i, along with several other people have been experiencing since update 1.186, is that if you are in control of a grid and then try to control a remote control on a sub-grid then you are told that "This is not the main cockpit".

    However since update 1.186.2 this has been changed to "Grid control forbidden. Seat/Remote with higher priority is already occupied." This is an issue as it stops people from effectively creating anything where they are controlling the grid from a sub grid such as large ships with small ship interiors.

    Now i would just like to note that if i was to get out of the seat on the sub-grid and control it from any other grid or my players antenna i do not have this issue.

    Proof of error message:
    [​IMG]

    Settings on seat. Note how "Control wheels" and "Handbrake" are greyed out
    [​IMG]

    Settings on the remote control. Note how "Auto pilot" is greyed out.
    [​IMG]

    Pre update 1.186 none of these settings would be greyed out and i would take a guess that it is them that are causing the issues. Please can you fix this.
     
    • Agree Agree x 1
  2. jura7 Trainee Engineer

    Messages:
    45
    I have the same issue after last major update, and I saw someone bug report right after update.
    I was very happy to read in last patchnote that the issue is solved, but after checking it ingame I wondered that nothing changed lol ;)

    Cmon, devs, your information is misleading (and hope breaking), and also gamebreaking for a common tank designs with turret-placed cockpits (like Anaconda).
     
    • Agree Agree x 1
  3. Thales M. Junior Engineer

    Messages:
    999
    Same here.
     
  4. Coolboard Trainee Engineer

    Messages:
    1
    I made a little grid for patroler with 2 cockpits, one for piloting and one to manage weapons. i had the trouble as without any interaction with high grid.
     
  5. Riasrock Trainee Engineer

    Messages:
    6
    I confirm, i have exactly the same problem
     
  6. Caedo Trainee Engineer

    Messages:
    3
    1.186.3
    Just discovered that I also have this problem. I get the above mentioned message and no change i settings seems to be able to change it.
    I play without 3rd person camera, and at the moment I can not use any of the ship's outside cameras.
    Are all small grids with remote control and gyros, connected to the large grid ship by rotors.

    EDIT: I want to add that taking control is working if I do by taking control of the ship by antenna (I chose ship from drop down menu at the top left) or from a panel.
    I just must not occupy any flight seat or cockpit that has control over the ship; means: message "This is not main cockpit" does not appear. in settings where this message appears, I can control the remote control from there.
     
    Last edited: Feb 28, 2018
  7. DrEarlInsanity Trainee Engineer

    Messages:
    14
    sadly this has largely hamper'd my hive minded turret system and most of my ships 'master controllers'
     
  8. Lightwolf Trainee Engineer

    Messages:
    8
    Same here i have two vehicles, that are useless now!!! realy frustrating me, i worked over 3-6 Month on it, and now i cant use it,...

    So i have two Cockpits, but the vehicle needs to be controled by the remote control. Why?
    the main grid has no wheels, its connected with rotors to an subgrid ( as a suspension), on the subgrid are the wheels, because the Cockpit dont able to control the wheels from the subgrid, i need the remote control for that,...

    So before the Update i leave two of my Project 100% working and finaly done, now i have just trash,... i worked atm on a other project, and just found that out today.
    so if you work on a project for months and you like your creation, you bring them to life and you tried to make it the best you can,... hard to tell you my actual feelings about this situation...
    only way to drive it atm is to go out of the Cockpit, and just use the Remote control, if i sit inside the Cockpit it wont work.
    So i think its a bug, because its absolute sensless if this is a plan for this game.

    so please fix that,... there are 1000 more reasons why we need an cockpit and remote controls on a creation.
     
  9. CriegWarfare Trainee Engineer

    Messages:
    1
    so why is this still not fixed? it has ruined every creation I've made that needs a targeting turret, and my command ship that has many hours into it. This feature has been used in thousands of creation for many reasons and it makes absolutely no sense why it would be disabled when we can already choose which cockpit has the main control, seems like this was a waste of coding time. It was such a frustrating bug that this is actually the first time since buying the game years ago that I have made a post about a bug.
     
  10. Thales M. Junior Engineer

    Messages:
    999
    I added a remote control with camera attached to it, to dock my small ship into a small hangar by moving backward. But I can't use it because of this bug.
     
  11. Udrakan Apprentice Engineer

    Messages:
    111
    yup, same problem. Remember that Keen doesn't fix any stuff anymore. They just break it in another way. Sometimes it replaces old bug with several another, enabling you to use your things.
     
  12. Shanjaq Trainee Engineer

    Messages:
    45
    Same problem here. I can't use remote control while in a passenger seat so I stuck a cockpit + antenna on my smallship "bucket" grid (no thrusters, wheels or gyros, only a container and a place to sit) then tried to drag it around with a remote controlled drone but as soon as the drone's landing gear locked on the bucket I got the message "Grid control forbidden. Seat/Remote with higher priority is already occupied.".. I used to be able to do this until a recent patch.
     
Thread Status:
This last post in this thread was made more than 31 days old.