Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.186.3][DS] major sim speed drop when flying into render distance of grids, but not when respawn.

Discussion in 'Bug Reports' started by piratep2r, Feb 28, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. piratep2r Trainee Engineer

    Messages:
    40
    Hello! On our dedicated server we are having a strange but really bad bug.

    We have a group of about 10 grids in one area on an asteroids only map, with the average block count of 800 and a max block count of 1500. The largest grid is static and attached to a small asteroid which we have mined heavily. The other grids are either all free floating, or all landing-gear locked to the static grid (we have tried both ways). This assembly is our HQ and the surrounding ships.

    When players fly from point A over to the HQ and enter render distance of this group of stationary ships, the entire server simspeed drops to below .1, and stays there for up to 30 seconds.

    But when players starts at point A and simply respawns at point B, there is no simspeed drop at all.

    Leaving the HQ area causes no drop.

    In both cases, the entire area must be loading in, right?

    It's like the combination of movingXloading is the problem. Note, this happens at 100 m/s.

    Server is modded, but besides fairly simply block mods, the only strange mod operating near the HQ is the nanite mod. We have tried both with nanites there and after removed all aspects of this mod from the HQ area, and still have the loading simspeed drop.

    Problem is 100% replicated on our end, and has been tested and seen at all such concentrations of grids above a specific size/number.
     
  2. Tharatan Trainee Engineer

    Messages:
    24
    We saw this last week on our DS as well - planet based area would see heavy lag when players entered the area (and when players connected the first time), but nothing near the same impacts when spawning there. We reset the planet voxels and reduced our sync distance, and these seem to have solved the issue.

    We are now starting to experiment with bringing the sync distance back up to see if it was the sync or the voxel reset that really solved the issue - indications so far seem to point to resetting the voxels as the step that solved the problem.

    *edit: I see that you note your asteroid has been mined heavily. Do you have an intact copy of the asteroid in a backup file that could be swapped in?
     
  3. piratep2r Trainee Engineer

    Messages:
    40
    Thanks for the reply, and glad to not be alone. We ended up doing exactly the same thing, with some partial success.

    Current iteration has us limiting the number of allowed grids near each other. Seems like we are bending over backwards with work-arounds here.
     
  4. Zhiila Tester Staff

    Messages:
    487
    Hi,

    this is known issue but if you have a world and would be able to upload it, it could help.

    Thanks.
     
    • Informative Informative x 1
Thread Status:
This last post in this thread was made more than 31 days old.