Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[1.186.5]Some particle textures not working solved

Discussion in 'Bug Reports' started by santibag, Jul 15, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. santibag Trainee Engineer

    Messages:
    53
    Some History
    I was one of the people that was seeing whole pink textures(not pink/black squares) instead of some particles(drill dust, hand welder flame...). After some trials to fix, I thought "If most of the people don't have the issue and I have, I have to find the difference to fix" (I'm still learning to plan before acting). Actually I was thinking it as a hardware incompatibility bug but it was a little thought idea. After playing(?) a buggy SE for a long time, it was not looking unreasonable.

    I finally remembered something. I sometimes backup game files by hand before OS reinstall and paste them before starting game download again. Steam finds these files and only downloads new updates. I thought, some old files may cause the problem.

    Fix:
    In my case, some old files were causing the problem so I just completely removed the game.

    1- Backup your data. They are not causing issue. You may delete shader cache folders.
    c:\Users\"User name"\appdata\Roaming\Space Engineers
    Backup this. Shader cache is in it if you wonder.

    2- Uninstall the game from steam.

    3- Check what's left. Location:
    c:\Program Files(x86)\Steam\steamapps\common\

    If there is a Space Engineers folder, delete it by hand. You may check the folder to find the problematic file. I found something related to particles. But I'm not sure if it's the problem.

    4- Reinstall the game

    5- Place the backed up Space Engineers folder in it's previous location in Roaming.

    It solved my problem. Be careful to remove ALL game files in steamapps\common folder.

    I couldn't use ship drills before fixing so it was important for me to fix. I hope it fixes yours too.
     
Thread Status:
This last post in this thread was made more than 31 days old.