Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

[128-011] [ds] Player walking and running now tied to SSS

Discussion in 'Bug Reports' started by demolish50, Apr 1, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Kham Apprentice Engineer

    Messages:
    478
    Yeah, I'd had the issue a long time back but haven't had it for so long. The same world, with nothing but station blocks in it, holds a sim speed of 1 and the jetpack works fine. But once I start putting ships back in and the sim speed starts dropping anywhere below about 0.7 I start seeing major issues with the jetpack. One minute it'll work fine, then the next it just refuses. I'm seriously hoping they'll switch things back on Thursday so that only ship movement is tied to SSS as the character being tied to it makes multiplayer pretty un-bearable at the moment and MP is the only reason I play this game.
     
  2. Scorpion00021 Senior Engineer

    Messages:
    1,411
    Even if it is tied to sim speed, it should be SCALED with the speed instead of limited by.
     
  3. striker_lord Apprentice Engineer

    Messages:
    163
    @Kham the issue you are showing on this video doesnt seem to be related to your SSS.
    Somehow the issue you are showing doesnt happen on any of my server instances.

    your issue looks like as if the Intertia dampeners or thrusters are not working at all.
    You might want to check your logfiles to see if there is any error that goes with this behaviour.
     
  4. Kham Apprentice Engineer

    Messages:
    478
    Yeah I'm not 100% sure what's causing it. It seems to have stopped happening again now. Last night it was fine whilst the server had a SSS of 1.0 but then once it started to dip below 0.7ish it started intermittently happening. I restarted the server before I went to bed last night and it hasn't shown up again today so now it's just character movement and things which are being affected. Nothing indicated in the logs though so I'm not sure why that happened last night. :(
     
  5. demolish50 Senior Engineer

    Messages:
    1,434
    Anyone seen an official response about this?
     
  6. Ronin1973 Master Engineer

    Messages:
    4,946
    What is tied to sim speed now is definitely thrust. If the sim speed drops, your amount of thrust gets nerfed. So if you're flying in atmosphere with a cargo ship full of inventory and you hit a sim speed drop... like during a game save or a deteriorating sim speed... you crash into the planet. The end. Game over, man... game over.

     
  7. Kham Apprentice Engineer

    Messages:
    478
    Ship speed has been tied to SSS for months now. This thread is about Thursday's patch also tying character movement to SSS. I'm really not sure how this move 'helps' anything. I could understand (though I still dislike) the change to ship thrust as it was to help with desync supposedly. However, if I can fly at 70-80m/s why the hell can't I even run at a full 7m/s??

    Edit: Nvm, I misread your post. I read 'thrusters' rather than 'thrust' and yes, rate of acceleration does also seem to be affected now for ships.
     
    • Agree Agree x 1
  8. Prescott Freyd Senior Engineer

    Messages:
    1,833
    Hey guys!

    Sorry you're experiencing these slowdowns, we're working on fixing the simulation speed drops that emerged in a lot of world after the 127 update. We'll also be issuing a major update to the multiplayer this week, hopefully that will help with these issues.

    Regards,
    PF
     
    • Like Like x 4
  9. Harrekin Master Engineer

    Messages:
    3,077
    Define "major"...

    Like "meeting exterrestrials major" or "steak for dinner major"?
     
    • Funny Funny x 1
  10. Kham Apprentice Engineer

    Messages:
    478
    I am both excited and terrified in equal measures. :p
     
    • Agree Agree x 1
  11. [PSI] BC Trainee Engineer

    Messages:
    95
    My friends and I are seeing the same issues on a dedicated server. Even worse, when I gave up on the DS and went back to hosting the game on my own rig, we STILL had slow-motion problems.

    I'm slightly upset, as I rented a dedicated server specifically to ESCAPE the sudden slow-down of our jointly created level. Figured that since my friends could literally walk rings around me when I was the server, we'd all be able to move normally once I shifted the server to a DS and became one more client. BC is not happy with this update.
     
  12. mxxpower Trainee Engineer

    Messages:
    52
    I am also thinking that welding and grinding are now tied to sim? The elite grinders are about as fast as the non upgraded ones.
     
Thread Status:
This last post in this thread was made more than 31 days old.