Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Annoying bugs !

Discussion in 'Bug Reports' started by WillyGmod, Mar 11, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. WillyGmod Trainee Engineer

    First of all, sorry for my bad english, this is not my main language, i'm french !

    For the various bugs I noticed, here they are:

    1) The translation is half made (my game is in French, and when I lay blocks, the names of the blocks are sometimes French, sometimes English, for me who speaks not very well English, it does not help)
    2) When I am in a small vessel cockpit, there is a block that appears, and that flashes, as if I had a block in hand, while I'm in a ship (and I'm not in construction mode) (to see what I'm talking about :
    3) When I sit on the ice, without a landing gear, after a while, or when I reload a backup, the ship jumps into the air, and makes a loop, and sometimes it explodes, without me touching it (but why?) (If you want an example:
    4) When I load a hologram in the projector, I leave my game by backing up, and I return to my part, the hologram that the projector projects disappears after a while, even if I turn it off as I turn it on again, the projection will recover a time , and disappears again, my only way to fix it is to fire the projector, and rebuild it, but when a big job is on the way, it's very handicapping!
    5) On one of my game, it is IMPOSSIBLE for me to add mods, on the main menu, the button "mods " Just disappeared, I tried to uninstall my game, put it in english, but nothing to do, its not working!
    6) When I click too fast on the main menu, My computer makes me a big BLUE SCREEN, which forces it to restart.

    Oh yes, it would be possible to disable pressurization on Earth? When I build, its makes me huge calls of air for no reason, and its makes me freeze, and on earth, it's useless, because there is oxygen!

    When you mine (in secondary mode), it would be possible for the temporary pebbles to disappear faster, or there are none at all? Because when a temporary pebble approaches a structure, one does not ask little nothing, and it is necessary to wait until the pebbles Despawn to be able to pose a block (if I mine in secondary mode, it is precisely because the pebbles, I do not want theme, and the fact that they appear Like his, and that he does anything, it's a little disturbing anyway)

    This game has a very big potential, but if you could fix all bugs before adding new things, everybody would be happy

    PS: I know that I ask you a lot of thing, but could it be possible to finnaly fixed the multiplayer (and no, it have not be fixed yet :
  2. Zhiila Tester Staff


    1. It is not official translation. It's done mainly by community so we can not guarantee quality of those translations. You can look at http://www.spaceengineersgame.com/localization.html

    2. This has been recently reported and will be fixed.

    3. I didn't reproduce it, even though we are aware of this kind of behavior in some cases, it just seems to be part of much bigger problem. So if you have any blueprint which cause this behavior frequently, can you share it?

    4. I don't really understand this. :( Can you explain it a little bit more?

    5. If you could upload the world, it would be helpful.

    6. I am not able to reproduce this. I was clicking as hell and nothing happened. What is your PC configuration?

    Thanks a lot for your time!
  3. WillyGmod Trainee Engineer


    1) I know that, but I didn’t make myself clear, if I put 20 large reactor, a part will be translated (their name will be in French), but the other will be in English, which is curious, because this block is translated into French.
    2) Ok, thanks for the information!
    3) I do not have a blueprint, it's just in the video you can see it, I know why it did it, its even made me several times, so I hope its not going to happen again, because its all funny ^^
    4) In fact, it's simple, I build a projector, I load a blueprint in it, so the projection appears, I save my game, and I leave the game. When I return to my game, the blueprint laid in the projector is visible, for a few minutes, but after a few minutes, the projection disappears, for no good reason, my only way to remedy it is to destroy the projector, and to replace it, even turn it off and turn it back on have no effect (for more info, this video shows the bug, just watch the projection, after a while, it disappears "
    5) It would seem that the update on Thursday has fixed the problem.
    6) My config is:

    -Windows 10 64-bit family edition.
    -i5-6500 3.2 GHz
    -GTX 970 4GB
    -16GB Ram DDR4

    Thanks a lot for your answers !
  4. Zhiila Tester Staff

    So i tried it again and I was able to reproduce no. 1. Block wasn't translated if I placed it into the air, if i placed it on already existing grid, it was ok. So I reported it. I am still not able to reproduce no. 4 (I tried it in Single Player and Dedicated server). Also for no.6, could you send SpaceEngineers.log after the crash?

  5. WillyGmod Trainee Engineer


    1) Okay, thanks.
    4) Okay, but it's strange, if you're not able to repodruce it, could you at least report it, or show the video ? It's handicapping, when the he crash, and I'm not next to it, I have to came back, , destroye and rebuild it ! I didn't make myself clear, I am in single player
    6) When I tried to reproduce the crash, Windows told me that a file was corrupted. After verifying the game file, steam downloaded it, and since this the bug cannot be reproduce.
    7) A new bug appears (there is nothings new, but I was thinking that it have been fixed), the light bug, depending on the viewing angle that we have (for example:
  6. Zhiila Tester Staff

    To make a ticket we need a reliable way to reproduce the bug since I didn't reproduce it I can't make the ticket. I can keep trying, but can you send exact steps to reproduce maybe even with already prepared world?

    Something like:

    Reproduction steps:
    # Step no 1
    # Step no 2
    # Step no 3
    # Step no 4
    # Observe the behavior

  7. WillyGmod Trainee Engineer


    You want me to explain everything step by step? All right, I already did it, but I'm going to do it again, I hope you'll understand:

    For the projector bug :

    # Step # 1 : Launch Space Engineers !
    # Step # 2 : Place the projector's patern! (And place a reactor, to power the projector) !
    # Step # 3 : Build the projector! (I did it only in survival, I did not try in creative) !
    # Step # 4 : Load a blueprint in the projector !
    # Step # 5 : Once the projection is projected, and visible, save your game !
    # Step # 6 : Once the game is save, quit your game !
    # Step # 7 : Then restart your game !
    # Step # 8 : Once your game is restarted, watch your projection !
    # Step # 9 : After a while (between 1 and 20 min), your projection will disappear, for no reason !

    For the light bug :

    # Step # 1 : Launch Space Engineers !
    # Step # 2 : Place many interior lights patern (at least 20) !
    # Step # 3 : Build indoors lights, and build something to power it !
    # Step # 4 : Build a room (Underground and closed if possible) !
    # Step # 5 : And then, put yourself a little at the edge of the light (not too far), and make a turn (not too slowly, not too fast) on yourself, and walk around this light !
    # Step # 6 : It looks stupid, but you will see that the light appears and disappears, depending on the angle of view !

    For the bug of the projector when you want to change his values in a seat :

    # Step # 1 : Launch Space engineers !
    # Step # 2 : Place a projector and a reactor paterns on your base !
    # Step # 3 : Build them !
    # Step # 4 : Active the projector !
    # Step # 5 : Load a blueprint into the projector !
    # Step # 6 : Place a flight seat in your base (where the projector is) !
    # Step # 7 : Jump in the flight seat !
    # Step # 8 : Add a shortcut to the rotation X or Y and the pitch (add increase and decrease) !
    # Step # 9 : When you click on increase rotation X (or decrease, it's an example), it automatically set it to 180° or -180° !
    # Step # 10 : Before this bug, I could increased it from 90 to 90 and from -90 to -90 !

    I hope it's understandable, and for info, here's my config :

    - Windows 10 Professional (64 bit)
    - Processor I5 4670K (3.5 GHz)
    - Geforce GTX 1060
    - 16 GB of ram
    - ASUS Z87 pro motherboard
    Last edited: Apr 1, 2018
  8. Zhiila Tester Staff

    Light bug and Projection rotation are already reported but I am still having problem with disappearing projection, can anyone else confirm, it is not a local problem and it is happening even to someone else?
  9. Hakuryu Trainee Engineer

    my game is the same that the game from Willy Gmod.

    i've make the same modification and my projection dissapears. that's very unpleasant and i stop the game frequently because the bug make me angry.

    if i play at Space Engineers, that's for this créativity ... but with many bug, this is not funny to play

    i'm joining willy to have a resolution of bug
  10. Zhiila Tester Staff

    Ok, so I created ticket also for this as it is obviously happening to more people. Someone is going to look at it.

    Maybe the world where it is occurring would help, can you upload it?
  11. Tinuveil Trainee Engineer

    I encounter the same issue than Willi Gmod with the Y and X axis. When i am on the projection mode on the command sit, they rotate on 180° and i can’t move back anymore.
    If you can look to correct this issue it would be very kindly !
  12. WillyGmod Trainee Engineer

    Ok, thanks for the information, I hope these 2 bugs will be settled quickly.

    Small question Anyway, there has been no update of SE since March 8th, is it normal? I mean, is it in anticipation of a big update or the development of the game is giving up?

    For my world, here it is, I included a list of mods that are to download because I play with them on this backup! = = > https://steamcommunity.com/sharedfiles/filedetails/?id=1355494665
  13. Thrak Junior Engineer

    Starting last month, Keen has stopped doing weekly minor updates in favor of less-frequent "major" updates. These aren't, apparently, on a set schedule, in order to allow for more testing and quality assurance. Read more at https://forums.keenswh.com/threads/...s-changes-to-release-system-xbox-one.7400482/
    • Like Like x 1
  14. WillyGmod Trainee Engineer

    Ok, thanks for the information !
    • Like Like x 1
  15. WillyGmod Trainee Engineer


    Zhiila, have you had time to look at my world, so you can see my projector problem?

    Oh Yes, it would seem that there is another bug (for me it's a bug, but I do not know if it's really a bug) :
    # Step # 1: Launch Space Engineers !
    # Step # 2: In your world's options, check the "Enable Sun rotation" checkbox
    # Step # 3: Start your world, press SHIFT + F10, then, in the dropdown menu, select "Admin tool "
    # Step # 4: Place the Sun where you want!
    # Step # 5: Save, and quit your game, and in your party options, uncheck the "Enable Sun rotation " checkbox
    # Step # 6: Restart your game, and you will see that the sun isn't where you put it
    # Step # 7: For me it's a bug, because it's impossible for us to place the sun as we wish, which is pretty boring!
  16. Zhiila Tester Staff

    I was planning to look at it today but it's telling me the file does not exist. :( Can you upload it again please?

    For the sun rotation, this is known behavior. It was specifically thought about this case, but it would require a huge change of how sun rotation works right now. I have to admit I would also like to be able to change position of sun in the world with sun rotation turned off but my kinda workaround is to set day duration to max (24h) so I don't have to change it often.
  17. WillyGmod Trainee Engineer

  18. Zhiila Tester Staff

    Thanks. So I finally reproduced the issue. It just happens only with mods in the world, projection won't disappear in vanilla world.

    So I would suggest to identify the mod which is causing it and remove it or contact it's creator to let him know about the issue.
  19. WillyGmod Trainee Engineer

  20. WillyGmod Trainee Engineer

    Well, uh, after a month of thinking, with you an idea that my little ship merged with my big ship? I'm asking because I'd like this bug to go back to the Space Engineers devs !

    Another question, the next update, do you know when it is scheduled ?
    Last edited: May 21, 2018
  21. Zhiila Tester Staff

    How did it happen? I can imagine it to happen with a bad connection to a server. But without steps to reproduce, I am not sure what we can do.

    I don't know when the next patch is going to be released.
  22. WillyGmod Trainee Engineer


    How did it happen ? Well, that's a good question, the answer is : I don't know!

    My small ship was stuck to the big one thanks to the landing gear, and I was not on a server, but solo, when the steps, well they are simple :

    1) I was in space, above Mars!
    2) I wanted to land on the planet, without crashing, I specify !
    3) I managed to land without crashing, but, when I went outside my ship, I saw this horror that was happening, but when ? I don't know

    Sincerely, WillyGmod

    PS : Thanks for the clarification on the update, I didn't know if we could find a place to get this information.
  23. WillyGmod Trainee Engineer

    Hello everyone, it's been a long time, but I have a bug to report (again), so well, for the process to follow :

    1) Launch Space Engineers, and create a world !
    2) Place some pistons, more than 5 (To make it work more than 7 seconds) !
    3) Make a group with all the pistons !
    4) Place 2 timers blocks , in the first one, configure it, place it in n°1, the group of pistons in "Reverse" mod, and the second one, the second timer blokc, in "Start" mod !
    6) In the second timer block, Configure it to activate after 6,999 sec (extremely important), then, place the group of piston in N° 1 on "Deactivated On/Off" !
    7) Launch the timer block n°1, and look very well how far the piston stop (Put a marker or something to remind you) !
    8) When it's done, reactivate the piston, make them all go down, and the second timer block to 7.00 secs (Very important) !
    9) Launch the timer block n°1, And you can see that the Pistons go up A LOT higher, this isn't normal, because there is only 0.001 sec of difference in the setting of the timer block n°2 !
    11) But this is not all, the timer block n°2, have fun to set it between 6 and 6,999 secs, as you want, you will see that the pistons go at the EXACT SAME hight, no matter the time you set the Timer block n°2 !
    12) You will agreed that this is not normal, because there is still a difference between 6 secs and 6,999 secs !
    13) If this is not understandable, I will make a video, but it will be in french, because I'm not english (but there will still be English subtitles) !
  24. Georgik Apprentice Engineer

    I believe timer blocks work only within precision of whole seconds. The value is automatically rounded down.
  25. WillyGmod Trainee Engineer

    But in this case, why propose such precise control of the timer blocks if it is to round at the end ? This is nonsense, the devs don't give a shit about the players there...
  26. Georgik Apprentice Engineer

    I don't know.
    I don't agree. I believe Timer blocks will get some attention when more important things are completed. They shouldn't and won't spend time on these small changes yet.

    For now, we have to use mods for precise timer blocks (none found?) or programmable block's script.
    • Agree Agree x 2
Thread Status:
This last post in this thread was made more than 31 days old.