Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Asteroid deformation glitch just destroyed my mining rig

Discussion in 'Bug Reports' started by AutoMcD, Dec 31, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. AutoMcD Senior Engineer

    Messages:
    2,369
    Here is a small mining ship:
    [​IMG]
    Pretty neat, right?
    So I'm doing some mining on a random asteroid. I pick a new spot on it and barely get through the surface before OMG I AM FLOATING IN SPACE AND THE DEBRIS NEARLY KILLED ME.

    Let me just back up and see what happened.. What things look like now:
    [​IMG]
    [​IMG]
    [​IMG]

    Yeah so apparently a giant cube spawned squarely where the ship was, nothing left but some drills and random bits of scrap armor.
     
  2. Latsabb Senior Engineer

    Messages:
    1,019
    That is what the AI wants you to think. You just got ambushed.
     
  3. Tony Hughes Junior Engineer

    Messages:
    715
    I think you were just assimilated. Resistance is futile.
     
  4. semple Trainee Engineer

    Messages:
    83
    #illuminati

    But yeah, there is something wrong. I was able to fly into the innards of an asteroid :))

    http://youtu.be/y_fIeff-wHY
     
  5. Beezilbub Apprentice Engineer

    Messages:
    237
    Same thing happened to me: my bug post. It's only happened twice but both times my rig was damaged by it.
     
  6. AutoMcD Senior Engineer

    Messages:
    2,369
    whoops, must have been looking for the wrong keywords. sorry for making a dupe thread.
     
  7. se5a Apprentice Engineer

    Messages:
    113
    Same thing here, except my ship is not destroyed since the rock spawned after I'd docked, then decided to chip some asteroid away where it was a little close to the ship.

    https://www.dropbox.com/s/qp3isnq99p5qf2e/SpaceEngineers_2015-01-01-22-11-37-680_FinalScreen.png?dl=0

    https://www.dropbox.com/s/qnmmqxkctqgar7p/SpaceEngineers_2015-01-01-22-11-59-059_FinalScreen.png?dl=0

    is there a way to rescue this ship?
     
    Last edited by a moderator: Jan 1, 2015
  8. Phand Master Engineer

    Messages:
    9,650
    Hi guys,

    is there any way how to reproduce this problem? I am trying to reproduce it now, so any information would be super helpful. Thank you.
     
  9. semple Trainee Engineer

    Messages:
    83
    For me, it seems to be random depending on how certain asteroids are generated and rendered. I cannot reliably reproduce. It just kind of happens when it wants to.
     
  10. Skeloton Master Engineer

    Messages:
    4,069
    Phand It happens more often to me with the right click mining.
     
  11. Kuu Lightwing Senior Engineer

    Messages:
    1,503
    wow, predator asteroids...
     
  12. Soulthule Apprentice Engineer

    Messages:
    362
    I have had several players have their miners come apart for no apparent reason while in an asteroid. I also noticed, and I think I can possibly reproduce using a hand drill shards of the asteroid you are mining with the hand drill that you can't remove.

    I few days ago we had a situation where there was a shard no bigger than a players head almost take apart a large ship we were taking in the asteroid. The ship got stuck on the shard and caused it to start bouncing around beating on the ship. We finally shook the ship loose.

    I have only witnessed these shards with a hand drill. I wasn't in the asteroid where player's miners came apart.

    One other note. I was usually with another player when this happened and we were both using hand drills working the asteroid pretty hard.
     
    Last edited by a moderator: Jan 2, 2015
  13. Jan5366x Trainee Engineer

    Messages:
    56
    ... mostly all time then in MP ^^
     
  14. RIPerKilla Apprentice Engineer

    Messages:
    140
    Same there. I got huge mining drill, and right now it's just have been cut in two by huge piece of rock spawned inside. Second time already.

    For me it's:
    1) I find new untouched asteroid.
    2) Drive closer, find an ore marker.
    3) Trying to get closer by right-click mining.
    4) OOHH CRAP. Some rock spawns inside my ship and breaks it almost completely.
     
  15. Hermanek Trainee Engineer

    Messages:
    31
    Same on our server. Do we need new map, to repair this problem?
     
  16. 25hz Trainee Engineer

    Messages:
    38
    My miner or asteroid (not sure which it was) just started spinning vertically and got jammed in the asteroid. Had to reload world to get out after everything stopped spinning. Also, I can't even control the drills with the mouse - I need to manually toggle everything with the toolbar.
     
  17. PaladinX333 Apprentice Engineer

    Messages:
    234
    Solution: Don't do that.

    I don't understand what the whole right click thing is supposed to be. It's like some kind of debugging cheat that has been left in the game. Drills containing some kind of magic rock remover doesn't seem very realistic in any event.
     
  18. se5a Apprentice Engineer

    Messages:
    113
    we're not looking for solutions we're looking for repeatability for the devs.

    right click is faster but you get no drops. it's for digging tunnels fast.
     
  19. AutoMcD Senior Engineer

    Messages:
    2,369
    as far as i know it's only for the hand drill, it will deform the asteroid but not actually pick up any of the rock. (more floating debris)
     
    Last edited by a moderator: Jan 3, 2015
  20. VikingPSG Trainee Engineer

    Messages:
    20
    Right click mining works with all size drills.
     
  21. kleptikondriac Trainee Engineer

    Messages:
    59
    Quick question to all that posted about this... did any of you have sensors on your miners?
     
  22. damoran Junior Engineer

    Messages:
    608
    I believe this happens when there is an inner void in the asteroid close to the out side shell. has nothing to do with how you are mining it I believe it happens during asteroid generation
     
  23. se5a Apprentice Engineer

    Messages:
    113
    There's possibly two bugs here which may not be related.

    When alt drilling, there are sometimes artifacts left behind. these look like shards where you've been drilling.

    When drilling (either normally or alt?) sometimes it can cause a large chunk of rock to be spawned a little further from the original asteroid.
    this will happen either when drilling by hand or with a ship, possibly it may only spawn where a ship is present however.
     
  24. AutoMcD Senior Engineer

    Messages:
    2,369
    yes.
    I use a sensor to automatically turn on the drills when it's within a few meters of the asteroid.
     
  25. kleptikondriac Trainee Engineer

    Messages:
    59
    Well... i have seen this bug 4 or 5 times while working with my autominer.... and the resulting asteroid bits that spawn, ive found are the same shape as the sensor field for the drone... dont know if other fields effect it or not as well but this is what ive found... ill try to get a picture up at some point to illustrate this.
     
  26. Beezilbub Apprentice Engineer

    Messages:
    237
    I didn't have sensors on mine so I don't think that is connected. All three times it happened for me were with no sensors, large drills, regular mining (no right-click mining).
     
  27. WormGda Trainee Engineer

    Messages:
    46
    he he he

    The same, when mining machinery.
    http://steamcommunity.com/profiles/76561198065943792/images/
     
  28. Whiplash Trainee Engineer

    Messages:
    52
    This is still a problem for random asteroids, this was never 'just' a torus asteroid bug, Keen needs to fix this issue for all procedural asteroids... I see at least 3 players every day complaining that their ships are damaged/destroyed from this bug.
     
  29. AutoMcD Senior Engineer

    Messages:
    2,369
    interesting observation.. hopefully it helps the devs figure this one out!
     
  30. Grendelbiter Trainee Engineer

    Messages:
    4
    So yeah this happened to me just now too. It was with a mod rill though so I'm not sure if it's because of that. Here's a crappy picture showing the aftermath:

    http://steamcommunity.com/sharedfiles/filedetails/?id=369385094

    You can barely see it, but there's a sliver of asteroid floating there, just visible from one angle. On the other side of this ball formed rock there's a floating square that wasn't there before. I'm not even sure what blew up the ship.
     
Thread Status:
This last post in this thread was made more than 31 days old.