Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Can a Planet's Gravity be Changed?

Discussion in 'General' started by Spaceman Spiff, Dec 7, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Spaceman Spiff Junior Engineer

    Messages:
    837
    I tried messing with gravity in the sandbox file, but it always reverts back. Is planet gravity a fixed entity?
     
  2. Ronin1973 Master Engineer

    Messages:
    4,532
    The safest way is to change the gravity before world generation. If you're trying to do it after You'll have to change it in both .sbc file locations.
     
  3. Spaceman Spiff Junior Engineer

    Messages:
    837
    Planets don't download to my computer now, so I have no way of changing the modded planet.
     
  4. Roxette Senior Engineer

    Messages:
    1,216
    Yes they do :) ... you would need to make a copy of the original (extracted) mod into a new sub-directory of the %appdata%\SpaceEngineers\Mods\ directory and make your edits there, and load the local mod into the game save.
     
    • Like Like x 1
  5. Spaceman Spiff Junior Engineer

    Messages:
    837
    I went to the C:\Users\{Username}\AppData\Roaming\SpaceEngineers\Mods directory and all the files there are listed as "1526479444.sbm", "1507391748.sbm", "709975763.sbm", etc. The dates for all 163 files, but not the times, are either 10/17/2018 or 10/18/2018. I added ".zip" to the extension and checked a bunch of them, but they're mods that I installed awhile back whereas these planet mods were installed in the last couple weeks. What am I doing wrong?
     
  6. elowan Trainee Engineer

    Messages:
    15
    Spaceman, check this folder: <your steam install location>\steamapps\workshop\content\244850. You should see folders organized by mod ID.

    My SE install has stopped updating/ downloading mods that I subscribe to into the %AppData%\Roaming\SpaceEngineers\Mods folder. Mods that I newly subscribe to / update are pushed (as unzipped folders) into the above Steam folder.
     
    • Like Like x 1
    • Informative Informative x 1
  7. May Rears Apprentice Engineer

    Messages:
    355
    I'm pitching in on this one. I do not know if it is a bug or user error but I had the old bug of a mod being subscribed and selected from the mod menu but the items from that mod not appearing in game. The usual "cure" is to delete the .sbc mod files from 244850 to force a download but the game now goes through the "checking for updates" screen and doesn't actually download any of them.

    A bit of google-fu suggested clearing the steam cache but that made no difference, a new game (creative empty world) with a mod I know worked previously (CMDbobs weapons) made no difference either.

    Currently trying a reinstall of SE, not done one for a long time anyway.

    Before I try and wade through the shot-show that is the bug report portal I thought I would check if anyone else has come across this and found a fix.

    EDIT: The reinstall has solved the problem. Mods are downloading properly now.
     
    Last edited: Jan 2, 2019
Thread Status:
This last post in this thread was made more than 31 days old.