Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Cant load game, Cant play at all.

Discussion in 'Technical Help' started by Sisyphus, Jan 21, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Sisyphus Trainee Engineer

    I recently bought the game, as the new planets update really intrigued me. I installed it, booted up the game, and much to my irritation, I cant even start a world. At all. After much debugging, I'm just very frustrated and no closer to a solution. It just freezes on loading easy start earth and never, ever loads. I've given it hours of time, but that doesnt seem to help at all. What else can I try? Should I just refund the game, and it wont work on my PC for some reason?


    Just the Important Info:


    • Game Never, Ever loads on Easy Start Earth. Loads fine on Empty World. When trying to start an easy start earth world, the loading icon spins for about 4 minutes, then just stops spinning and the program either hangs or crashes. Sits at about 75% ram and 45% CPU usage for first for minutes, then keeps Ram but CPU usage drops to ~2%. Does produce a file to "Load", but runs into exact same issue when clicking continue. I suspect its some sort of DirectX issue?
    System Specs:

    • Windows 10 (x64), GTX 970, 8gb ram.
    Things I've already Tried:

    • Switching to DX9 and back to DX11
    • Deleting SpaceEngineers.cfg
    • Running in Windows 7 Compatibility Settings
    • Reinstalling Graphics Drivers
    • Lowering settings
    • Waiting 1hr (!) to let it load
    • Verifying install integrity
    • Restarting PC (Of Course)
    • Running in offline mode
    • Checking D:woot:iag to make sure DirectX is fine (it is)
    • Reinstalling Game
    • Running in Widowed Mode
    Log File:
  2. sankti Trainee Engineer

    I think 8 gb of Ram is just not enough for this version today, And I have tried same things like you !! Only upgrading my ram to 16gb solved problem, and world ate at start 10gb of ram! It's just survival on alien planet FFS

    are you enjoying Out of Memory error ?
    Last edited: Jan 23, 2017
  3. Sisyphus Trainee Engineer

    Odd. I'd think "16 gb of ram required" would be something- mentioned somewhere on the page. Ouch. That- ups the price of play by a bit.
  4. bigsteve Trainee Engineer

    I play with 8GB of RAM so its not that.
    You are using Graphics Drivers from 2016-10-07 DriverVersion =
    I am using DriverVersion = Date 2016-12-11
    Update them from Nvidia's Website.
Thread Status:
This last post in this thread was made more than 31 days old.