Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Capped at 120 FPS?

Discussion in 'General' started by Wrapperup, Oct 14, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Wrapperup Trainee Engineer

    Messages:
    29
    Just built a new PC and wanted to try out Space Engineers, but I've run into a somewhat annoying problem.
    I've read around wondering whats up with the 120 FPS cap and I kinda understand what's up with that (the whole 100M fps on main menu), however, when playing on a 144hz monitor, it doesn't look very smooth.

    Is there any way to bump this up to atleast 144hz? Can Keen save us from this terrible fate?
     
  2. Malware Master Engineer

    Messages:
    9,663
    Not likely. Knowing Keen it's probably hardcoded and frankly, in this case, I can understand why. Just how many people do you think use 144hz monitors? :p

    They don't even fully support 4K yet.
     
  3. Inflex Developer Staff

    Messages:
    397
    We could prolly lift the cap a little bit, but better question is, is your HW really able to maintain those 144fps all the time?
    I mean lifting the the cap doesn't really make any difference when you are in complex scene and game runs "only" 60fps or so, which is usually more than OK for most players but will again look badly on 144Hz monitor.

    Then there is other thing that the actual simulation is running at 60 ticks per second so even if you are able to render +120fps, you are basically wasting you performance cos you are always rendering 2 same frames.
    --- Automerge ---
    Also, this sounds like a better monitor, don't you have some variable V-sync tech inside like GSyc or FreeSync, these are meant to cover exactly this type of problems.
     
  4. Wrapperup Trainee Engineer

    Messages:
    29
    Yeah it can (atleast I think it can). FPS sticks at 120 fps and dips when doing any of the complex physics stuff. First world problem here: it does drop to about 70-80 fps on the absolute highest graphic settings (the extreme graphic settings), but doing the high preset or lower caps it at 120.

    Specs:
    i7 8700k
    GTX 1080 TI
    16gb ddr4

    Unfortunately my monitor doesn't support GSync or Freesync so it doesn't look great when it isn't 144hz

    I know the problem is a lot more complicated than just increasing some numbers (UE4 dev here)
    Hopefully you guys can do something about it, it would be really nice!
     
    Last edited: Oct 14, 2018
  5. Inflex Developer Staff

    Messages:
    397
    From render perspective, lifting up the cap indeeed is simply aamatter of changin a single constant, but it won't help with your shuttering cos simulation is fixed at 60 tick per second.

    Given that the render would run at 144fps. It would mean that every simulation frame would be rendered somewhre between 2 and 3 times, causing the same stuttering, just at the different level of the pipeline (This time in render, not in your monitor).

    To solve your issue, I'd recommend switching your monitor to 120Hz (if you can) and enabling VSync. This way the entire pipeline, simulation, render and your monitor, will be in sync and providing the best possible experience.
     
  6. Oskar1101 Apprentice Engineer

    Messages:
    232
    This game doesn't do interpolation?
    I mean your idea with 120fps and vsync is best option anyway but that shouldn't be true that in 120fps game renders same frame twice because animations and some other things shouldn't be bound to physics.
     
Thread Status:
This last post in this thread was made more than 31 days old.