Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Dedicated Asteroid Settings

Discussion in 'Groups & Dedicated Servers' started by SultonMRP, Aug 26, 2019.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. SultonMRP Trainee Engineer

    Messages:
    77
    On my server the asteroids are smaller and has every little resources since i did a wipe for economy release, is it something new? how would I change it so there are larger asteroids with more resources on them?
     
  2. mojomann71 Senior Engineer

    Messages:
    2,005
    I think the fewer resources was on purpose, I can't say with 100% certainty though.
    You could do a creative session voxel hand in some ore spots then flip it back to survival.
    Or try using SEToolbox, not sure if it is reliable any longer though since Midspace stopped supporting it.
     
  3. Roxette Senior Engineer

    Messages:
    1,546
    Look for the <VoxelGeneratorVersion> setting, probably duplicated in both the sandbox file of the save and the server configuration file. You can try changing the number to use earlier versions. This has usually worked in the past and seems to work currently, though it may have performance impact or other side effects.
     
  4. Roxette Senior Engineer

    Messages:
    1,546
    On further looking, I realised it's even easier, the settings are exposed in the dedicated server GUI and are present on both local and server games, in the Sandbox.sbc file, and of course duplicated in the SpaceEngineers-Dedicated.cfg file because duplicate data is considered a good thing at Keen....

    <DepositsCountCoefficient>8</DepositsCountCoefficient>
    <DepositSizeDenominator>75</DepositSizeDenominator>
    <HarvestRatioMultiplier>3</HarvestRatioMultiplier>

    Try playing with the numbers - note that these options are only processed with the current voxel routine:

    <VoxelGeneratorVersion>4</VoxelGeneratorVersion>
     
Thread Status:
This last post in this thread was made more than 31 days old.