Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Dedicated Server [01.054.009] - Unable to queue production in Assemblers

Discussion in 'Bug Reports' started by ScubaSean, Oct 31, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. RTM Apprentice Engineer

    Messages:
    285
    Not true.

    You can turn on cargo ships and survive on those alone. With stealth-ships, taking on a cargo ship is quite doable.
     
  2. MangaYuurei Trainee Engineer

    Messages:
    9
     
  3. doctorbutts Trainee Engineer

    Messages:
    5
    Is there a way to do rollbacks? Because this game really needs it.
     
  4. dakatl Trainee Engineer

    Messages:
    2
    I did notice that when checking the inventories from terminal all the items in the assembler were present but once i went to 'production' none of the 'minerals' were present anymore in the assembler inventory, only the other hard items. perhaps a table was misplaced in the database.
     
  5. kiwimatsch Trainee Engineer

    Messages:
    7
    weekend gone.. if keen fix that next thuesday i realy pissed off about.. seems like one man developing show... so massive bug not fixed within hours is a nogo realy.. keeen sleep araound on a realy gorgeous game and do all that community is in rage..

    iam so pissed off about this F*** bug for real.. more than 15 players from our community cannot play on our survival server that we pay for.. for days.. or weeks?.. i realy dont think that a hotfix come these days..

    i think that signal is clear from keen today:

    f**** off community.. it seems like they are not interest about the hundreds of players actually they cannot play


    a disaster this time!

    real

    regards

    ballerkneipe.de
     
  6. Koder Apprentice Engineer

    Messages:
    216
    Alright I'll give you that. It's definitely not unplayable (I just never play with cargo ships on when there are asteroids, cargo ships are ez mode). I didn't make possibly one of the most difficult respawn ship mods in the community, just for me to go grab a cargo ship and win.

    I have played empty world survival pretty regularly in the past, and its possible to live exclusively off of cargo ships, even with no spawn ship to start with. No need for stealth ships, just go for a business shipment first to stage off of.

    In multiplayer with the frequent rubberbanding and lag, I seldom see this as an enjoyable experience.
     
  7. kiwimatsch Trainee Engineer

    Messages:
    7
    nope.. its unplayble for gamers they want to assembly stuff!

    not rope from ki

    your idea is OK but not the solution
     
  8. vsimoesbh Trainee Engineer

    Messages:
    35
    People keep saying about the Cargoships, to use it until the fix dont comes.


    Well, we would if the turrets were nothing CRASHING THE GAME AT SERVER SIDE.
    So basically, with cargoships the chances of a server crash increases like hell, so no we cant do that too.
     
  9. dicaetra Trainee Engineer

    Messages:
    5
    This seems to be an issue in Multiplayer shared games as well. I can queue production, but my friend connected to my game cannot.
     
  10. theonemanyuri Trainee Engineer

    Messages:
    13
    Keen really need to acknowledge this bug, I can handle a bit of a wait as long as it's clear it's being worked on. There's nobody on our server any more, the game's pointless without assemblers
     
  11. Koder Apprentice Engineer

    Messages:
    216
    Yeah in my testing so far, it seems only the host can queue. This had led to some team-based gameplay, but it really sucks not being able to queue when the host just wants to do his own thing and you're at the mercy of whatever they want to queue.
     
  12. vangrunz Apprentice Engineer

    Messages:
    401
    I can confirm that assemblers are unable to be queued on our dedicated server, too. However, existing production queues are working fine.

    Additionally, I have the feeling that the assemblers eat up internal fps. If you boot your avatar 1 s forward, it needs more than 8 to stand still again. This is not normal.
     
  13. JohnB Trainee Engineer

    Messages:
    5
    Got up this morning hoping for a hotfix.. still nothing. Maybe one more post will speed things up..??
     
  14. Marsh007 Trainee Engineer

    Messages:
    6
    Well Keen - any news - a lot of people are getting a bit annoyed - 1 Million copies sold - Support please.. Test your patches before release..
     
  15. Marsh007 Trainee Engineer

    Messages:
    6
    Does anyone in the Dev team actually fully test their patches.. hmmm... before releasing them - Would be a good time to have a response to this issue I think.
     
  16. kiwimatsch Trainee Engineer

    Messages:
    7
    downgrade your game, .. i call to my server provider today that they downgrade my server, i think is the only solution in these crazy situation
     
  17. Dark_Fox Trainee Engineer

    Messages:
    2
    when will be repaired assembler? wanted to play this weekend :(
     
  18. Dark_Fox Trainee Engineer

    Messages:
    2
    when will be repaired assembler? wanted to play this weekend :(
     
  19. penance Trainee Engineer

    Messages:
    1
    Me and a friend on our dedi have come up with a temporary fix for this issue.

    We took our server down and started it up single player.
    Created 1 assembler for each component, queued that component on infinite.
    Saved the game and uploaded it back onto our dedi.

    Now all we have to do is toggle the assembler for the desired component on.

    we generate any component and because of the dedicated assemblers we actually do it faster than before this bug. Assemblers are not really that expensive to make so I think this method works really well if you wanna continue playing while keen fix the bug.

    Hope this helps!
     
  20. ArtofWar Trainee Engineer

    Messages:
    97
    That actually is a good idea, but in retrospect on dedicated servers, this will either result in giving assemblers to everyone to account for all of the different components the can be produced and with mods this number can be 30+. And say someone joined the server and were given the assemblers to make items, this isn't fair to the players that had to work from the ground up. Granted that this situation may call for such actions to get anything done and not everything will be 'fair' for everyone, but this is what it is no matter how you look at it:
    Either Keen made a serious mistake and it was overlooked in the closed testing group, this wasn't reported as a bug, the closed testing group is being ignored by Keen, or Keen seriously needs to get their act together and actually look for bugs and provide prompt hotfixes on occasions like this to keep the community happy and the game playable.
     
    Last edited by a moderator: Nov 3, 2014
  21. SocialSystem Trainee Engineer

    Messages:
    2
    Spent the last few days grinding respawn ships down for parts as the dedicated server I play on does not have NPC ship spawns. I would have hoped for some statement acknowledging there is an issue with assemblers and that they are indeed working on a hotfix for the issue. I can understand having a weekend away from work but I am assuming they have been in the office/garage for at least half a day now and still no word.

    As a side note Amazon have stopped selling the game as it is under review based on the description.
     
  22. Phand Master Engineer

    Messages:
    9,650
    Hi,

    this should be fixed in today's hot-fix.
     
  23. SocialSystem Trainee Engineer

    Messages:
    2
    Phand,

    Thank you for giving an update. Glad to hear from the team that your aware and working on it.
     
  24. Spatsy Trainee Engineer

    Messages:
    1
    Thanks Phand, Way to start your Monday Huh.
     
  25. ElGordo Trainee Engineer

    Messages:
    7
    good news Phand but I feel I gotta say.............

    the assembler bug was a pretty big deal for those of us who play survival.

    I think everyone is appreciative of how Keen provide weekly updates and we are ( or REALLY should be !! ) aware that it is still a alpha game, however ......

    I think you guys should've acknowledged the bug straightaway and let us know that you were on it. We obv assumed you were but a little reassuring post would've helped prevent at least some of the "rants"

    it was clearly a serious issue for you as it has taken a few days to sort but keeping us updated wouldn't have hurt

    haven't tried it yet but fingers crossed its sorted

    Edit - I have - it is - nice one
     
    Last edited by a moderator: Nov 3, 2014
  26. ScubaSean Trainee Engineer

    Messages:
    4
    Ty for the response and fix!
     
  27. Phand Master Engineer

    Messages:
    9,650
    Hi,

    I am truly sorry for inconvenience guys. Thank you for kind reposes. We are doing what we can, but sometimes we just screw up. :( Take this one on me. :(
     
Thread Status:
This last post in this thread was made more than 31 days old.