Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Dedicated Server not listening on ports

Discussion in 'Groups & Dedicated Servers' started by TechnoRush, Mar 10, 2019.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. TechnoRush Trainee Engineer

    Messages:
    2
    I'm trying to run a dedicated server for my small group of friends and I'm having the time of my life trying to configure it.

    Basically from what I can tell the Dedicated Server / Service is not even trying to listen on the default port or custom port I've specified.

    Meanwhile if I run a dedicated server from another game or even another service for another program on the same exact port ( 27016 ) the port opens up and I can see it.

    I've already tried the following.
    • Running as Admin
    • Disabling UAC
    • Turning off Firewall
    • Putting myself on DMZ
    • Doing Firewall and DMZ together
    • Creating a new instance instead of the Local / Console
    • Using another port
    • Forwarded the Steam server port
    • Grabbing a fresh copy of dedicated
    • And finally all of the above together
    Any input is appreciated. Log files to follow if I can find them.
    --- Automerge ---
     
  2. Roxette Senior Engineer

    Messages:
    1,546
    Bind the server to the IP address of the network interface that is the machine's route to the rest of the world. (the "Listen IP" in the 'General' tab of the server setup UI or the line " <IP>188.201.87.5</IP> " in the SpaceEngineers-Dedicated.cfg
     
  3. TechnoRush Trainee Engineer

    Messages:
    2
    Doesn't work.. Even tried the Public IP just in case, nope.
    --- Automerge ---
    I used to be able to see the server on the "LAN" tab but now it's not there...

    Scratch that, I can see it on LAN now. I had some filtering on the server browser but what's below is still true.

    I can't direct connect to it from 0.0.0.0:27016 but I can direct connect to it via my system's local IP 192.168.X.X:27016
     
    Last edited: Mar 11, 2019
Thread Status:
This last post in this thread was made more than 31 days old.