Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Dedicated Server: Program Block breaks batteries.

Discussion in 'Bug Reports' started by Captain_Locke, Jul 3, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Captain_Locke Trainee Engineer

    Messages:
    7
    Being in a ship with a battery drains power as normal. If the ship has a programmable block attached, the battery drains power as normal, but when you exit the ship and re-enter the MWH is reset to whatever the value was when the block was added.

    Being outside the ship while it is draining power works as normal. This only happens when you are inside the cockpit.
    --- Automerge ---
    Let me rephrase this so it makes more sense.

    Vanilla server, fresh world. Made a simple ship with landing gear, thruster in each direction, cockpit and a battery.

    Get in ship, battery is at 324mwhr, drain it a bit by moving around down to 300mwhr. Get out of ship, get back in ship, battery is at 300mwhr.

    Build a programmable block onto the ship, get in the cockpit, now the battery is reset to 324mwhr. Move around, drain the battery back down to 280mwhr. Get out, get back in, battery resets to 324mwhr.

    Now, get out of the cockpit let the ship hover. Drain the battery to 280mwhr. Get in the cockpit, battery is at 280mwhr. So. This bug only happens when a ship is being actively piloted.

    Remove the programmable block, and everything works perfectly.
     
Thread Status:
This last post in this thread was made more than 31 days old.