Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Dedicated server will not start with mods

Discussion in 'Technical Help' started by maahes, Dec 29, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. maahes Trainee Engineer

    Messages:
    2
    Having some issues with a dedicated server that was working fine up until a restart to switch to creative to restore a ship that shook itself apart.

    Log at point of failure:

    Code:
    Thread:   6 ->     MySandboxGame.LoadData() - END
    Thread:   6 ->     Downloading world mods - START
    Thread:   6 ->        Server connected to Steam
    Thread:   6 ->        Server PolicyResponse (1)
    Thread:   6 ->        HTTP: error Invalid
    Thread:   6 ->        Could not retrieve mods details.
    Thread:   6 ->     Downloading world mods - END
    Thread:   6 ->     Unable to download mods
    Thread:   6 ->  MySandboxGame.Initialize() - END<div>Thread:   6 ->  Timer Frequency: 2337889
    Thread:   6 ->  Ticks per frame: 39128
    
    The log file ends at this point.


    </div>Seeing the above error I removed all the mods from the config and the server starts just fine. One at a time I tried each of the 4 mods I had used and all produced the same error. I also tried a random mod from the workshop and no luck.
    All mods load fine in a non-dedicated game.

    The service shows as Started, and the Dedicated Server Configurator becomes unresponsive after clicking "Save config and start". Both processes must be killed through task manager.

    I backed up and deleted all saves, config files, instances and core dedicated server files/content. With a fresh install from the zip and a new instance/map/config the error persists.

    The server can browse the workshop and each mods URL, Im not sure what HTTP URL it is trying to reach that is failing.



    Edit: The issue has resolved itself. I am guessing something on the Steam side was broken that they fixed. Ill leave this info in-case someone else has the issue.
     
    Last edited by a moderator: Dec 29, 2014
  2. xGlitchInHumanityx Trainee Engineer

    Messages:
    8
    I have this exact same error
     
  3. xGlitchInHumanityx Trainee Engineer

    Messages:
    8
    RESOLVED THE SAME ISSUE!!!

    After 3 days of troubleshooting, my buddy had the bright idea of sending me the .sbm files for the mods on the server, which I saved in the "%appdata%\Roaming\SpaceEngineers\Mods" folder.

    I then connected to the his dedicated server and PRESTO! it worked!!!!

    I am not sure if this is a caching issue or whatnot, but the files never actually downloaded as the folder was continuously empty.

    After having re-installed the game, so many times and even deciding to re-install steam, this was the fix I needed!

    Hope this works for you!

    Cheers!

    xGlitchInHumanityx
     
  4. Finkhrek Trainee Engineer

    Messages:
    1
    Hi there,

    I had the same issue and did find out the problem. My dns wasn´t working well on the server so the dns requests couldn´t be handled =). I fixed my dns server and now the server downloads a entered mods.
     
Thread Status:
This last post in this thread was made more than 31 days old.