Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Dedicated Server wont appear on browser

Discussion in 'Groups & Dedicated Servers' started by bigbangnet, Mar 30, 2019.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. bigbangnet Apprentice Engineer

    Messages:
    137
    Hello guys,

    Need help with this one as this is a curious one. I can't seem to see my server on the browser list. I can connect (direct connect)to it just fine, I can play on it just fine but it just doesn't appear on the list.

    Heres my setup and some information.

    First the console of what it says when its just started:
    https://www.pastiebin.com/5c9d4a31acba2
    of course the Ip is wrong but its giving me the public Ip which my modem gives or when I type whatismyipaddress.com or something similar

    my setup is I have 1 modem/switch (Bell crap) and 2 computers on it.
    1 computer has windows 10 which acts as my dedicated server and my modem forwards all ports needed to it on that computer (I call it workstation.
    1 other computer which I use for gaming and other use (no porn :) )

    So when I go on my gaming PC I search for the name of my server like "fluffy" and I can't see anything.

    I forwarded the port 27016 on my Bell modem

    port 3389 and 3390 are open and good. I use it for my job. the ftp is working but its turned off for now so port forward is working on my router. But the 27016 isn't working. Its stills says its closed when I test it online. All others say its open when I test it.

    I even tried to turn off my firewall and putting my "server" (where my game is running) in DMZ on my router.

    I have a feeling its because of my port forward thats not working. I need help please lol
     
    Last edited: Mar 30, 2019
  2. Roxette Senior Engineer

    Messages:
    1,399
    It is probably working fine. You need to ask a friend to look for it and try to connect from outside your LAN. This is a common red herring caused by the way the game server list works with Steam. The game requests details of servers from Steam which responds to the game with a list of addresses that it knows are running the server, and the game then queries those matching your search settings, and those that respond are listed. The game will thus be trying to query your server status via its external ip address, which will fail.
     
    Last edited: Mar 30, 2019
  3. bigbangnet Apprentice Engineer

    Messages:
    137
    uhh I should of asked this earlier. can someone try and tell me if it works or not ?

    fluffy.servegame.com:27016
     
  4. Roxette Senior Engineer

    Messages:
    1,399
    I was connected to it yesterday :)
     
  5. bigbangnet Apprentice Engineer

    Messages:
    137
    ahh ok, I saw your name there. ok then its working. thanks for the help then.
     
  6. Dereknor Trainee Engineer

    Messages:
    81
    We got the same Problem with out server. We can all connect via IP, and we can save it in our favourits and see it in our server history. But the server doesnt appear in the server list.

    This means, only people who know the IP can join the server. Thats why we are always the same 4 people on the server, and there has never been joining anyone who didnt know the IP.

    Thats bad because we wanted to make an open server for all people.
     
  7. bigbangnet Apprentice Engineer

    Messages:
    137
    Only I can say to help you is go through the list here : http://www.spaceengineersgame.com/dedicated-servers.html and make sure to go through every steps and if you need to verify and you're not sure how, just ask. Just put every detail you can in a new post and people will help you.
     
Thread Status:
This last post in this thread was made more than 31 days old.