Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

DS null error on server start

Discussion in 'Bug Reports' started by zjn2002, Mar 19, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. zjn2002 Trainee Engineer

    Messages:
    9
    Whenever I start up my server this shows up in the console:

    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown – see comments in hkStackTracerWin32.cxx)'

    Anyone know what this means or where in the file system of the game I can find the comments mentioned in the null 0 lines?
     
    • Agree Agree x 1
    • Informative Informative x 1
  2. Neitronus Trainee Engineer

    Messages:
    10
    Same, using SESE and Essentials plus bunch of mods, supposed to work with recent patch, but still wondering.
     
  3. Amerikanovich Apprentice Engineer

    Messages:
    323
    We get the same thing on our DS, everything seems to work fine though, our thoughts were that maybe they forgot to remove a bit of code from the startup routine causing it to search for objects that no longer exist, but who knows.
     
    • Informative Informative x 1
  4. Neitronus Trainee Engineer

    Messages:
    10
    Anyway this causes my server to drop performance by 1/6. So i believe this has something to do with multithreading.
     
  5. Diegor34 Apprentice Engineer

    Messages:
    108
    Same here, i got this msg every time I start my server, i'm trying to figure out what it means.
     
  6. Soulthule Apprentice Engineer

    Messages:
    362
    I am having the same issue with my server. I receive the same null message. Also, noticed a huge sporadic and drop performance at times .25/.30 sim speed. I have not see anywhere near this level of performance drag for months. Usually 5 or 6 players the server may show at the worst. .82/.85....
     
  7. Apocalypse07 Trainee Engineer

    Messages:
    30
    Same here...

    Dedicated Server on Windows Server 2012R2
    No mods
    Loaded map were created in version 0.125
     
  8. Diegor34 Apprentice Engineer

    Messages:
    108
    Up, this must be at least evaluated by a dev, or at least have the confirmation that keen read this
    this msg is showing even more in my server.
     
  9. Prescott Freyd Senior Engineer

    Messages:
    1,833
    Hey guys,

    we know about this message, our programmers will take a look at it :)

    Regards,
    PF
     
    • Late Late x 1
  10. DoctorSweety Trainee Engineer

    Messages:
    12
    yeah, take a look, we works for SE community spending lot of money to open server for gamers buying your game to have multiplayer experience . Yes, i know, i know, my english is ugly and the game is in alpha, but i know one more thing. It's time to do SOMETHING for MP/DS players, we don't want rollback update, we don't want streaming, we don't want to see a guy in a youtube video speak about.... nothing... Is like to fuck a fly..... WE NEED SOLUTION, HOTFIX, S.O.M.E.T.H.I.N.G......

    Angry Regards
     
    • Disagree Disagree x 5
    • Agree Agree x 1
  11. Ramius86 Trainee Engineer

    Messages:
    3
    I got this message spammed A LOT while server start and even while server runs, without mods. This happens a lot when someone mine on earth and server drop performance making the game almost unplayable, you can't simply mine on earth.
     
  12. Bobylein Apprentice Engineer

    Messages:
    201
    We get this message spammed in the server console once someone starts mining for about 20 seconds and the server simespeed drops from 1.00 down to 0.2 Any ideas already what causes this?


    Edit: Also it only happens if you mine boulders
     
    Last edited: Apr 4, 2016
  13. Diegor34 Apprentice Engineer

    Messages:
    108
    I had to shutdown my server, i noticed that the CPU usage has increased a lot in one of the cores, besides the bugs in the animation and everything else, the players of my server got tired, i got tired also, a lot of work to assemble/maintain the server, to stay in agony with updates that look like Russian roulette.
     
    • Like Like x 1
  14. TheNudeNerd Trainee Engineer

    Messages:
    74
    This definitely needs fixing, all I see is this spam in the console window over everything else.
     
  15. Ramius86 Trainee Engineer

    Messages:
    3
    Error still present in latest patch
     
  16. Stormer Trainee Engineer

    Messages:
    2
    You may know the game is alpha... but you sure dont act like it. if you want a fully polished games, why dont you wait till it's release?
     
    • Like Like x 1
  17. DoctorSweety Trainee Engineer

    Messages:
    12
    .

    Sorry, but there are things that i can't understand, rotors, pistons for exemple still buggy (a little bit less than 2 years) in DS. We are limited to build something nice but simply, it's an example and server administration is a nightmare.... i don't know why they add "cosmetic" content and no repair old broken stuff.... I spend 3000 hours in this games, and i love it, this game have lot of potential that's the reason why i was angry this day.... But i still playing....
     
  18. Stormer Trainee Engineer

    Messages:
    2
    I only started playing a few months ago, had a fair amount of frustration with some of the bugs so far. But from what I understand, Alpha is the stage where you add all the features of the game, Beta is where you work out the bugs. Then you release hoping you have not missed to many bugs.
    That being said, the game is still in alpha, so for myself, I expect a lot more frustration from bugs before they move on to beta.

    and I agree with you, this game as so much potential, i'm eager to see 2 years from now where we will be at.

    Cheers!
     
    • Agree Agree x 1
  19. CrookedTube Trainee Engineer

    Messages:
    37
    Been getting the same error for weeks. I am running a private DS hosted by an official SE server provider, Bluefang.
    Upon startup of the server I counted 22 immediate entries of:

    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'

    At times when I am playing, or right after I am playing there will be a new one of these every 3-4 seconds. It drowns out anything else in the server log.

    Oddly, sometimes after exiting or multiple restarts, there are no recurring entries of this, just the initial few of them.

    Right now there are no other players on the server, so I can't figure out why it will be showing this at some times and not others when I am not in the game.

    I will try and find some more ways to reproduce it. If anyone has any tips I should try please let me know.

    r/
    CrookedTube
     
  20. Drakrtar Trainee Engineer

    Messages:
    3
    I also have this issue on our dedicated with Oorahgaming in fact since todays server update stuff it has been happening much more frequently and even froze the server. My log was filled with it


    EDIT: We just noticed after a jump drive use once we reappear this message spams like mad and we lose server connectivity almost completely as it just keeps spamming this until it slows to a crawl. Unplayable.
     
    Last edited: Apr 15, 2016
  21. CrookedTube Trainee Engineer

    Messages:
    37
    My server is now unplayable. I see hundreds of these entries in the server log when I restart it when I used to just see a few dozen.

    Tried to log into my private DS server after the update and get "Host Disconnected" (I am the only player)

    I downloaded the server files and tried to play in SP and it just hangs in the initial load screen.

    I also tried a repair with SEToolbox and no luck.

    Couple hundred hours down the tubes right now, will try and see if I can copy my ships and space station out of the corrupted/broken world but will have to figure out how to do that on the weekend.
     
  22. Drakrtar Trainee Engineer

    Messages:
    3
    Any devs able to comment on this as it stands right now our server is unable to stay active as soon as we log in this hk spam just floods the server slowing it to the point it does not function.
     
    • Like Like x 1
  23. JTConsortium Apprentice Engineer

    Messages:
    290
    I am seeing that too pretty regularly now
     
  24. CrookedTube Trainee Engineer

    Messages:
    37
    I was able to paste my few ships and station into a fresh world using SEToolbox. Still getting these errors.

    This is my log after pasting a few ships into a fresh world, and starting the DS server for the first time:

    2016-04-15 17:29:49.771: Loading session: C:\bluefang\servers\serverxxxxx\DedicatedServer64\Saves\myworld
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    2016-04-15 17:30:31.697: Session loaded
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    (null)(0):'(unknown - see comments in hkStackTracerWin32.cxx)'
    2016-04-15 17:30:45.228: Game ready... Press Ctrl+C to exit


    My question to my fellow sufferers, are you running any mods? If so, which ones?

    I'm using
    • Midspace Scan mod
    • Midspace unlimited speed mod
    • Nanite Control Center
    Regards,
    CT
     
  25. Marko Trainee Engineer

    Messages:
    2
    Hi,

    I am having the same report filled in my console!!

    There are like 500 lines of these and server is slower and slower. Would be nice if someone fix this problem or just say what is the prolblem so we can handle with it!!!!!

    Reg Marko
     
    • Like Like x 1
  26. Ingar Trainee Engineer

    Messages:
    3
    I'm getting this error since 01_132_007 and did some googling. The error seems to originate in the Havok debug routines, so it is most likely a physics-related crash.
    (see http://transporter-game.googlecode....emory/StackTracer/Impl/hkStackTracerWin32.cxx ). The code mentions an MSDN article, the link doesn't work but the article can be found here
    https://msdn.microsoft.com/en-us/library/windows/desktop/ms679294(v=vs.85).aspx
    which basicly says that the dbghelp.dll you have installed is outdated. Updating dbghelp.dll should reveal the actual error, but I haven't tried it yet.

    TL;DR: it's a physics crash, but you need to install updates to see the actual error.

    * Update: I get a lot less messages after deleting all floating objects in the world.
     
    Last edited: May 2, 2016
Thread Status:
This last post in this thread was made more than 31 days old.