Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Faction Join & Crash Glitch

Discussion in 'Bug Reports' started by Phazonic, Apr 4, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Phazonic Trainee Engineer

    Messages:
    2
    As soon as a friend of mine attempts to join the game, he is automatically put into the faction "Space Spiders." It resulted in sound playing for a moment, then the warhead explosion sound playing, and proceeded to crash the game itself, Discord, and Java. I'm not sure if it was a Java error or has something to do with the world (I have had a few issues with sound blocks and the inventory on this world, however the world is completely up to date), but I am afraid that the next time he joins that it may crash his PC.
    [​IMG]
     
    Last edited: Apr 4, 2016
  2. Bobylein Apprentice Engineer

    Messages:
    201
    Can confirm the part that players are being put into Space Spiders faction, also they can't leave the faction even if one removes them out of it in the .sbc file, hence one of my friends can't join our faction :(
     
  3. Prescott Freyd Senior Engineer

    Messages:
    1,833
    Hey guys!

    Thank you for the report. How often does the issue occur? Is it happening to the same people over and over or does it seem random? Also, if you have a world where the players are saved in the Spider faction, could you please share it with us?

    Regards,
    PF
     
  4. Phazonic Trainee Engineer

    Messages:
    2
    Thank you for the response.

    As for how often, its every time my friend attempts to join. I had to create another world and transfer a few of our builds over as well. I noticed that while I was in the faction menu, random member tags popped up with no names next to them under the founder. The world was heavily modified (20 + large mods) however the new world I created without that many mods (5 small mods, none I used in the other world) is starting to appear to get the same issue (menu glitches and the sound block plays distorted sounds). I'm afraid I cannot share the old world as it has somehow become corrupted. If it happens on my new world then I will share it. I will also continue to test out whether or not the mods are causing it or if it has something to do with spawning planets.

    I should also mention that the first time my friend attempted to join, no sound played and his camera was stuck at an odd angle. Not too sure whats going on with the factions currently but its rather worrying.
     
    Last edited: Apr 4, 2016
  5. Bobylein Apprentice Engineer

    Messages:
    201
    We get this error now with every player that joins, note that it's not happening since the beginning but just since after some hours of world creation.
     
Thread Status:
This last post in this thread was made more than 31 days old.