Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Half built ship vanishing.

Discussion in 'Gameplay Help' started by InvertedCow, Oct 21, 2018.

  1. InvertedCow Trainee Engineer

    Messages:
    15
    Here is the thing. I had a ship in space that I was using to mine while I built it up, Single player game.

    I got a touch too close to the planet and got caught in the gravity well. As you can imagine 2 small thrusters in each of the six directions were not enough to rescue three days of grinding and welding and mining. The impact crater was awesome. But all that survived was the control station, 4 drills, several large container's contents of ore, but not the containers, and the ejector port for the stones. I was able to salvage enough to build a small craft cockpit, and 4 large cargo containers. Mostly by building one, filling it, then grinding it down to as close to nothing as I could and repeat the process. I had transferred the contents from the ground and salvaged the drills and other random bits. I started the build of a small reactor as my power was now down to redline.

    When a probe landed I ran over to it, (About 2 km away), took the refined urainum and ground the reactor for components. I returned to my building site and everything except some of the large chunks of minerals were gone. All the backup games were refreshed but the journey there and back had recycled my backup games past the point where the ship was there.

    Is this common for half finished player grids to vanish? I was annoyed that the drills full of ore had vanished before but to have everything vanish. This is seriously messed up.

    2 years ago I walked away from space engineers because it was so buggy that it became un enjoyable. I can see that in 2 years keen still has not resolved anything.
     
  2. WraithLeader1 Apprentice Engineer

    Messages:
    402
    Try SEToolbox by Midspace… Look at your save and see if you can find the ship....
    I can think of 2 things off of the top of my head;
    1 - It fell though the world
    2 - Auto-cleanup got you... It acts strange sometimes.

    I haven't experienced this 'Bug' but, who knows....
     
    • Like Like x 1
  3. Spaceman Spiff Junior Engineer

    Messages:
    553
    It IS infuriating when auto-cleanup “disappears” stuff; I’ve had it happen way too many times. So now, before I run off to grab a precious drop pod, I make sure the partial salvage assemblies have at least 20 blocks (I think that’s the default threshold) so it won’t be removed by auto-cleanup. Also, save often when you’re playing survival mode so you can restart if something like this happens.
     
  4. InvertedCow Trainee Engineer

    Messages:
    15
    Ok thanks. I was unaware of the auto cleanup, So it never occurred to me that would be the cause. Either way a total restart is in order to attempt to play again. IS there any way to remove the auto cleanup feature?
     
  5. Roxette Senior Engineer

    Messages:
    1,094
    The settings for it are specific to each individual game save and can be found in the alt-F10 admin screen under the 'trash removal' option.
     
  6. mojomann71 Junior Engineer

    Messages:
    728
    This is the reason why I always turn off auto removal. :)
     
  7. Roxette Senior Engineer

    Messages:
    1,094
    I am sure many do. It is a shame that it must be done per save at a third or fourth-level menu option and not set as a default option overall.