Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Help with dedicated server Crash at VRage.Compiler.IlChecker..cctor

Discussion in 'Technical Help' started by CatMan, Apr 17, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. CatMan Trainee Engineer

    Messages:
    2
    Hello all,
    I am trying to get a dedicated server running again, however I keep running into this error. I am running the server on a dedicated box. The error always starts with:
    Code:
    Could not find environment item definition for MyObjectBuilder_DestroyableItems/SnowFoliagexxxxx
    I have tried downloading a fresh server zip and starting a clean game, no mods.

    Here is the server log pastebin for easy reading:
     
  2. CatMan Trainee Engineer

    Messages:
    2
    Has anyone else run into this?
     
  3. CptTwinkie Master Engineer

    Messages:
    4,458
    This is a known bug related to some issues with Microsoft's .NET Framework. There is a hotfix rollup available from Microsoft that repairs and updates .NET.


    You can acquire the patch at https://support.microsoft.com/en-au/kb/3120241
     
  4. Dga8705 Trainee Engineer

    Messages:
    37
    I am having this issue as well with the missing texture for snow foliage, and I already have the .NET hotfix that you posted. It keeps crashing my dedicated server.
     
  5. CptTwinkie Master Engineer

    Messages:
    4,458
    the error wasn't the snow foliage. There was crash at VRage.Compiler.IlChecker..cctor. That's what the .NET fixes. The SnowFoliage is harmless
     
Thread Status:
This last post in this thread was made more than 31 days old.