Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Issues spawning on Dedicated Server

Discussion in 'Groups & Dedicated Servers' started by Potatoboy, Jul 31, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Potatoboy Trainee Engineer

    Messages:
    2
    I made a dedicated server before the multiplayer overhaul update that ran with no issues, after this update none of my friends are able to "spawn". I am perfectly able to, I don't run the server off of the same pc I play on. My friends however are able to join, but when they choose a spawn location they get stuck on the respawn screen with the streaming symbol and the game paused thing at the top. I've tried with and without mods on, brand new worlds and reinstalled server files but none of it has worked.

    Any one else experiencing this or have any tips?

    PSA: for everyone trying to install the latest version use this in your browser, it will force steam to download the latest version (.89) steam://install/298740
     
  2. MTXRooster Trainee Engineer

    Messages:
    60
    Do you run any mods (if so, list please). On your 'not a new world' attempts, are any of the players new to your server, or could you get someone who's not been on before to try? When it is stuck on streaming it means (as you may already know) that the server is pushing content to that client. If could do this on an already populated map, say, a player who is rejoining to their med. bay/cryo chamber and have a large base, for instance, or (also likely) if you have a mod that isn't getting along with your updated server.

    What are the specs on the PC you are hosting on? (specifically CPU, RAM, internet upload speed)

    If you are experiencing this with a brand new server install, it could suggest a bandwidth, CPU, or even a RAM issue where for any one reason the server just can't get the client(s) the data they are needing in a timely manner.

    I assume your friends are not on LAN, and are connecting via Internet, and the fact they can 'see' your server (even with a direct IP) would indicate your ports are set up properly, but never hurts just to double check.

    Also, what do the dedicated server logs tell ya? Even if it doesn't throw an exception error or anything there may still be a clue as to what it is doing while they are waiting or something, again, possibly hinting toward a mod issue..

    Lastly, since I know you mentioned you use the steam client to install, and the steamCMD dedicated server install path is a different location, have you checked your firewall rules to ensure the proper dedicated server exe is authorized? You may have some random firewall issue where maybe the steam port is open and available but the game port has an issue. Not probable, but a possibility.. Also, not that it will necessarily mean anything, but does ANYTHING show up on their machines? I mean yes, it says streaming, but do they ever start to see part of their base, a planet, space/stars, any hint of a spawn ship, etc..? Or is it just complete plain blue SE screen? (this will aid in whether ANY data is making it between the server and client rigs)
     
  3. rising Trainee Engineer

    Messages:
    1
    I'm not a 100% sure, but I think this is related maybe - A friend of mine is hosting a dedicated server and any of my friends can join pretty good. I cannot direct and if I join via steam I can join but get the same issue as you have: Im streaming forever.

    That I can join via steam kind of eliminates the possibility of my firewall having sth to do with it, doesnt it? I checked anyways and it doesnt look like it. I got Bitdefender installed tho, if thats a similarity this might cause the problem.
    Also I use antenna cables for internet, not the phone wires.
    We deinstalled all mods and started a whole new world but no changes, so im thinking - espacially since the others can join - that the problem may be on my end. And could be in your case, too.

    Im using windows 10, Intel I7 - 7700K 4.20 Ghz processor, Nvidia Gforce 1080 and 16gb of ram. I tried to copy the game on my SSD Drive with also no effect.

    Any more Information, you may need?
     
  4. foulblade1 Trainee Engineer

    Messages:
    3
    Having the same Issue Don't know any work arounds either.
     
Thread Status:
This last post in this thread was made more than 31 days old.