Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Lag since cargo ship update?

Discussion in 'Multiplayer' started by TheBlackPumpkin, Mar 30, 2014.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. TheBlackPumpkin Trainee Engineer

    Messages:
    44
    The title pretty much says it all, ever since cargo ships came out me and my friends get serious lag. Anyone else having the same issue?
     
  2. Oppositioner Trainee Engineer

    Messages:
    6
    A lot of the lag will be dependent on your system, from what I've noticed a lot of the lag is because of distance from the player.... It seems to me there may not be any type of LOD introduced yet, or the issue may be that once it's brought in it forces our CPU to spike and calculate the movement of all the blocks attached.... Most games that have graphics of massive size are all considered a single object that the system only calculates the origin of the object as it moves... With these ships each block has it's own origin, so every block is calculated differently, as it moves.... So instead of doing one calculation your doing hundreds or thousands.... I would think the best way for your system to be resolved at this pout would be to turn off the cargo ship or to fly to each of them and disable the cockpit as soon as you see them.... From my experience on my closed map with friends when leavin the local area things get a little funky..... We are trying to build a space station 45 km away from the asteroids and all of the players are dying randomly from the death bugs much more frequent in one case a guy was holding completely still and died, in other cases they were trying to fly yellow submarines back to the location and were constantly ejected... So distance from the asteroids seem to be an issue and these ships spawn in some cases 20 km away..... Hope this helps a little in at least understanding

    EDIT: I'm just an observer, if the blocks origins are concentrated on creation with a vessel then I'm wrong, but it's just am observing idea that could be a possibility
     
  3. TheBlackPumpkin Trainee Engineer

    Messages:
    44
    Yea that is what we were guessing aswell, currently in my game we had sent the cargo ships that spawned in that we didnt want out of the map, they are each about 500-600km away, and are getting further out, we may have to restart if that IS the issue.
     
  4. Ender Trainee Engineer

    Messages:
    25
    Ive just noticed almost all of the cargo/drifting ships seem to be glitchy, its not my system either. I run perfectly fine. But Ill be trying to capture one and its just bouncing back and forth, often killing me if im close to it. Ive had a few vessels I cant grind material away to get in (stays at 100% no matter how long I use the grinder), doors don't work, etc.

    I know its alpha and I still love the game, so just adding in some of my noticed issues with the drifting ships.
     
  5. Jeroenv92 Trainee Engineer

    Messages:
    53
    Hmm, i'm not having any lag when these spawn in. Then again, my survival world is pretty empty. 2 refineries and assemblers. A mining ship, reactor, medbay and some solar panels (put the panels in in creative to have that early game emergency power). And one cargo ship that i stole and put near my 'base'
     
  6. ozarkamax Junior Engineer

    Messages:
    542
    not sure if they fixed it since last Thursday but cargo ships only despawn for the host.
     
  7. Zethariel Trainee Engineer

    Messages:
    17
    This is still an issue, and a major one. A friend of mine needs to reboot his PC every once in a while due to the massive calculations that non-existent ships press onto his CPU. Ship despawns need to be a thing, or at least the ability to easily clear unused rubble from the server (like a forced purge that a host could initiate)
     
  8. Morrigi Apprentice Engineer

    Messages:
    240
    Yeah, I've noticed that it's a major problem. Fixplz.
     
Thread Status:
This last post in this thread was made more than 31 days old.