Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Locking small ship landing gear to large ship= large ship ignores planet gravity

Discussion in 'Bug Reports' started by Calaban, Feb 8, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Calaban Junior Engineer

    Messages:
    932
    At first I thought it was the megatons of Hyrogen I was stockpiling in my H2 tanks causing my large ship to act as a "zepplin" when taking off... I noticed my large engine power draws were weirdly minimal (6% instead of typical 60% of power useage)- I was enjoying flying around with this unusual phenominon- thinking the hydrogen boyancy lift countering my ships weight as some sort of "unlisted feature easter egg"- but, with a lack of downward thrusters, I almost drifted up to outer space (!!)

    I barely managed to flip upside down and use the large thrusters to push me back down in time while the atmospheric engines were still working. (whew!)

    After laboriously trying to maneuver my ship back to the surface (for all intents and purposes- drifting without inertial dampeners in outer space- and missing a down thruster), I tested things out; roll to counter all momentum, come to a stop over a lake: motionless. Turn dampeners off: motionless. Turn all engines off: motionless. Gravity had no effect on me.

    Scratching my head in confusion for a bit, I logged out and back in several times- maybe a glitch? relogged and everything was exactly the same. Leaving my flight seat while hovering weightless over a lake, I jumped around a bit: gravity had effect on me. BUT something flew me out in front my my ship violently as soon as I left my chair- whooosh!

    returning to my hovering ship... I decided to power up my small mining ship I had parked on the deck of my large ship- to see if IT was buggy/glitching out as well... the moment I unlocked the landing gear to lift off- my large ship suddenly found gravity! it banked and plummeted and destroyed itself. :<

    Reloading the last save state, I landed my large ship the hard way, with small ship still locked. Then got in my small ship again, and carefully tinkered around with the interlocks. I went to the connector port (which had a landing pad plate for the mining ships to lock both connector and landing gear simultaneously) Hitting P to engage all interlocks: weightless large ship started rifting away- its landing gear still showing green and locked to the ground. Definate bug. Reset everything and tried just the connector: no issues. Tried just the landing gear: glitched bug again.

    Consistent and repeatable. Lock/park a small ship onto a large ship, large ship ignored planets gravity- and its own landing gear locks.

    I guess this is less severe than simulation speed dropping to .18 when same small ship anchoring to large ship event occurs, but darnit!! WHY is it so hard to have small ships parked on large ships work properly?!?
     
    • Agree Agree x 3
  2. Pie Apprentice Engineer

    Messages:
    116
    EDIT - Looks like they're aware of the issue

    http://forum.keenswh.com/threads/docked-small-ships-let-large-ships-float.7379583/

    Hi,

    I've just had exactly the same experience. After building a large ship capable of atmospheric entry and exit I attempted to land it on a planet in DS Survival. I noticed that when I turned inertial dampeners off it didn't fall any faster in gravity. I had to actively accelerate at the planet. At about 25,000m I switched the Atmospheric engines on, the Ions off. The ship was 'falling' at ~70m/s but not accelerating. The atmospheric thrusters stopped the ship at around 7,000m - way above what it should for the weight. I have no upwards facing atmospheric thrusters and I found it was impossible to descend without rotating the ship towards the ground so I could use the back/front/side engines.

    I too thought it was a glitch so I disconnected and re-connected. I waited for the next auto-save and restarted the server. The ship was still hovering there. I could jump off and fall fine. I then turned the engines off and the large ship still just hovered there!

    I noticed I still had my space miner docked via 3 landing gears and connected to one of the connectors. Getting in the cockpit and pressing 'P' resulted in the large ship plunging to it's doom.

    It's reproducible - I can provide a save with the ship hovering on earth if it would be helpful for anyone.
     
    Last edited: Feb 9, 2016
  3. Calaban Junior Engineer

    Messages:
    932
    [update]

    New causal information discovered, after doing some more experimentation on this glitch/bug:

    Apparently, its the small ships Inertial Dampeners causing this glitch. If the small ship has its inertial dampeners on while locked to a large ship, the entire group drifts free of the planets gravity.

    Turning the small ships dampeners off renders everything normal.

    This is a game breaking glitch: as it allows an exploit: launch an entire massive ship or entire base city into outer space without any tanks hydrogen, nor engines, simply build a small ship drone, leave the inertial dampeners on, lock its gear to the large mass, and drift up, up, and away.
     
  4. conradfrenzy2 Trainee Engineer

    Messages:
    4
    Hi, just found a bug with small ship landing gear. (modded 2X2X1 ones)

    Seems to function as a quantum anchor if you spawn a craft in creative mode that has a moving part secured by a locked landing gear (connector/conveyor frame/small ship conveyor hinge). The plane hovers in place, unable to move using thrusters (but still rotate with gyros), until the landing gear is unlocked. Seems to happen quite consistently at the moment, although nevr noticed it before patch 1.121.
     
  5. Ronin1973 Master Engineer

    Messages:
    4,890
    This happens also when locking down a grid attached to a rotor with a landing gear (all small grid). The entire entity will not respond to gravity. You have to power the ship down to the surface rather than dropping like a stone...
     
  6. Beartlaoi Trainee Engineer

    Messages:
    11
    Found same problem here. Launching large ship from planet into space with small ship docked on it. While landing gear is locked, its as if inertial dampeners are on, but neither actually are.
    When planet gravity reduces, so does the need for H thrust, but while the small ship landing gear are locked on, the ship flies as if it is still at 1G requiring maximum thrust all the way.
    I use thrust override during this so I know exactly how much thrust is needed to keep the speed above 90 m/s.
    When I unlock the small ship landing gear and leave just the connector locked, the problem goes away and I can reduce thrust to save fuel.
     
  7. Grit Breather Junior Engineer

    Messages:
    874
  8. CrookedTube Trainee Engineer

    Messages:
    37
    I'm also having repeatable problems with gravity not affecting my ships. Built a ship on Titan moon with 1/4 Gs, flew to Earth, had to power down to the surface. I hacked off the engines and the ship still just floats like a zepplin. When I get out of the cockpit my character is affected by gravity, but not the ship. Any tips on a workaround for this bug?

    Edit: I cycled the landing gear on my small ship and planet gravity reappeared and stayed on.
     
    Last edited: Feb 18, 2016
  9. CCampbell Trainee Engineer

    Messages:
    28
    My ship jumps up into the air when i release my gear and wont stop going up... havent tried to see how far it'll go but even shutting off the engines is no help. I have to decelerate downward and turn off dampeners and it'll keep floating down.
     
  10. Prescott Freyd Senior Engineer

    Messages:
    1,833
    Hey CCampbell!

    Thanks for the report. How often does the issue with unlocking landing gears occur? Also if it is happening in a specific world, could you please link it here or send me a private message?

    Regards,
    PF
     
    • Like Like x 1
  11. Sumyunguy Trainee Engineer

    Messages:
    86
    Merging the ship with a station merge block on a planet fixes the issue for me, so that might be a quick fix for those having this problem.
     
  12. Kham Apprentice Engineer

    Messages:
    477
    Had the exact same issue a few days ago. I even recorded a short video of it happening. All of them were small ships and all had been locked to the planet and then disengaging the landing gear sent them drifting up even with dampeners and thrusters off. They just never stopped, I got all the way to orbit before restarting the server. After the restart, they went back to behaving normally and I haven't been able to repro it.
     
    • Like Like x 1
  13. CCampbell Trainee Engineer

    Messages:
    28
    Thanks for the tip - Jumping in now. I'll give it a shot.
     
  14. CCampbell Trainee Engineer

    Messages:
    28

    Hey sorry for the slow response - LONG WEEK.

    The issue was happening a lot on the standard earth planet. Batteries on > Atmos on > gear unlock > pop up off the deck and start floating upward. I tried everything and weirdly enough, occasionally when I shut off the batteries and atmos mid air, my craft would just come to a stop and hover. only thing that seemed to make a difference was actually thrust downward then turn off dampeners and atmos and I would float right back down.

    I do use a handful of mods so I wouldn't rule them out but i'm pretty sure its unrelated.

    P.S. I could not figure out how to private message you for the the life of me. May consider making it more clear. Just saying.
     
  15. Syncaidius Junior Engineer

    Messages:
    824
  16. Prescott Freyd Senior Engineer

    Messages:
    1,833
    Just click on my profile and then Start Conversation :) Sending the world would help a ton!

    PF
     
  17. Ragotag Trainee Engineer

    Messages:
    30
    ^^^This... on a MP game; happened twice, affects ALL ships on planet when it occurs, and requires a server restart to fix. In our game, we observed this behavior after 1-2 hours of MP play, and when it happened on those two occasions it happened immediately after unlocking large ship landing gears that were locked to the planetary surface.
     
  18. CCampbell Trainee Engineer

    Messages:
    28
    Sent. I actually went into conversation and saw another's comment and figured it was not "private".

    It's like these other guys said, it only happens when you load up a game and have a ship(mine is small). locked via gear to a planet(which shouldn't be possible anyway). If you can manage to get your ship locked to large blocks while floating - it stops bugging out.

    Let me know if there is anything else I can help with.
     
  19. JuStX2 Apprentice Engineer

    Messages:
    312
    Can Confirm this issue (Unlocking Landing Gears from Earth planet causes steady rise) still exists as of Today's Hotfix. I was using a Mod landing gear too and it still happened. Additionally I had several mods adding realistic physics requirements to atmospheres enabled but this is likely unrelated as these mods are supposed to "fix" realism problems, not create them.
     
  20. crazy_bad Apprentice Engineer

    Messages:
    152
    i think, i found a problem and discribed in this topic:
    http://forums.keenswh.com/threads/transporting-ships.7381679/#post-1286957396

    but this is before 1.130 hotfix. This information was delivered to KSV team member, so i hope they will check suggestion and if it right - they will apply fix.
    basically, if you too lazy to search my post in topick above - after debugging:
    1) after locking landing gears - grids are 'wielded' inside - and we have only one physic body ( suggestion, not fully checked )
    2) we steel have number of entityes as actual number of grids\ships. Developers added optimization, that prevents calculating of grawith fow 'wielded' ships.
    3) doesn't metter ship is wielded or not - gravity value written to phisic object each update, even if it was not updated.

    so if you lock landing gears in space with zero gravity, you should be happy, because in most cases you will have no gravity on any planet. (this is positive side)
    if you lock landing gear on planet gravity, gravity vector stored anw will be applyed to phisics until landing gears unlocked (all ships 'unWielded'.). (this is negative side). For example trying to fly from moon to earth, using jump drive - i was unable to land ship. because 'down' trusters too weak and moon (old planet, when landing gears was loked) gravity are higher than 'down' thrusters can suppress. so my ship always flaying away from planet :). But after detailed debugging - solution is simple. Attach ships, fly away from planet gravity. reduce speed to 0 (zero). relock landing gears. And mostly can land ship with out problems (without much fuel wasted :-D).

    why i telling about this situation not stable (in mu case i was not meet another behavior):
    but exploring code, according my suggestion many entityes (by number of attached ships + 1(host ship)) writing gravity value to one physic object. I not sure about update order, but all depends from update order. Last value should be used if physica frame calculation processed after all values was set.If physics word asyncronusly (as i think) - no any warrany at all. But if physic work async, i dont know how syncronization works in MP game. But this is another question (only for me, should explore code).

    After added fix in post on link above - i didnt see this problem any more.
     
Thread Status:
This last post in this thread was made more than 31 days old.