Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Modding New Block - Problem Help Needed

Discussion in 'Modding' started by Kieran, May 7, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Kieran Trainee Engineer

    Messages:
    13
    I am working on making a mod that uses base game models and logic from existing objects like the battery, I have it to the point where it works without any problems but the only thing that is off is that in my new tab under the G window there are both batteries my mod and the base game battery. any idea how to fix this problem?
     
  2. Vicizlat Apprentice Engineer

    Messages:
    174
    If you want your block to replace an existing vanilla block, you need to use the same SubtypeId as the vanilla block you want to replace. If you have any other name it will appear as a new block. For example to replace the large block battery you need to use <SubtypeId>LargeBlockBatteryBlock</SubtypeId>. DisplayName can be whatever you want. Also I am assuming that you copied the information for the *.sbc file from the vanilla CubeBlocks.sbc? If that is the case you should leave in the <BlockPairName>BatteryBlock</BlockPairName>. This is needed so the game knows to change the block for small and large grids.
     
  3. Kieran Trainee Engineer

    Messages:
    13
    thanks for your reply I managed to make shift it after asking for help on the discord, ended up waiting 3 hours for a reply on there but someone was nicer enuff to help me understand what the PairName dose and then I worked on the Position after that using the PairName as the ID and it worked just fine. thanks for taking the time out to help :)
     
Thread Status:
This last post in this thread was made more than 31 days old.