Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Refineries not refining w/out reloading world

Discussion in 'Bug Reports' started by Drivenbydiamond, Oct 30, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Drivenbydiamond Trainee Engineer

    Messages:
    73
    After this last update, my refineries will not work unless I put the ore in them, and then reload the world. They will still pull in ores, but no refining.
     
    • Agree Agree x 2
  2. PsicoPato Senior Engineer

    Messages:
    1,097
    Can confirm this bug.
     
  3. Phand Master Engineer

    Messages:
    9,650
    Hi,

    I will check that out. Thank you for letting me know! :)
     
    • Like Like x 3
    • Agree Agree x 2
  4. erich.weinhammer Trainee Engineer

    Messages:
    3
    Same here, they remain in Standby-Mode, despite being connected, powered, given enough space and ore.

    I got about 20 refineries, 3 of them refuse to lift a finger since the new patch, the others kept working as usual.

    I saw no pattern in the 3 slack-offs in comparison to the working ones. Tried to manually re-connect them, turn off/on, changed user, turned conveyor system usage on/off, emptied and refilled them.
    It is not Ore-type dependent, as they refuse to refine ANY ore.

    They keep in standby @ 1kW power usage.

    No mods installed.
     
  5. OI Steven Trainee Engineer

    Messages:
    41
    Refineries dont process material on our DS, restarting server helps, but only processes the material that was in the refinery before restart, once you add more ore to the refineries or arc furnaces, they stop working again.
     
  6. CheeseJedi Apprentice Engineer

    Messages:
    382
    I've looked in to this a bit on our DS and I cannot emphasise enough how game-breaking this is for survival worlds, particularly on DS.

    It is not possible to process material in Refineries or Arc Furnaces without a server restart and they seem to only work 'once' after a restart.

    Initially the refineries/arcs will process material in their inventories but as soon as they empty their inventory, they will no longer process ore until the server is restarted.
     
    Last edited: Oct 30, 2015
  7. Walnut Trainee Engineer

    Messages:
    14
    I can confirm this. Somehow i managed to refine <0.01 uranium by grinding it and re-building. But it only happened once. Also, i reloaded and nothing happened.
     
  8. joethepro36 Trainee Engineer

    Messages:
    11
    I can confirm this also. It's pretty game breaking for me as I play lone survivor in survival mode.
     
  9. Virdi Trainee Engineer

    Messages:
    11
    It also happens with the arc furnace. Another one with an useless survival server atm, has anyone tried rebuilding the refinery?

    ---------
    Edit: Rebuilding worked with arc furnaces, hard to rebuild refineries in my game though
     
    Last edited: Oct 30, 2015
  10. Heisenberg Trainee Engineer

    Messages:
    17
    Really waiting for a fix for refineries and asteroids.
     
  11. SnottyCat Trainee Engineer

    Messages:
    59
    Same problem here. Refinery refuses to work.
    Started single player game in creative. Build ship with refinery and began refining some ore for testing, and it worked. Then switched to Survival and tried to refine more ores, and the refinery refuses to work. Switched back to Creative and said refinery still not working. Test built just a refinery with reactor, and this new refinery works, but previous refinery still not working.
     
  12. Sibz Apprentice Engineer

    Messages:
    361
    Tested again after hot fix, still stops after processing what was in the queue on load.
     
  13. skyhouse71 Trainee Engineer

    Messages:
    1
    I will confirm the bug. If i want to process ores I need to exit the world and then reload....... each time....... kind of annoying.
     
  14. procyon1980 Trainee Engineer

    Messages:
    47
    Yes, it still happens after hotfix.
     
  15. LFCavalcanti Senior Engineer

    Messages:
    1,378
    Same here, tested now. Also created a new save to test it.
     
  16. Hiryuu Trainee Engineer

    Messages:
    1
    Same here, both of my refineries stopped working. Reloading the world makes them process what's in their inventories, but they stop as soon as I remove/re-add ores.
     
  17. Torezu Trainee Engineer

    Messages:
    1
    Bug confirmed. Though even restarting the world doesn't seem to do it for me.
     
  18. Zhab Apprentice Engineer

    Messages:
    446
    Confirm bug.
     
  19. Echillion Senior Engineer

    Messages:
    1,334
    Confirming the same problem as I've had the same issue
     
    Last edited: Oct 31, 2015
  20. HadesDurin Apprentice Engineer

    Messages:
    119
    i have the same issue in my world, where only the inventory on reloading is processed
     
  21. kakolukya Trainee Engineer

    Messages:
    6
    Confirming the bug as well. It's a little weird that at least by me it still consumes full power to work even tough it does nothing.
     
  22. rexxar Senior Engineer

    Messages:
    1,532
    Still a problem on my DS.
     
  23. glennmanor Trainee Engineer

    Messages:
    4
    Same here.
     
  24. HadesDurin Apprentice Engineer

    Messages:
    119
    my refinery consumes standby power
    and what i experience so far,
    the only check up or update of refinery inventory to process is done when i reload my world
     
  25. rutland.shakespeare Trainee Engineer

    Messages:
    7
    Bug confirmed.
     
  26. STeelGear Trainee Engineer

    Messages:
    8
    Confirm. It still here and it realy bad. Need to reload.

    And after change ore in ore-list in refiner, ore that refine early still refining, when order this ore was move
     
  27. kakolukya Trainee Engineer

    Messages:
    6
    i tested modded refineries.. they seem to work just fine but apperantly not every time... it's really strange... is this possibly related to the conveyor issues?
     
  28. Duto Fujamee Trainee Engineer

    Messages:
    11
    Yep, also confirmed on Multiplayer. After a time, refinery doesn't work at all.

    It's actually Game blocking, because we can't anymore get Ingot to build anything. The survival is actually dead and a hotfix is really needed.
     
  29. Schwirzl_66 Trainee Engineer

    Messages:
    5
    I think there is a Conveyer-System bug too.
    FOr example, some assemblers, which connected to a empty cargo container, are not able to move finished items into it.
    The production stand still, till i move the items via drag and drop into the container.

    Also all conceted Gatling turrets.
    I connected a conveyorsorter to each turrent for supplyin them with ammo and nothing else.
    Each turretinventory can handle about 20 ammoboxes.
    After there are 10 boxes in the turret inventory, the conveyorsystem stopped the suplly with more (there are enough ammoboxes in the cargo container).
    Ive to move another 10 boxes via drag and drop into the turrets.

    Did someone can confirm this problem/bug?
     
  30. bronxae Apprentice Engineer

    Messages:
    135
    same here, added iron to refineries on my survival ship, its just sitting there, even after world restart. Also the asteroid clipping thing is still happening, the hole I dug to mine said iron in survival got covered by fake asteroid voxels that I can move threw.
     
Thread Status:
This last post in this thread was made more than 31 days old.