Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Refineries not refining w/out reloading world

Discussion in 'Bug Reports' started by Drivenbydiamond, Oct 30, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. darth_crunchus Apprentice Engineer

    Messages:
    239
    Same bug here. Can't refine any ores. Luckily, I have a good stockpile of ingots in my base. Loge the game to pieces, to, here's hoping it gets taken care of Thursday.
     
  2. Sibz Apprentice Engineer

    Messages:
    361
    I finally reloaded my game again ... it seems the refineries stopped working. *sigh* Least I finished my large ship so don't need ingots atm.
     
    • Like Like x 1
  3. Zarkov Trainee Engineer

    Messages:
    10
    I have the same problem. I recently bought the game and only have a new world, so I'm forced to quit and reload continuously to keep the refinery going and actually be able to play. IMHO that sort of ruins the game experience by being so tedious and immersion breaking. Hopefully it's fixed in the Thursday patch.
     
    • Agree Agree x 2
  4. joemorin73 Junior Engineer

    Messages:
    949
    You can avoid the "reload" issue in MP is to never let the refinery finish processing. When you get low on Ore, turn the refinery off until you fill it up again.
     
  5. gsmsigi Trainee Engineer

    Messages:
    4
    Hello, i have the same problem whit the refineries,

    they stop working when they run empty en will not response after i refill them...


    I wonder if there is a solution for this problem like whit the asteroids invisible.
    Then I just have to delete the games old cache files : C:\Users\name\AppData\Roaming\SpaceEngineers\ShaderCache

    This was a good working solution, but it take me hours to find et !
     
  6. RubberSword Apprentice Engineer

    Messages:
    140
    Still a problem for me. Tried playing with my refinery - taking ore in, out and moving it about :)

    When I transfer ore from Avatar to refinery it sometimes just disappears. Looked around and haven't dropped it

    Now ore and components appear in Oxygen tank
     
  7. Tigerstripe Apprentice Engineer

    Messages:
    479
    Seen this too.
    Very game breaking.
     
  8. matty3d Trainee Engineer

    Messages:
    20
    unplayable :-(
    wow, thats a very smart suggestion and it will work right away in survival when you just have started!! (sarcastic off)
     
    • Funny Funny x 1
  9. Dicarus Apprentice Engineer

    Messages:
    136
    I tried it and it didn't even work. It processes the materials it had then it stops at the ones you dumped in.
     
    • Agree Agree x 1
  10. Thedrelle Trainee Engineer

    Messages:
    15
    same problem here.
     
  11. Slow Trainee Engineer

    Messages:
    1
    Just in case the devs are currently still searching for the cause:
    It seems for there is a sync failure after the refinery stops working. When I refilled it afterwards and emptied the cargo of it I couldn't notice any progress on the refinery - not working anymore. After I tried several things (moving around the ore, start/stop the refinery/furnance several times) I restarted the DS and checked the inventory. I found loads of refined ore in the cargo and only half of the unprocessed ore left in the queue. So it seems the refinery kept working on DS but did not tell it's state to the clients.
     
  12. Cattasraafe Trainee Engineer

    Messages:
    20
    So if I rebuild my refinery it should start eating whats next in queue until I reload again?

    Confirmed heh if you break down a refinery (I did not test just partly breaking it down) and rebuild. It will refine like normal and recognize when you change ores in the queue.
     
    Last edited: Nov 4, 2015
    • Agree Agree x 1
  13. neo39m Trainee Engineer

    Messages:
    2
    I Have the same problem, works for a while after reload but if you change any of the ores ect it will then fail.
    i will wait untill they patch it, i have noticed a fair few people getting very angry about this (especially if its game breaking) however i am sure they do care and they are working on it asap. i work in "IT" and sometime you have to break things to make it better.
    i am very pleased with the game and compared how it was it was when i first played it. i love that they keep adding stuff, lets not get to angry that sometimes stuff breaks otherwise they will be to scared to do stuff and i for one like that they keep adding awesome things to it..
     
    • Agree Agree x 1
  14. X_Wing_Ian Trainee Engineer

    Messages:
    61
    Someone said earlier in the posting that fully rebuilding the refinery works and it does work for at least one or 2 restarts(For me on DS) as for the arc furnace that does not process anything hopefully it will be all fixed today, also it is a sync issue b/c I can move around the the ors and it processes just fine
     
    Last edited: Nov 5, 2015
  15. Soulthule Apprentice Engineer

    Messages:
    362
    Confirmed - Players on my Server seeing the same issues. I play too so ... me too!
     
  16. Soulthule Apprentice Engineer

    Messages:
    362
    The issue for us is uranium. Between it being almost impossible to mine with the massive server/lag and the inability to refine. Finding uranium in any copious amounts from cargo ships if you can take them down is very rare. So, its getting to the point of Demand and increasingly outweighing Supply. :eek:
     
  17. CheeseJedi Apprentice Engineer

    Messages:
    382
    Hi @Phand Are there any updates on this issue? I, and many others, are keeping our fingers crossed that a fix for this makes it in to today's update.

    Have you been able to reproduce this behaviour? If not what can we do to assist - this bug needs to be smashed ASAP as it makes Survival completely unplayable (particularly DS).

    Just let us know what we need to do to help.

    Edit: Spelling.
     
  18. BlaydeTan Trainee Engineer

    Messages:
    1
    While this may be resolved in today's patch, here's what I've found:

    1) Starting the world with an inventory of ore causes it to process only that ore. Any additional ore added during the time it is processing what it was loaded with is left behind in its deactivated state.
    2) Moving inventory around within the individual refinery has no effect until it runs out of what was working on, in which case it begins on the first slot material.
    3) Moving ore out of the refinery causes it to work on the first slot material, as is normal.
    4) Returning the ore to the refinery seems to have no effect at first, but if you put it as the first material or next in line it will return to working that material again after the one it is currently on runs out or is moved as in #3.

    What this tells me is that when the world loads, the refinery is taking a snapshot of its current inventory and the refinery is running off that static list rather than rebuilding it every time. Logically, there must then be a cycle that detects manual changes (or completion of a stack) and updates this snapshot. There must be something either preventing this update subroutine from functioning or preventing the refineries from accepting the new snapshot.

    Example: You load the world with 10k each of iron, silver and gold in the refinery in that order. You allow 1k of the iron to process and then pull it to another cargo hold. The refinery thinks it has 9k iron and 10k each of silver and gold to process, but it can't find the iron so it sees what is in the first slot and begins to work on silver. At this point you decide to move the iron back in, but put in 10k of it again. You also move the silver to slot 3. The refinery keeps processing the silver, because that's what it thinks it's working on. You then move the iron to the 1st slot and remove the silver. It once more looks at what it thinks it has in its inventory, sees iron in the first slot and starts there again. This time however, once it processes 9k more iron it would stop working on iron and begins to work on the gold. The extra 1k iron you added back in stays unprocessed.

    Just to double check my analysis I ran this again today while typing this up. I loaded the world with 100k iron ore followed by magnesium in the refinery, added 100k more ore and now have 100k iron ore sitting while it processes magnesium.

    Screenshot of experiment results:
    Done in creative mode to allow for the larger inventory space. The same situation happens in survival.
    https://drive.google.com/file/d/0B2MKEOlkONFdTk8zRjlodnJXQUk/view?usp=sharing
     
  19. Cattasraafe Trainee Engineer

    Messages:
    20
    Has anyone Tested to see if this was fixed in the latest patch.
     
  20. Voyager_sput2015 Trainee Engineer

    Messages:
    37
    It wasn't, as you can read in the 2nd reply on the Change log post on the 107 update. Hoping for some process on it on today's hotfix :)
     
  21. neo39m Trainee Engineer

    Messages:
    2
    I created a new refinery and that seemed to work all night for me.
     
  22. Voyager_sput2015 Trainee Engineer

    Messages:
    37
    Yeah some have reported that adding new refineries or grinding down and replacing old ones fixes it. I was holding of on that one myself, given the 24 refineries I have in my base now. Not that eager to grind and replace all of them just yet...
     
  23. Cattasraafe Trainee Engineer

    Messages:
    20
    Yeah can see how that would not be to fun. Could be the bug fix only works on new worlds or if you replace your refinery too. But,,, if you have a small enough ship and a big enough build area you can rebuild em from the cock pit now :))
     
Thread Status:
This last post in this thread was made more than 31 days old.