Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Respawn Issue on servers. spawn menu disappears when spawn point selected then nothing.

Discussion in 'Technical Help' started by Neoublie, May 6, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Neoublie Trainee Engineer

    Messages:
    4
    When I try and play on a server, any server, I am on the spawn screen.

    I select any of the spawn options and then the menu disappears and I am left frozen in the same location the menu had as a background. I have once been able to move the camera so I am not completely frozen, and I can see players moving where the camera shows.

    I have reinstalled the game and I am pretty sure I have removed all the profile files.

    this has been an issue for me for a very long time. makes it so I can't play with my mates. if I run my own server or play single player I spawn in no worries. how ever if I run the server everyone gets stuck on world downloading 0%

    I have my ports open and used to be able to run a dedicated on the exact same computer/router/internet provider/any other environmental issue you can think of. I am an IT person so I have tested so many different things. I dont know what I am missing.

    I hope you can assist me to get the multiplayer going again and I hope to be able to fix my dedicated server issues as my mates normally play on my dedicated server (more dependable usually)

    the most resent log when I spawned in crashed my game and the error log is attached.

    http://textuploader.com/5bsh8
     
  2. CptTwinkie Master Engineer

    Messages:
    4,458
    Does the menu disappear when you click on the location or when you try to spawn there?
     
  3. Neoublie Trainee Engineer

    Messages:
    4
    Yes the menu disappears and then I am left with only the background image from where the camera was looking. I have been able to move the camera using some hot key and the mouse. forget which key it was sorry
     
  4. Prescott Freyd Senior Engineer

    Messages:
    1,833
    Hello!

    Maybe you're being spawn in Spectator? Does anything happen after pressing F6 or when you try to kill the character with Backspace? Making a video could help us understand what exactly is going on :)

    Regards,
    PF
     
  5. Neoublie Trainee Engineer

    Messages:
    4
    I was having no response from any keys at all and couldn't swap from spectator and couldn't suicide. how ever I tried wiping my game and my settings again and the second time it has started working, kinda. I am now able to connect to my friends server but now I play for a short time and then I desync. my friend is in Canada and I am in new Zealand. I have found that a person in Australia seems to be having the same issue as me.

    the issue as it stands now is that I can connect and build etc for a short time. then I can no longer interact with anything in the game and my friends are stationary or traveling in their last know direction.

    I have to disconnect and reconnect to be able to do anything and then a short time later i will desync again.
    --- Automerge ---
    Next update, played for about 5 mins on mates server and then stuff stops responding. can't transfer inventory, weld but can still move and access containers but can't transfer anything. can't enter cockpits see my mate standing still even though he is actually moving. rejoined and then continued to build my ship. 5 or 10 mins pass and same thing happens again. re-log and now I am stuck with the original issue. I now click the med bay to re-spawn and the menu dissapears, I can't move, suicide or access inventory. I hold alt and can move my camera. I can press F5 to get prompt to rejoin server but F6 doesn't do anything. can't backspace to suicide. looks like I might be able to see my living body standing where I disconnected. so could be in broken spectator mode.

    Problem is that combined between both these issues the multiplayer part of this is unplayable as each time I "Desync" and have to reconnect I loose my inventory. and all in all this game I brought to play with my friends. not solo. really hope you put some focus into fixing this as I have been playged by these issues for many months I had given up playing for a long time but was hoping your multiplayer work might have fixed this.
     
  6. Neoublie Trainee Engineer

    Messages:
    4
    Next Piece of the puzzle...

    I have also retried running a world and having my friends connect to me. they connect and get stuck on 0% downloading world and never get any further. I have tried opening all the ports. I have tried leaving it to upnp and neither work. the ports I was opeing was not only space engineers ports but also the steam ports for query and so forth.

    I also have discovered a trigger that seems to desync me from my friends server. This was when I build a projector and then loaded up a blueprint I have that I got from steam. is this possible a but that hasn't been addressed?
     
Thread Status:
This last post in this thread was made more than 31 days old.