Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Rotors, Pistions are going places (See video)

Discussion in 'Bug Reports' started by PurrfectBlinky, Dec 16, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. PurrfectBlinky Trainee Engineer

    Messages:
    26
    I want to address the issue caused by this week's update here:



    This machinery was fine before stable was overwritten by dev, and now most things look terrible and are also not functioning as expected. Weird floating, heavy sim drops and even getting close causes slowdown.
     
    • Agree Agree x 3
  2. iN5URG3NT Senior Engineer

    Messages:
    1,132
    Feel ya bro. All timers built via projector now forget their settings. This has broke virtually all my PMW. Calling SE Beta seems optimistic.
     
    • Agree Agree x 1
Thread Status:
This last post in this thread was made more than 31 days old.