Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

SE says it's not connected to Steam, but it is.

Discussion in 'Bug Reports' started by JohnnyBoy, Jul 19, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. JohnnyBoy Trainee Engineer

    Messages:
    2
    So I'm pumped to try out the new update but so far the only thing I can do is start a new vanilla single-player offline world. Everything else throws errors like SE is not connected to Steam, even though it was launched from Steam and Steam is not in Offline Mode. Here is what happens when I try a few things:

    From the Main Menu:

    -Oberservation 0.5: The update/news window says "STEAM NOT AVAILABLE" in the lower right corner. All the new 1.187 update stuff is there though.

    -Action 1: Click on Character button
    -Result 1: A popup message saying "ERROR {0} is offline. Please run {0} in normal mode or restart {0} if the problem persists"

    -Action 2: Click on Join Game button
    -Result 2: A popup message saying "ERROR Steam is offline. Please run Steam in normal mode or restart Steam if the problem persists"

    -Action 3: Click on New Game, Custom Game, Star System, Mods, Browse Workshop.
    -Observation 3.25: Observed there are no mods available on the left hand side like normal.
    -Result 3: A popup message saying "PLEASE CONFIRM This will open Steam Workshop in you internet browser, because Steam Overlay is either disabled or failed to open. The game will keep running. Do you want to continue?"
    -Observation 3.5: The overlay is enabled, I can bring it up via shift-tab, I can browse the workshop with it, and see all the mods I'm subscribed to. I even subscribed to an arbitrary one, to no effect.

    -Action 4: Click on New Game, Custom Game, Star System, set Online modes to Public, Start
    -Result 4: A world is created and started but is immediately flagged with the following red error message "Multiplayer server cannot be started, error: Steam offline, try restarting steam"
    -Observation 4.5: When typing something into the chat window, there is no handle next to what I type (e.g. expecting "Johnnyboy: Blah Blah Work Dammit" but getting only ": Blah Blah Work Dammit".

    So in general it sounds like even though Steam is running fine and SE seems to start and run fine, SE cannot talk to Steam for some reason. Or SE is but Steam isn't talking back. Everything worked fine on 1.186 just a couple hours before.

    -Actions 5 through 11 (future): Drink beer.
    -Results 5 - 11 (future): Mildly lessened frustration.

    Things I have tried already:

    -Restarting Steam.
    -Switching Steam to Offline mode and back.
    -Switching the Steam Overlay off and back on.
    -Restarting the computer.
    -Verifying local files.
    -Uninstall/reinstall. <--- See? Steam is working, SE just doesn't know it.
    -Verify local files again.
    -Uninstall/reinstall while cleaning out both the SE folders (both steamapps and appdata).
    -Verifying local files again.
    -Mess with various game and steam settings, switching them back after the don't work.
    -Dig through the log file, nothing of note (the usual startup this is graphics options, this is config file, this is loading pre-fab stuff, this is loading world stuff, etc. No flags/errors/exceptions/"hey I wonder what that means thingies".).

    Things I am going to try next:

    -Beer run.
    -Load Grandpa's shotgun (don't worry, this will be done by the third beer, Safety first!)
    -Pray one of you fine folks reading this has a solution before I run out of beer and/or patience.

    Thank you and Merry Patchmas!
     
  2. Zeys Trainee Engineer

    Messages:
    28
Thread Status:
This last post in this thread was made more than 31 days old.