Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

SE Server Extender - Current Releases and Plugins

Discussion in 'Groups & Dedicated Servers' started by dodexahedron, Mar 13, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. FoxTech Trainee Engineer

    Messages:
    13
    same here
     
  2. SilentSymphony Apprentice Engineer

    Messages:
    201
    Be patient guys, I'm confident dodex will be on top of this as soon as he can!
    Also be sure to post your issues on the github!
     
  3. dodexahedron Apprentice Engineer

    Messages:
    224
    Guys, it's the same every week.
    You know things happen around patch time.
    Don't update your servers until SESE is ready, if you want to have no downtime.

    In any case, I'm home now, so I'll get to it.
    Shouldn't take long, in theory.
     
  4. dodexahedron Apprentice Engineer

    Messages:
    224
    New version is up.
    Enjoy!
     
  5. FoxTech Trainee Engineer

    Messages:
    13
    Thank you sir, luckly, I only updated one of my test servers.
     
  6. FoxTech Trainee Engineer

    Messages:
    13
    Any word on what could be Preventing certain large ships / stations from concealing? I can't verify for sure but it seems so far that newer created platforms and large ships are concealing like they are instructed to while older platforms and ships are not. This is not a new issue since update for my server, as I haven't seen most of my large ships or stations conceal at all since I first installed SESE about 2-3 weeks ago.
     
    Last edited: Jun 12, 2015
  7. Cobra Apprentice Engineer

    Messages:
    204
    I am still getting errors when starting the server:
    2015-06-12 10:12:30.8733|Error|SEServerExtender.SEServerExtender.FactionRefresh|System.NullReferenceException: Object reference not set to an instance of an object.
    at SEServerExtender.SEServerExtender.FactionRefresh(Object sender, EventArgs e)
     
  8. Lithorn Trainee Engineer

    Messages:
    50
    Where do I put the plugins?
     
  9. FoxTech Trainee Engineer

    Messages:
    13
    In the mods directory, put the Essentials plugin in a new folder named Essentials. I put the Get Out of My Sandbox plugin into a new folder named GetOutOfMySandbox and that worked for me not that I saw any specific documentation about where to place it.
     
  10. FoxTech Trainee Engineer

    Messages:
    13
    Additionally, I have finally realized which grids won't conceal. It's any grid that has another entity attached either through a "LOCKED" Connector, Landing Gear, Rotor, or Piston. I believe one of my admins told me that Merge blocks were ok as they create a single entity when merged. Additionally, removing the head of a piston or rotor suddenly allows stations/ships to be concealed. I've also noticed that the /admin scan grids "hasdisplayname:DISPLAY NAME HERE" command does not owrk on any of these grids that have an attached entity. Has it always been this way or is this a more recent bug that hopefully can be fixed in the future?
     
  11. therimmer96 Trainee Engineer

    Messages:
    2
    I'm getting something I cant find any info on.

    Everytime I load a world with steam workshop mods added in the sandbox.sbc file, it renames the file and creates a new one without the mods.
     
  12. therimmer96 Trainee Engineer

    Messages:
    2
    *bump*

    Really confusing me now. I can see no reason for it to be doing this.
     
  13. SilentSymphony Apprentice Engineer

    Messages:
    201
    You really need to be posting this stuff on the github: https://github.com/SEServerExtender , this is a release thread, Dodex might answer your questions here but you will receive better support on github, your issues will be given a number and if they are fixed they will appear on the releases, In addition other people may have posted your issue, or if they have the issue post information on your report to help fix it.
     
  14. maxx Trainee Engineer

    Messages:
    24
    new version of Space engineers (087) is starting up with Extender, but some stuff got moved again - and clicking on the entity tab brings havok to your logfiles :)
     
  15. dodexahedron Apprentice Engineer

    Messages:
    224
    Version 530 has been posted, with the necessary fix for SE 1.87.
    Happy engineering!
     
  16. dodexahedron Apprentice Engineer

    Messages:
    224
    Version 532 has been posted, which fixes possible crashes when attempting to ban or kick clients.
     
  17. dodexahedron Apprentice Engineer

    Messages:
    224
    Version 539 has been posted.
    This release removes more reflection, adds the DisableRespawnShips setting, and fixes the broken CubeGrid export functionality.
     
  18. 88ToM Trainee Engineer

    Messages:
    38
    hi dodexahedron, please fix the /admin scan inactive and /admin delete inactive because i think this is a very important command..
     
  19. FoxTech Trainee Engineer

    Messages:
    13
    big patchmas today ^^
     
  20. dodexahedron Apprentice Engineer

    Messages:
    224
    Indeed it was.
    Version 540 has been posted, which fixes compatibility.
     
  21. dodexahedron Apprentice Engineer

    Messages:
    224
    Version 543 has now been posted, with support for various new settings.
     
  22. radar Trainee Engineer

    Messages:
    29
    Hello dodexahedron :) (or to anyone else who reads that)

    Being new to Extender/Essentials I would love to talk to you, at least short, via chat or skype. But being a skype-noob also, the hint "modding community" was not enough.

    So here is my question and a bit of environmental info:
    I'm the one who has to get the Extender/Essentials to get going for our server, but I have no physical access to the machine.
    I read the docu and are running under the assumption that I can control all settings over the chat (except what has to be put into the startup options).
    Doing first steps first I have successfully set the command
    "/admin settings loginenabled set enabled"
    But then I run into problems when I start to get a greeting going.

    I'm not sure if I read/understood the docu right. Do I have to first add items into the greeting? Please be aware that I have no idea or access of the gui/configfile part of this wonder- and powerful tool. Is the Greeting something like a list and I have to enable first the fields before I can fill them? Is this what it is meant when the docu mentions arrays and add?

    I read the thread here to at least the point where you mentioned you can be reached over skype, but most of what I saw was people having at least some access to the physical machine and examples for doing the configuration over gui/config file, or? Correct me if I'm wrong :)

    I think with some pastebin or their like of some initial "/admin setting ..."-commands I would be on my way. I have only a basic problem of understanding of the ways of the essentials here, at least I think. Any help would be most appreciated :)

    Edit: Come to think, I mean has anyone ever setup the Essentials by chat? Or should I just go ahead and edit me a local config and then get me that switched on the machine? I mean, I was just reading the docu and thought, ok, I can do that by chat, cool ...

    Edit: Maybe I should have put the chatcommands here that I have problems with m)
    When I do "/admin settings greetingenabled set enable", the command goes through, but then "/admin settings greetingenabled" returns me still "Getting Value(s) for setting: greetingenabled (newline) GreetingEnabled: False"

    Edit: But as I just see, when I set the command "/admin settings loginenabled" this returns me also false.
    I start to think that I maybe encountering a permission problem here. Like the Essentials have no write permissions on their own setting file ...

    Edit: I moved the issue to an actual issue on githup https://github.com/Tyrsis/EssentialsPlugin/issues/99
     
    Last edited: Jun 27, 2015
  23. FoxTech Trainee Engineer

    Messages:
    13
    A week ago, I would have said that greetings are completely bugged and not working. This week, I've been very busy with work in real life and thus haven't done much testing, but from what I've seen greetings have been working more often. I know that's not quite the answer you've been looking for. But greetings have been broken for awhile and may still be some what broken, so if it doesn't appear to be functioning correctly, I wouldn't put to much time into it. The only open issue I see available on gethub is located here: https://github.com/SEServerExtender/EssentialsPlugin/issues/17 but it doesn't directly talk about the informational greeting window. I'd do some testing but I'm burnt out from work and doing nothing but starting up my test server to try and break stuff. Need to play a bit of space engineers, something I haven't done much of this month.
     
  24. radar Trainee Engineer

    Messages:
    29
    Thank you so much, that is a quite helpful information. I wish you much fun in space :)
     
  25. FoxTech Trainee Engineer

    Messages:
    13
    yeah don't worry, i ended up starting up my test server send spent the entire night testing out various ideas and found 3 new bugs to report LOL

    I'm like addicted or something...can't just sit down and play..
     
  26. rolstone76 Trainee Engineer

    Messages:
    28
    Hi guys, I understand github is the way forward with reporting potential issues now? but I still havn't gotten my head around it entirely and I don't know how/if I can post screenies there so... here will have to do for the moment until I know better :)

    So, I encountered this error a few (4/5) times whilst crashing, it appears to mention docking handle, I assume that is a reference to the "safe docking" feature of essentials? if not I'm totally and utterly clueless, please help!

    [​IMG]
     
  27. rolstone76 Trainee Engineer

    Messages:
    28
  28. tunefuldjmike Trainee Engineer

    Messages:
    57
    It seems that dodexahedron is quite busy atm since he has not responded on github for some time now. Anyone heard from him ?
     
  29. Nova Dwagon Apprentice Engineer

    Messages:
    125
    Best guess he has dissapeard like the rest of the owners of this

    Dont blame any one, maintaining this is a huge chunk out of your day

    it will be better if we all try to get this client intgrated into the dedicated server tools
     
  30. rolstone76 Trainee Engineer

    Messages:
    28
    any word on if today's update has killed SESE?
     
Thread Status:
This last post in this thread was made more than 31 days old.