Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

SE wont update from 1.144

Discussion in 'Bug Reports' started by Nico The Red Rogue, Sep 4, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Nico The Red Rogue Trainee Engineer

    Messages:
    8
    I have tried everything from deleting all the game files and redownloading to changing my region on steam, nothing has worked and I'm still stuck on 1.144. There are no alerts no errors, as far as steam is concerned it seems to think SE is up to date but when I start it up it says its still running 1.144 and there are none of the features of the latest updates so it is not a UI error. I have even tried switching to the development version and still I'm on 1.144. My firewall doest seem to be flagging it either. Please help me the past few updates seemed really cool.
     
  2. Dawnkeeper Apprentice Engineer

    Messages:
    260
    1.144 is the up-to-date version of the stable branch.
    The weekly updates were moved to the develop branch that can be selected in the Steam properties Beta page.
     
  3. Nico The Red Rogue Trainee Engineer

    Messages:
    8
    I've tried that already, I'm currently running the dev version.
     
  4. Lynnux Junior Engineer

    Messages:
    881
    Did you recheck the game settings in steam ? The dev branch was renamed. Maybe you have to reapply it.
     
  5. Nico The Red Rogue Trainee Engineer

    Messages:
    8
    yup
     
  6. Georgik Apprentice Engineer

    Messages:
    215
    After switching to develop branch, steam should immediately start downloading new version. If not, there must be something wrong, try verify game data in steam when in develop branch.
     
  7. Malware Master Engineer

    Messages:
    9,858
    I have seen this happen now and again (not often), but for me it usually fixed itself by restarting Steam...
     
  8. Nico The Red Rogue Trainee Engineer

    Messages:
    8
    It did download but it downloaded 1.144
     
  9. Dawnkeeper Apprentice Engineer

    Messages:
    260
    Does it say "Space Engineers [develop]" in your Steam library? If not then switching the branch did not work.
     
  10. Nico The Red Rogue Trainee Engineer

    Messages:
    8
    yup and it says it on the main menu too
     
  11. Replic TuaniOne Apprentice Engineer

    Messages:
    485
    Then you are in de Dev version (don't look at the right below screen that says 1.144, they don't have a 1.151 blog version)
     
  12. Nico The Red Rogue Trainee Engineer

    Messages:
    8
    It works now yay! I could have sworn it said 1.144 in the lower corner though. It's up to date now though.
     
Thread Status:
This last post in this thread was made more than 31 days old.