Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Server not the same version as client, 1.187

Discussion in 'Groups & Dedicated Servers' started by GrimmSpector, Jul 26, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. GrimmSpector Trainee Engineer

    Messages:
    53
    No one can join my server, because the server app is according to steam up to date, and it's on version 1.187.088, meanwhile the client is on version 1.187.089, and of course it tells me to change the branch in steam betas, which doesn't work because 1.187 isn't a option and the minor revisions don't exist in the branch opting selection anyways.

    This is ludicrous. It shouldn't event be an issue.
     
  2. MTXRooster Trainee Engineer

    Messages:
    60
    Same here still (7/27/2018)
     
  3. MTXRooster Trainee Engineer

    Messages:
    60
    Everyone else still having this problem? I have run my script to download updates for dedicated server (and have auto-update on the new dedicated GUI) on, and time after time it continues to tell me my version is current. Yet, the client assures me the dedicated server is 1 revision out of date and refuses to connect (same exact message as what the OP wrote). I'm no stranger to seeing the dedicated server update slightly behind the clients, but this is DAYS now.. Help?
     
  4. Potatoboy Trainee Engineer

    Messages:
    2
    To get the latest version use this: steam://install/298740 in your browser to force steam to install it.
     
  5. MTXRooster Trainee Engineer

    Messages:
    60
    Yeah that's really not for dedicated servers.. We use the SteamCMD program.. Doing it that way does get you the correct version (I did it about 4 days ago when I gave up on SteamCMD properly updating as it should), but you have to have steam installed, and possibly logged into and it will put the app in a steam file hierarchy, not in say, "C:\SEDedicated".. We need SteamCMD fixed to match the proper version, as it has always worked up until this 089 update. I do thank you for the info though, you're not necessarily wrong, but it's the wrong way to go about it on a server you remote into, that doesn't have steam on it for a server environment. That's my bad for not adding that bit :)
     
    Last edited: Aug 14, 2018
  6. SteelWing Trainee Engineer

    Messages:
    1
    Bumping thread because I'm getting the same problem. I use SteamCMD for my group's Dedicated Server and it says the server is up to date. I ran it again with -validate and it validated successfully. Still not getting the .101 update.

    EDIT: Deleted the executable for the server and reran my update script. That seems to of fixed it.
     
    Last edited: Aug 12, 2018
Thread Status:
This last post in this thread was made more than 31 days old.