Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

{Space Engineers} Thick green lines on screen

Discussion in 'Technical Help' started by NemesisActual, Mar 15, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. NemesisActual Trainee Engineer

    Messages:
    3
    Hi all,

    I started up SE a few days ago after the most recent update, and it's pretty much completely broken. Thick green lines and static cover the screen, though sound plays through the mess. It's only happening with SE, so I don't think it's a graphical problem. I've checked my driver status, and they're up to date. Some help would be appreciated.

    SYSTEM SPECS:

    AMD 6800k Black Edition 4.1ghz
    SAPPHIRE R9 290 Tri-X
    8GB Kingston Ram
     
  2. Aldakoopa Apprentice Engineer

    Messages:
    437
    Different games will react differently with your GPU, I found that out through overclocking, that some games would be stable at higher performance settings and others would show instability.
    I don't know if this is the case for you, but let's try something...
    Just for curiosity's sake, try using AMD's Catalyst Control Center (part of the driver install package) to underclock the graphics core and memory speeds by 100-200MHz. This will not harm your graphics card in any way, in fact underclocking would probably have more benefits to the longevity of your graphics card, if anything. So, don't worry about what you're doing if you're not familiar with overclocking.

    To do this, open up Catalyst Control Center (CCC for short), should be available by searching in the start menu or on the bottom right of your taskbar, you might have to click "show hidden icons". CCC will appear to be a red ball surrounded by silver balls.

    Open up CCC.
    Find the "Performance" tab on the left side of the window and open it.
    Check "Enable Graphics Overdrive".
    Find "GPU Clock Settings" and "High Performance Memory Clock Settings".

    INDIVIDUALLY lower these, to try and figure out if one or the other is causing your problem:

    First, try lowering the GPU clock by about 100-200MHz, at first, hit apply, and try running the game. If the problem persists, try lowering it another 100MHz and try again. If it goes away, you could fix this by either underclocking or overvolting your GPU to increase stability for Space Engineers. I wouldn't go any lower than about 300MHz below stock speed, because that should be plenty of headroom for stability.

    Next, if that doesn't solve the issue, try lowering the memory the same way. If this works, you can turn your GPU clock back up to normal. If not, then go a little lower and try again. Once again, don't go any lower than about 300MHz. If it is your memory and not your GPU, the only solution would be to lower the memory clock as there's no way to overvolt the memory on graphics cards... at least not that I know of. :( If it is the problem, you can play around with different MHz increments and find it's "Happy place", whatever the highest stable clockspeed it will run Space Engineers at. You'll have to fine tune by 10s and 1s MHz, so you may end up with an odd number like 986MHz for example, but I have no clue what the stock clocks are for that card.

    If neither of these work, restore every thing to default settings and... well... I don't know what to tell you. :( Sorry.

    From my overclocking experience on Radeon cards, this really, really sounds like a VRAM issue to me (GPU memory).
     
    Last edited by a moderator: Mar 15, 2015
  3. NemesisActual Trainee Engineer

    Messages:
    3
    Well, I reduced the memory clock speed, but now my pc keeps rebooting itself after a few seconds, not enough time to open CCC.
     
  4. Aldakoopa Apprentice Engineer

    Messages:
    437
    Whoops... That's strange. Sorry, I've never heard if that happening before, especially with VRAM... If it was system memory, maybe.

    Oh well... You'll have to restart in safe mode, see if you can reset to defaults. Of not, then you'll have to uninstall CCC in safe mode and restart and reinstall the drivers again. Make sure you have the install files, if not then restart on safe mode with networking.

    Press F8 while your computer is starting, before the windows logo appears for the safe mode prompt.


    Sorry again, I didn't realize it would do that.
     
  5. Aldakoopa Apprentice Engineer

    Messages:
    437
    Another oddity is that those clocks you lowered are 3D clocks it only runs at under load from a 3D application (like a game), it shouldn't have affected regular Windows which is all 2D and so the card runs at 2D "idle" clocks to conserve power.

    Weird... Maybe it's a problem with CCC. If you feel like trying again you can use something like MSI Afterburner or Sapphire TrixX to change clocks. You could probably uncheck some kind of 'apply at startup' option on them so it doesn't keep restarting your computer if it happens again.
     
  6. NemesisActual Trainee Engineer

    Messages:
    3
    Not your fault, don't worry. I reinstalled CCC after removing all my AMD content. It broke the reboot loop and also fixed SE. Thanks for all the info.
     
Thread Status:
This last post in this thread was made more than 31 days old.