Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Space Engineers won't start

Discussion in 'Technical Help' started by malleusmintaka, May 27, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. malleusmintaka Trainee Engineer

    Messages:
    8
    Every time I start SE (and ME), i get immediately after the steam "preparing to launch game" window an error with the following log (first is from SE, second from ME):

    2016-05-27 16:42:52.479 - Thread: 1 -> Log Started
    2016-05-27 16:42:52.481 - Thread: 1 -> Timezone (local - UTC): 2h
    2016-05-27 16:42:52.481 - Thread: 1 -> App Version: 02_070_009
    2016-05-27 16:42:52.481 - Thread: 1 -> Steam build: Always true
    2016-05-27 16:42:52.481 - Thread: 1 -> Is official: True [NO][IS][NAMP]
    2016-05-27 16:42:52.481 - Thread: 1 -> Environment.ProcessorCount: 8
    2016-05-27 16:42:52.481 - Thread: 1 -> Environment.OSVersion: Microsoft Windows NT 10.0.10586.0
    2016-05-27 16:42:52.481 - Thread: 1 -> Environment.CommandLine: "C:\Program Files (x86)\Steam\steamapps\common\MedievalEngineers\Bin64\MedievalEngineers.exe"
    2016-05-27 16:42:52.481 - Thread: 1 -> Environment.Is64BitProcess: True
    2016-05-27 16:42:52.481 - Thread: 1 -> Environment.Is64BitOperatingSystem: True
    2016-05-27 16:42:52.481 - Thread: 1 -> Environment.Version: 4.0.30319.42000
    2016-05-27 16:42:52.481 - Thread: 1 -> Environment.CurrentDirectory: C:\Program Files (x86)\Steam\steamapps\common\MedievalEngineers\Bin64
    2016-05-27 16:42:52.481 - Thread: 1 -> MainAssembly.ProcessorArchitecture: Amd64
    2016-05-27 16:42:52.481 - Thread: 1 -> ExecutingAssembly.ProcessorArchitecture: Amd64
    2016-05-27 16:42:52.481 - Thread: 1 -> IntPtr.Size: 8
    2016-05-27 16:42:52.481 - Thread: 1 -> Default Culture: en-GB
    2016-05-27 16:42:52.481 - Thread: 1 -> Default UI Culture: en-GB
    2016-05-27 16:42:52.481 - Thread: 1 -> IsAdmin: False
    2016-05-27 16:42:52.488 - Thread: 1 -> MyConfig.Load() - START
    2016-05-27 16:42:52.491 - Thread: 1 -> Path: C:\Users\.\AppData\Roaming\MedievalEngineers\MedievalEngineers.cfg
    2016-05-27 16:42:52.491 - Thread: 1 -> Config file not found! C:\Users\.\AppData\Roaming\MedievalEngineers\MedievalEngineers.cfg
    2016-05-27 16:42:52.493 - Thread: 1 -> MyConfig.Load() - END
    2016-05-27 16:42:52.494 - Thread: 1 -> Checksum file is missing, game will run as usual but file integrity won't be verified
    2016-05-27 16:42:52.507 - Thread: 1 -> Exception occured: System.TypeLoadException: Could not load type 'IOleControl' from assembly 'System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' because the format is invalid.
    at Sandbox.MyCommonProgramStartup.InitSplashScreen()
    at Sandbox.AppCode.App.MyProgram.Main(String[] args)
    2016-05-27 16:42:52.509 - Thread: 1 -> Hiding window
    2016-05-27 16:42:52.509 - Thread: 1 -> Hiding window done
    2016-05-27 16:42:52.509 - Thread: 1 -> Showing message
    2016-05-27 16:42:52.539 - Thread: 1 -> ERROR: branch name cannot be resolved, services=
    2016-05-27 16:42:52.539 - Thread: 1 -> ERROR: branch name cannot be resolved, services=
    2016-05-27 16:42:52.546 - Thread: 1 -> ERROR: branch name cannot be resolved, services=
    2016-05-27 16:42:52.546 - Thread: 1 -> ERROR: branch name cannot be resolved, services=
    2016-05-27 16:42:52.546 - Thread: 1 -> ERROR: branch name cannot be resolved, services=


    2016-05-27 16:42:57.386 - Thread: 1 -> Log Started
    2016-05-27 16:42:57.388 - Thread: 1 -> Timezone (local - UTC): 2h
    2016-05-27 16:42:57.388 - Thread: 1 -> App Version: 01_136_005
    2016-05-27 16:42:57.388 - Thread: 1 -> Steam build: Always true
    2016-05-27 16:42:57.388 - Thread: 1 -> Is official: True [NO][IS][NAMP]
    2016-05-27 16:42:57.388 - Thread: 1 -> Environment.ProcessorCount: 8
    2016-05-27 16:42:57.388 - Thread: 1 -> Environment.OSVersion: Microsoft Windows NT 10.0.10586.0
    2016-05-27 16:42:57.388 - Thread: 1 -> Environment.CommandLine: "C:\Program Files (x86)\Steam\steamapps\common\SpaceEngineers\Bin64\SpaceEngineers.exe"
    2016-05-27 16:42:57.388 - Thread: 1 -> Environment.Is64BitProcess: True
    2016-05-27 16:42:57.388 - Thread: 1 -> Environment.Is64BitOperatingSystem: True
    2016-05-27 16:42:57.388 - Thread: 1 -> Environment.Version: 4.0.30319.42000
    2016-05-27 16:42:57.388 - Thread: 1 -> Environment.CurrentDirectory: C:\Program Files (x86)\Steam\steamapps\common\SpaceEngineers\Bin64
    2016-05-27 16:42:57.388 - Thread: 1 -> MainAssembly.ProcessorArchitecture: Amd64
    2016-05-27 16:42:57.388 - Thread: 1 -> ExecutingAssembly.ProcessorArchitecture: Amd64
    2016-05-27 16:42:57.388 - Thread: 1 -> IntPtr.Size: 8
    2016-05-27 16:42:57.388 - Thread: 1 -> Default Culture: en-GB
    2016-05-27 16:42:57.388 - Thread: 1 -> Default UI Culture: en-GB
    2016-05-27 16:42:57.388 - Thread: 1 -> IsAdmin: False
    2016-05-27 16:42:57.394 - Thread: 1 -> MyConfig.Load() - START
    2016-05-27 16:42:57.397 - Thread: 1 -> Path: C:\Users\.\AppData\Roaming\SpaceEngineers\SpaceEngineers.cfg
    2016-05-27 16:42:57.398 - Thread: 1 -> Config file not found! C:\Users\.\AppData\Roaming\SpaceEngineers\SpaceEngineers.cfg
    2016-05-27 16:42:57.400 - Thread: 1 -> MyConfig.Load() - END
    2016-05-27 16:42:57.401 - Thread: 1 -> Checksum file is missing, game will run as usual but file integrity won't be verified
    2016-05-27 16:42:57.408 - Thread: 1 -> Exception occured: System.TypeLoadException: Could not load type 'IOleControl' from assembly 'System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' because the format is invalid.
    at Sandbox.MyCommonProgramStartup.InitSplashScreen()
    at SpaceEngineers.MyProgram.Main(String[] args)
    2016-05-27 16:42:57.409 - Thread: 1 -> Hiding window
    2016-05-27 16:42:57.409 - Thread: 1 -> Hiding window done
    2016-05-27 16:42:57.409 - Thread: 1 -> Showing message
    2016-05-27 16:42:57.430 - Thread: 1 -> ERROR: branch name cannot be resolved, services=
    2016-05-27 16:42:57.430 - Thread: 1 -> ERROR: branch name cannot be resolved, services=
    2016-05-27 16:42:57.436 - Thread: 1 -> ERROR: branch name cannot be resolved, services=
    2016-05-27 16:42:57.437 - Thread: 1 -> ERROR: branch name cannot be resolved, services=
    2016-05-27 16:42:57.437 - Thread: 1 -> ERROR: branch name cannot be resolved, services=


    Validating files doesn't work, reinstalling didn't change anything, drivers are up to date. I have Windows 10.

    Can't say since when this error exists because I haven't played for some time. Any help is appreciated!
     
  2. Geneticus Senior Engineer

    Messages:
    1,618
    something is wrong in the OS. you could try reinstalling .net 4.6.2 or using the windows troubleshooter to scan system files incase you have malware. You should also check your AV to make sure it isn't blocking apps from launching.
     
  3. malleusmintaka Trainee Engineer

    Messages:
    8
    Thanks to Geneticus for helping me out, reinstalling the .net 4.6.2 fixed it, can play SE and ME without any problems now.
     
Thread Status:
This last post in this thread was made more than 31 days old.