Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Steamworks is not initialized

Discussion in 'Groups & Dedicated Servers' started by failtolawl, Jul 20, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. failtolawl Trainee Engineer

    Messages:
    44
    I have had a working server on my dedicated box for awhile now, and I started it succesfully and had no issues.

    After the update, I reinstalled the dedicated server software via the steamcmd and have tried running a server, everything works until it sends a message stating "Exception while loading world: Steamworks is not initialized"

    I am wondering what I am forgetting or missing.

    Thank you for your help.
     
  2. GrimmSpector Trainee Engineer

    Messages:
    53
    I'm having this exact same issue on a brand new install via SteamCMD on a Windows box. Can't get anywhere. Very frustrating, someone please help, want to get this server up!
     
  3. MTXRooster Trainee Engineer

    Messages:
    60
    Not sure what steamworks is?
    I searched my logs and no Steamworks come up. Assuming it's a mod? Try making a backup of your folder, then removing the steamworks mod and starting the server then? Some of us DID have a problem with the energy shields mod, which we brought up with the author who immediately patched/updated the mod and solved the problem. I'm guessing same situation with whatever steamworks is?

    You could also try to just create a brand new dedicated server instance and see if it runs. Least you'll have a starting point to compare to.
    This is assuming when you reinstalled, you continued to use the same previous world file/mods etc.. Was that the case or was it a fresh, new install?

    FWIW I also use steamCMD method (I run it on a server box that has no steam client even installed, just game servers) and other than the one mod problem briefly, works fine.
     
  4. GrimmSpector Trainee Engineer

    Messages:
    53
    You clearly have no idea what you're talking about. Steamworks isn't a mod, it's the API that all steam games run that gives them steam capabilities, such as the overlay, achievements, VAC, etc.

    Normally the steam API should execute silently and integrate into the game or server, it shouldn't show up unless it throws an error under most normal circumstances. So something in the latest dedicated server software is at least in some instances causing it to throw an error and fail.

    What's this problem you had with this mod, energy shields? And how do you feel it relates to this issue?
     
  5. MTXRooster Trainee Engineer

    Messages:
    60
    Well I did say I had no idea what it is (I am trying to help).. But I'll reply with this:

    If it is "the API that all steam games run that gives them steam capabilities, such as the overlay, achievements, VAC, etc."

    I'm going to counter this with why, then is it not in any server log in the numerous years I've been running a Space Engineers server? Does it appear in your server log file?
    I only see a small handful of even the mention of "Steam" in my startup log:
    Furthermore it (to me) doesn't make any sense as a dedicated server, is not utilizing ANY of those things, and I doubt the server is loading them; they are steam client things.
    1. Steam game (Space Engineers) has NOTHING to do with your overlay.
    2. Steam game (Space Engineers) has nothing to do directly between YOUR client and the server in terms of achievements. That goes through game->steam-steam API->client.
    3. Steam game (Space Engineers) does not even HAVE VAC (at least not that any search turned up as of 2017, unless they just added it?!??

    I have absolutely no ties with Keen, Steam, Valve, I'm just trying to report to you what I found while looking up your problem. Internet searches can be wrong, and if that's the case, I apologize for listing incorrect facts, but that's what I found, and while you've made it clear that "steamworks" isn't a mod, I again am telling you on my dedicated servers, there is NO mention of a Steamworks, or any other mention of "Steam" other than those three lines I posted. I checked with a server running 43 mods, and I checked with a complete vanilla one. As mentioned, I also installed my dedicated server via SteamCMD. How are you launching the server (initially, as it can, by default once running be a service)? Are you using the DedicatedServer GUI interface/program or a command line only method?
     
Thread Status:
This last post in this thread was made more than 31 days old.