Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

subparts not moving in 1.181

Discussion in 'Modding' started by Hannobal, Jun 8, 2017.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Hannobal Trainee Engineer

    Messages:
    5
    Hi all,

    as of the new verison 1.181 my switchable airtight force field door is sort of broken. The issue is, that it consists of mainly subparts (except for the "dummy" block that's still OK) and these refrain from moving with the ship. Instead they stay in place as ghosts and you can fly through them. I think that this problem arose due to changes in the way physics are handled but I've got no idea how to tackle the issue.

    I'm working with blender v. 2.78 with Harag's SE plugin 0.7.0 and the old version of the MWM Builder uploaded by Digi. I already tried using the "new" MWMBuilder supplied in the current ModSDK but that still gives the old System.ArgumentOutOfRangeException. I also checked wheter there were any changes to the the model of the original AirtightHangarDoor changed especially in the syntax for subparts but that appears not to be the case. It's still empties named "subpart_*" Also it's not the cs-script that causes the problem. I ruled out by simply removing the script from the mod but that didn't help either so it's definitely linked to the model somehow.

    Unfortunately I can't circumvent having subparts in the model. Does anyone have an idea on how I might tackle this problem or experience similar issues?
     
    • Like Like x 2
  2. Draygo Senior Engineer

    Messages:
    1,297
    Set the NeedsWorldMatrix property of the subpart to true and see if that fixes it.
     
  3. Phoera Senior Engineer

    Messages:
    1,713
    ppl sayd you may be need traverse and set for all hierarchy to top
     
  4. Hannobal Trainee Engineer

    Messages:
    5
    Alright, I finally found time to try some stuff. First thanks for the suggestions. Unfortunately I haven't solved the problem yet but I found out the following:
    • NeedsWorldMatrix = true has no effect
    • NeedsUpdate = MyEntityUpdateEnum.EACH_FRAME doesn't work either
    • sp.Value.Render.UpdateRenderObject(true) changes nothing
    • The problem is somewhat connected to the name of the empty in the model: As the block is essentially a Hangar Door, the subparts do move with the ship when I give the empties in the blender model names such as "subpart_HangarDoor_door1" instead of "subpart_Base" or "subpart_ForceField_blue", which I'd like to use. The problem with that is, that the subparts start moving (of cause) when I open/close the door block. Keen must have changed something in the treatment of subparts so that only those subparts that are relevant for the block feature receive a positional update.
    I'm sorry, but I didn't quite get what you mean by "traverse". Do you mean I should update the positions manually? If so, I fear that this might be somewhat over my head.
    I'd really like to get this mod going again. Any other suggestions?
     
  5. Eikester Apprentice Engineer

    Messages:
    423
    he means you need to set NeedsWorldMatrix for every subpart/child entity not just the base
     
Thread Status:
This last post in this thread was made more than 31 days old.