Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. Hello Guest!
    Welcome to the Bug Report forum, please make sure you search for your problem before posting here. If you post a duplicate (that you post the same issue while other people have already done that before) you will be given a warning point which can eventually lead into account limitations !

    Here you can find a guide on how to post a good bug report thread.
    Space Engineers version --- Medieval Engineers version
  2. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Survival infinite inventory bug

Discussion in 'Bug Reports' started by NapAnPn, Apr 2, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. NapAnPn Trainee Engineer

    Messages:
    2
    Hello everyone,

    I have this weid bug in my latest survival game that has me scratching my head.
    A few hours into this game, I started losing consentration and ending up dying. On respawn I started to notice that instead of being able to carry only a few hundred kilos, I could carry several hundred tons.
    I did try respawning, Checked the settings were "Survival and Inventory = Realistic", I even changed to Creative mode for a minute than changed back, I also check my inventory and I noticed my carry weight read "57.0/0.0".

    It's not game breaking but it does feel strange to be able to carry entire ships or mines in my pockets when I should only be able to carry a few blocks.
     
    • Agree Agree x 2
  2. lostkangaroo Trainee Engineer

    Messages:
    6
    Your not the only one I have the same issue with the same conditions you describe.
     
  3. Garith_Mar Trainee Engineer

    Messages:
    1
    I have the same issue
     
  4. Dkz1181 Trainee Engineer

    Messages:
    87
    i have somthing simular, but ive given up worrying about it.. instead of personal inventory my large cargo pods seem to have different max capacities, depending on whether they were built while having realist inventory sizes or x3 sizes, even tho switching between the two modes culls half my inventory (ive lost tons of items and resorces lol) in effect in normal mode i have pods with x3 max capacity or in x3 pods with the normal max capacity, they just dont seem to want to sync or change
     
    • Informative Informative x 1
  5. MacinTrash Trainee Engineer

    Messages:
    5
    ahhhh i was hoping no1 would report this :p

    j/k it needs to be fixed
     
  6. Stingray1980 Trainee Engineer

    Messages:
    3
    Yup i got the same i even tried switching inventory space in the advanced setting, but that doesnt seem to work.
     
  7. Dakroth Apprentice Engineer

    Messages:
    144
    I prefer this bug over the one that preceded it in which items disappeared forever if you ground bloks and didn't have space to carry it all. Some items would even just not be added to your inventory anyway. I suspect that the infinite personal inventory space might be a stop-gap measure while they figure out the previous problem. I noted that it did not appear until after one of the two hotfixes they released after the main update.

    -Dakroth
     
  8. Bobylein Apprentice Engineer

    Messages:
    201
    Do any of you guys use the Hydrogen-Recolored Jetpack Thrusters mod?
    It caused the same issue on our server but seems like the mod author already updated it today.

    Also I gues sit could be caused by another suit modifying mod, but I am not sure.
     
  9. Prescott Freyd Senior Engineer

    Messages:
    1,833
    Hey everyone!

    Thank you all for the reports. Could you please describe the issue in more depth? Does it occur on new worlds without mods as well or only on specific worlds? Also, if you have a world where the issue is present, please upload it here, we'll check it out.

    Regards,
    PF
     
  10. Dkz1181 Trainee Engineer

    Messages:
    87
    unfortunatly, at least from my own experiance this seems to only occure with mods added i did try to replicate this with out anymods on both a new world and an old world with the problem but with mods removed and both worked as to be expected, i cant however comfirm this with the current bugged world as i cant play it due to issue with mods making it laggy and unplayable ( issue already raised and world submitted)
     
  11. turlough51 Trainee Engineer

    Messages:
    11
    i have the bug also where i can literally carry everything i own if i want to , but as bugs go i don't care 2 much if this one takes time to fix,
    the weird part of it is there must be something triggering it, cause one of my mates also plays on my server and he has not got this bug at all he has normal inventory size,

    possible theory for what caused my inventory bug "maybe" as it is only me that it seems to effect and nobody else on my server perhaps its the way i generated the map as i did remake the whole server/world after the last update due to the silly bugs that came with the last update. it could be like how if u generate a world spawn in a planetary lander and immediately save the map then throw it on your server and bam when u log in you have a planetary lander for life :woot:
     
  12. NapAnPn Trainee Engineer

    Messages:
    2
    I've decided to do a text on this bug. Looks like a mod issue.

    Started a New Custom Game - Star System, Survival, Realistic Inventory, NO MODS.
    Spawned over Earth Planet, waited for lander to hit the atmosphere and come to a stop.
    Jumped out the door, no jetpack, landed at speed, died.
    Respawned, NO BUG.
    Save and Exit.
    Had a look at my mod list, choose a mod that directly affected the astronaut. "50x Jetpack Hydrogen Rebalance"
    Load game, repeat fall.
    There's the bug.
    I then decided to save and exit, unload the mod (NO MODS AT THIS POINT), load test.
    Bug is still there.
    Respawned, Bug is gone.

    Gggrrrr, I actually liked that mod.
    I would not be surprised if this is not the only mod that causes this issue.
    I drop a bug report with the mod author when I get a chance (I don't get much time to play through the week), unless someone beets me to the punch.
     
  13. Shadowbreed Trainee Engineer

    Messages:
    8
    We were having the exact same issue.
    Removing S - Sektan Suit v3 - DX11 mod fixed it.

    It sounds like any mod affecting the astronaut might be breaking it currently.
     
  14. MacinTrash Trainee Engineer

    Messages:
    5
    that's not accurate, the sever i play on has 0 mods that affect the astronaut and i have infinite inventory
     
  15. dirtyredz Apprentice Engineer

    Messages:
    208
    Setting your suit back to the default and then killing yourself fixed the issue for me. I had the sektan suit on, i did not have to remove the mod just switch outa the suit.
     
  16. Prescott Freyd Senior Engineer

    Messages:
    1,833
    If you're still experiencing this issue on worlds without mods, please upload the world here or link it to me via personal message so that we can take a look at it ;)

    PF
     
  17. dbiehl1979 Trainee Engineer

    Messages:
    8
    Is there any way to fix this that I am missing in my searches? I cannot seem to get rid of this bug. My world is modded, but all character mods are gone. It happened in a previous world, but I could switch back to the normal astronaut suit and kill myself, and it would be fine. In my new save, it presented itself after I died the first time (wearing the default suit), and there is nothing I can do to get rid of it. As bugs go I can live with this one by acting like I have the hard limit, but it would be nice if it was fixed.
     
  18. ZEvangile Trainee Engineer

    Messages:
    2
    This "bug" come from any mod which modify the charcater but missing the description part for the inventory, added with the patch 1.129. The inventory size is wrote in the sandbox.sbc file so your character must died to reinitiate the value. Missing the inventory part in the character description file lead to an infinite inventory size.

    Here is the missing part :

    <Inventory>
    <InventoryVolume>0.4</InventoryVolume>
    </Inventory>

    0.4 is for 400L (Why 0.4 anyway ?? Why not simply 400 ? Is the volume unit in m3 ?).
     
    • Like Like x 1
  19. Kham Apprentice Engineer

    Messages:
    477
    I'm guessing something else changed in the code for suits and yet again there have been no notes released for modders to up date their skins sadly.
     
  20. dbiehl1979 Trainee Engineer

    Messages:
    8
    And it started working out of the blue again, with custom characters and everything. I didn't change a thing. Now to figure out why my small util ship isn't working like it used to. I am still loving this game, even with all the small bugs and annoyances.
     
  21. jandraelune Apprentice Engineer

    Messages:
    218
    Yep...change your suit skin back to vanilla and suicide, that fix's the issue.
     
Thread Status:
This last post in this thread was made more than 31 days old.