Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

The (unofficial) Bug list

Discussion in 'Technical Help' started by switchback, Oct 17, 2013.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. switchback Trainee Engineer

    Messages:
    6
    Before posting, remember this thread should be for bugs within the game, not problems starting up/purchase issues. Things such as CTD's (Crashes to Desktop) should be posted here.

    Remember, the faster any bugs are reported the faster they can be addressed by the devs.

    Before posting, Read these links:
    System Requirements
    Troubleshooting

    Use the below Form to fill out the bug report:

    An Example Report (And a problem I am experiencing currently):
    Issue: CTD
    Description: Game Crashes to the Desktop when alt-tabbing out and clicking the toolbar to get back in-game.
    Build Number: 01.001.005 (2013-10-17 05:13)
    System Specs: Intel Core i5 3570k @ 4.4ghz, GTX-670, 8gb RAM, Windows 7 Professional
    Notes: For some reason on odd occasions it will not CTD, but 90% of the time (at least for me) the game will CTD.
    Pictures?: N/A


    Bug List (Green for Confirmed Bugs, red for unconfirmed. Blue for fixed bugs):
    Deformation not Showing/certain blocks have No-clip characteristics < This may not be a bug, depending on the specific blocks being used. Only the Light Armor blocks have completed impact characteristics. Still noteworthy and therefore listed.

    Small Ship landed the nose of the large Red Default ship results in loss of Left-Right and Roll control

    Camera Resets when using the Large Blue Default Ship < I checked this with the Red large ship and the blue ship, only happens with the large default blue ship

    Not Enough Memory error after loading game < False Alarm, possible memory leak?

    Error Report when exiting game via Exit Button on main menu

    Music stops playing after alt-tabbing out


    CTD after Alt-Tabbing

    Graphical Artifacts and texture issues while ramming & shifting views
     
  2. Acela5 Trainee Engineer

    Messages:
    70
    Issue: Odd texture glitch
    Description: Twice i have seen this now when ramming ships and messing with views
    Build Number: 01.001.005 (2013-10-17 05:13)
    System specs: i7 3770k, gtx 680, 16gb ram, windows 7 ultimate 64 bit
    Notes: Nothing major as Alt Tabing to desktop and back seems to fix it. However the game does lose performance and lag while it is happening.
    Pics:
    [​IMG] [​IMG] [​IMG]
     
  3. Stranger Trainee Engineer

    Messages:
    6
    Issue: Falling through blocks
    Description: I sometimes can fall through deformed blocked even though there are no visible holes
    Build Number: 001.001..05
    Short Video Showing the Bug: http://www.twitch.tv/johnsgalt/c/3099710

    I have also attached the save file.
     
  4. gordogomez Trainee Engineer

    Messages:
    28
    Issue: Camera resets when flying ship and using free look

    Description: using the large blue ship (the one far away) of easy start 1, when using free look, if you look straight back (look at the front of the ship) the camera resets to its original position.

    Build Number:01.001.005

    System Specs: i5-750, ati radeon hd 5850, 4gb ram, win 7 64-bit professional
     
  5. gordogomez Trainee Engineer

    Messages:
    28
    Issue: Slow downs when walking

    Description: When walking inside any structure in easy start 2 there are some random slow downs in the walking speeds

    Build Number:01.001.005

    System Specs: i5-750, ati radeon hd 5850, 4gb ram, win 7 64-bit professional
     
  6. gordogomez Trainee Engineer

    Messages:
    28
    I'm on fire haha

    Issue: Unable to turn or roll when small ship is placed inside large ship

    Description: In easy start 2 when I place a blue small ship inside the red large ship (parked it on the front opening), and then control the red ship I am unable to either roll or turn (not even using the arrow keys) the large ship

    Build Number:01.001.005

    System Specs: i5-750, ati radeon hd 5850, 4gb ram, win 7 64-bit professional
     
  7. gordogomez Trainee Engineer

    Messages:
    28
    Issue: Asteroid texture disappears after crashing onto it

    Description: Crashed ship onto asteroid and some textures disappeared. See pics

    Build Number:01.001.005

    System Specs: i5-750, ati radeon hd 5850, 4gb ram, win 7 64-bit professional

    Pictures:

    [​IMG]
    [​IMG]
     
  8. switchback Trainee Engineer

    Messages:
    6
    Updated the post with new problems.
    @Acela5 Looks a bit like a graphics card driver issue, but I added it regardless.


    Devs, if you want me to add something to the bug report sheet message/post and I can edit it in. Or change it yourself I guess :woot:
     
  9. yttrium Apprentice Engineer

    Messages:
    141
    Issue: Music stops playing after tabbing out.
    Description: Self-explanatory. Trying to alt+tab while the game is running, and then re-focusing the game, causes the music to stop playing indefinitely. Audio still works, only music stops.
    Build Number: 01.001.005 2013-10-17 05:13
    System Specs: i5 2500k @ 4.5GHz, 550 Ti 1GB, 6GB RAM, Windows 7 Ultimate SP1 64-bit.
    Notes: Only tested in fullscreen, doubt it's an issue in windowed.
     
  10. Valkyrx Trainee Engineer

    Messages:
    5
    Severe performance issues on my gaming laptop, specs are

    Intel i7
    Windows 8
    Geforce 660m gpu
    8 gb ram

    Even on normal im getting about 5 fps sometimes rises to 10 fps, makes it unplayable, all other games i can run on high or ultra at least
     
  11. Scorpion00021 Senior Engineer

    Messages:
    1,411
    Issue:Not enough memory to place objects
    Description:After loading a saved game, the game disallows placement of blocks, claiming to not have enough memory.
    Build Number:01.001.005

    System Specs:
    Intel Core i7 @2.30 GHz
    Windows 7 Home Premium 64 bit
    8GB RAM
    NVidia GeForce GTX 660M - 2GB dedicated VRAM

    Notes: Tabbing out of the game and back into it resolves the problem. Found this when using CTRL ALT DEL to check memory usage. Game was working properly upon return. I get this problem almost every time I load a saved game.
     
  12. Sgt Doom Trainee Engineer

    Messages:
    99
    Issue: Crash upon exiting the game
    Description: When quitting the game, it crashes and generates an error report. It does this every time I quit the game,
    Build Number:01.001.005

    System Specs:
    Intel Core i7 965 @3.20 GHz
    Windows 7 Home Premium 64 bit
    12GB RAM
    Nvidia GeForce GTX 660 Ti - 2GB dedicated VRAM

    Notes: Not really an issue as you can imagine, but it's a bit odd.
     
  13. switchback Trainee Engineer

    Messages:
    6
    @Valkyrx That isn't a problem with game, but rather your computer's setup. Check this thread: http://forums.keenswh.com/post/space-engineers-running-really-slow-6577353

    As for the other issues, updated the list. Most of these issues have been confirmed, with the exception of the music one, which I will check later.
     
  14. Moonblink Trainee Engineer

    Messages:
    19
    Issue:Crash to Desktop
    Description: Random crash every now and then. I will get the same crash error when closing the game
    Build Number:
    System Specs: i73770K @4.4ghz 16GB DDR3 GTX650 Ti Boost 2GB DDR5 Win 7 64
    Notes:Seems to be random and not very frequent. Next crash I'll snap a photo and post it here.
    Pictures?:Ill get one next time
     
  15. Acela5 Trainee Engineer

    Messages:
    70
    Edit: This seems to be happening to more of my ships on ocassion including small ships, but mainly just the ship in the picture.
    Issue: All thrusters break off ship
    Description: One of my ship designs that i made and used to work will now randomly break every thruster off it when i as much as tap something.
    Build Number: 01.001.007, 2013-10-18
    System specs: i7 3770k, gtx 680, 16gb ram, windows 7 ultimate 64 bit
    Notes: every time i load the save i can replicate this problem by tapping anything with the ship.
    Save: /images/icons/file_types/zip.gif creative world.zip
    Pics:
    [​IMG] [​IMG]
     
  16. Sgt Doom Trainee Engineer

    Messages:
    99
    Saves can be found in C:\Users\(username)\AppData\Roaming\SpaceEngineers\Saves
     
  17. Acela5 Trainee Engineer

    Messages:
    70
    Issue: I can build only one side of my ship
    Description: When i try to build on my ship if i'm facing the direction shown in the picture the blocks go through to the other side like i'm building on the station.
    Build Number: 01.001.007, 2013-10-18
    System specs: i7 3770k, gtx 680, 16gb ram, windows 7 ultimate 64 bit
    Notes: If i turn my ship around then its the other side that glitches through it is still the same for the direction my character is facing.
    Save file: /images/icons/file_types/zip.gif creative world.zip
    Pics:
    [​IMG] [​IMG]
     
  18. Sgt Doom Trainee Engineer

    Messages:
    99
    Issue: Collision box of large thruster larger than it should be
    Description: The back of the large ship's large thruster's collision box extends at least a block further than the model itself
    Build Number: 01.001.007, 2013-10-18
    System Specs: Intel Core i7 965 @3.20 GHz, Windows 7 Home Premium 64 bit, 12GB RAM, Nvidia GeForce GTX 660 Ti - 2GB dedicated VRAM
    Notes: I can place things fine on the back of the thruster, it just blocks player movement

    Picture:
    [​IMG]
     
  19. gordogomez Trainee Engineer

    Messages:
    28
    Issue: Large thrust block has invisible back

    Description: the large thrust block has an invisible part behind it that prevents movement.

    Build Number:01.001.007

    System Specs: i5-750, ati radeon hd 5850, 4gb ram, win 7 64-bit professional

    Notes: Just place a large thrust and try to walk behind it
     
  20. crazyhedredd Trainee Engineer

    Messages:
    1
    Issue: Unable to place objects after loading save file.
    Description:After saving game and loading save file, game states that there is not enough memory to add new objects. Exiting and reloading the save and/or exiting the game and restarting the game and save does not eliminate the problem.
    Build Number: 01.001.007 (2013-10-18 06:55)
    System Specs: Intel Core i5 2400 @ 3.1ghz, GTX 670, 8gb RAM, Windows 7 Ultimate 64 bit
    Notes: I have tried tabbing out of the game as the other user who had this issue suggested, did not work for me.
    Pictures:
    [​IMG]
     
  21. TechyBen Junior Engineer

    Messages:
    542
    I get this bug too.
    Save is here: http://benart.www.idnet.com/NewWorldTB.zip

    That save also crashes if a block is deleted (might have overreached the memory limit by mistake).
    Issue: Game crashes when block deleted.
    Description: Delete a block and the game crashes.
    Build Number: 01.001.007, 2013-10-18
    System specs: AMD PhenII 3.4GHZ 4 core (970), ATI4870, 4GB ram, Windows 7 64bit.
    Save: As above.
     
  22. Scorpion00021 Senior Engineer

    Messages:
    1,411
    Issue:Spawn inside asteroid model when crashing at high speed
    Description:I crashed a ship into an asteroid at high speed and upon destruction of the cockpit, I was ejected into the asteroid's mesh. I was unable to leave the object.
    Build Number:01.001.007

    System Specs:
    Intel Core i7 @2.30 GHz
    Windows 7 Home Premium 64 bit
    8GB RAM
    NVidia GeForce GTX 660M - 2GB dedicated VRAM

     
Thread Status:
This last post in this thread was made more than 31 days old.