Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Unable to connect to Friends only server

Discussion in 'Multiplayer' started by penguintutor, Dec 27, 2018.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. penguintutor Trainee Engineer

    Messages:
    3
    I am having a problem with connecting to a server created by a friend. This worked on the first day we tried (25 December 2018), but we have tried on two days since and have not been able to connect.

    We are both friends on Steam and on the same network.

    Are there any tools that can be used to test connectivity and/or see if there are any problems connecting to the same server?
     
  2. mojomann71 Senior Engineer

    Messages:
    1,410
    It could be a number of things preventing the connection.
    There are no tools that I am aware of that would pinpoint the cause.
    Check to see if one of you has experimental mode enabled and the other does not.
    Try inviting to game from Steam interface and not through the game browser. (I have a friend and the only way we can connect is from one of us using Steam invite)
     
  3. penguintutor Trainee Engineer

    Messages:
    3
    Thanks for the reply - unfortunately I am still unable to connect to the same game.
    Both games are in experimental mode and tried through Steam invite.

    I've also tried creating a public game and my friend cannot see that either.

    It worked on the first day we installed, but hasn't worked since.
     
  4. mojomann71 Senior Engineer

    Messages:
    1,410
    Both of you should try verifying the game files just to see if that helps.

    Verify Integrity of Game Files
    1. Restart your computer and launch Steam.
    2. From the Library section, right-click on the game and select Properties from the menu.
    3. Select the Local files tab and click the Verify integrity of game files... button.
    4. Steam will verify the game's files - this process may take several minutes.
    Not sure what else it could be unless ports are blocked on your router. port 27016 should be the one to check. (I think)
     
  5. penguintutor Trainee Engineer

    Messages:
    3
    Thanks for the suggestion.

    I did a verify game files and it just reported all files verified.

    I tried starting a game using my friend's computer and was unable to see the game from my computer.
    I then tried starting the game from my computer and my friend could then see the game and join.

    Both games were setup exactly the same and it was working before without any problems.

    This is however progress on what I had beofore where I was not able to see games regardless of who / how they were created.

    Looks like this may be an intermittent problem, so I'll just keep trying different configurations and see if there is a pattern.
     
  6. mojomann71 Senior Engineer

    Messages:
    1,410
    @penguintutor hopefully you will not have any more issues with it. If it does happen again just repeat verifying files again. :)
     
  7. SubtleSloth Trainee Engineer

    Messages:
    44
    Hey bud, I’ve had a lot of issues dealing with my dedicated servers and it sounds like you are having one of the same ones I had in the very beginning.

    First, make sure that if your friend’s server has a password on it, that you go into the advanced filter settings in the server window in game, and make sure ‘Has Password’ is checked. As it turns out, you can’t see any passworded servers without it checked...even if all of the IP settings and everything else is setup perfectly. I had this problem for about 4 days when I setup my newest server .

    If that doesn’t fix it, make sure your friend has the SE ports forwarded correctly in his router settings. I believe the server port is 27016. And make sure his server is set to public.

    All this information is assuming you guys are trying to use a dedicated server. Let me know if you guys have figured it out yet!
     
Thread Status:
This last post in this thread was made more than 31 days old.