Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 01.102 - Performance & bug fixes, Character's jump corresponds to gravity strength

Discussion in 'Change Log' started by George.Mamakos, Oct 2, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Scorpion00021 Senior Engineer

    Messages:
    1,411
    Holy cow, you've really oudone yourselves keen... that moon... Were those procedurally generated impact craters and ridges?!? And that goegeous desert.. those sand dunes were fantastic. The coloration of the atmosphere.. the clouds.. it was magnificent! I'm really looking forward to seeing what you guys come up with
    And great job on bugs this week. That was quite a list
     
    • Like Like x 1
  2. KissSh0t Master Engineer

    Messages:
    3,722
    Better argument? I was not arguing with you just stating the obvious.

    Multiplayer in it's current form is just placeholder, you would be better off waiting for the actual multiplayer update instead of wasting your money.
     
    • Like Like x 2
  3. Thedevistator Senior Engineer

    Messages:
    1,942
    What's the point of fixing a broken netcode when we're getting a new one. Honestly I think the only mistake keen made was releasing dedicated servers before the new netcode in the first place.
     
    • Like Like x 2
  4. Stardriver907 Master Engineer

    Messages:
    3,368
    Nothing wrong with Keen's priorities. Or, did they MAKE you go out and rent that server? In my opinion, it is unwise to rent a server to play an alpha game on. At least without considering that things will go wrong. I certainly hope you're not promising a bug-free experience for everyone that uses your server, because that would be fraud.

    See you next week, when they probably still haven't fixed your problem.
     
    • Like Like x 5
  5. LFCavalcanti Senior Engineer

    Messages:
    1,378
    This update video made me get back to this forum... nice touch of humor and that movement sync... :D
     
  6. Visentinel Junior Engineer

    Messages:
    843
    • Like Like x 1
  7. Shadowtim3 Trainee Engineer

    Messages:
    6
    Keen . . . NEVER STOP DOING EPICNESS! If you do, I will cry.
     
  8. Shadowtim3 Trainee Engineer

    Messages:
    6
    Keen . . . NEVER STOP DOING EPICNESS! If you do, I will cry.
     
  9. Super_Happy_Alien Apprentice Engineer

    Messages:
    388
    Thanks for putting this out , i have tried but still not working m do i have to delete sensosr with Toolbox as well
     
  10. Protocol005 Trainee Engineer

    Messages:
    29
    some impotant updates in this fix= good! but now my small ships can't move at all. I put together a tiny little zipper of a ship ( cockpit, a couple light armor blocks, gyro, two med containers and 2 small thrusters in each direction powered by 2 small reactors,) and it WILL NOT MOVE. so once again my game is rendered unplayable cause I can't use my ship grinder, ship welder or even mine for stuff. Why'd you guys have to go and break the game just when I'm building my very first large block ship????? =C.
     
  11. BlackRedDead Apprentice Engineer

    Messages:
    204
    best update ever!!! :)
    also very nice video! :)
    now fix the ~200 other reported bugs - bring back ladders and add more block shapes AND THEN - planets can comming^^
    (but pls as world option - idc about planets much! :)
     
  12. Ash87 Senior Engineer

    Messages:
    1,977
    Annnnnnnd, now I need to change my pants.
     
  13. Visentinel Junior Engineer

    Messages:
    843
    mmm well i have done the best i can do the thing i noticed on the dedicated server was the sensor would still be able to trigger if you came within the 1 meter range it has. i set 0 meters range but the game still then just does 1 meter range, when you get on the server just access the sensors control panel from as far as u can and turn it off or do it via an antenna.

    What i did beforehand was to also edit the sanbox.sbs file manually and i set all sensors to "false" in the enabled tag.

    -edit im just toying with it abit to see if i can do more, i made the mod in haste so i am trying a couple more things to see if i can truly make them dead as a door nail.
    -edit2 theres nothing else i can do to the sensorblock :( atleast with what this mod can do is limit it to 1 meter giving most people the chance to atleast get near or into the area to shut the sensor down.
     
    Last edited: Oct 2, 2015
  14. ZOP Trainee Engineer

    Messages:
    1
    New bugs:
    Attempting to mine ice now crashes.
    Cannot depressurize any longer either.
     
  15. GreenStepper Trainee Engineer

    Messages:
    52
    i cant play any world after this update. every world keep loading for over 1 hour and after that i press alt+f4.
    if i creat a new world, it loads the same time.
     
  16. Thedevistator Senior Engineer

    Messages:
    1,942
    Do you ever notice that the loading wheel freezes and starts again? If so go into SE full screen and when that happens press shift f11, and if a performance menu pops out alt tab to desktop. Then wait until you here the SE music to start playing or something else to listen to. Then open the game up again.
     
  17. GreenStepper Trainee Engineer

    Messages:
    52
    i tried that. but it still nothing happens. i changed to DX9. lets see if this works better


    EDIT: ok SE freezed completly.
    i try again after the next hotfix or so
     
    Last edited: Oct 2, 2015
  18. Manticore Apprentice Engineer

    Messages:
    189
    Yep; this really needed to happen. Thanks Keen.
     
    • Like Like x 1
  19. Mix-martes86 Senior Engineer

    Messages:
    1,110
    Ha!, missed my release ETA by 27 minutes, but I was right on the teaser and massive bugfixing... and the total ungratefulness I've seen in a comment or two, though despite the bugs, most people seem to appreciate the effort.
    In any case, wonderful patch, lots of nice fixes, and a kick-ass teaser (you people are surely getting creative hahaha). Damn right we like it. Now, next week should come another teaser. :D

    Cheers
     
  20. ATalkingRock Apprentice Engineer

    Messages:
    396
    I love this update an' all, but I wonder if it's intentional that small ships which are locked by landing gear are not detected by sensors anymore. hm
     
  21. gimmilfactory Junior Engineer

    Messages:
    523
    Please fix the projector next!
     
  22. S7E Trainee Engineer

    Messages:
    27
    The Welder keeps making sound after a block is built.

    Also it seems that the oxygen generators do not work anymore (tested in Creative Mode).
     
    • Disagree Disagree x 1
  23. Altair Trainee Engineer

    Messages:
    46
    Could you improve/fix the oxygen system please?
     
  24. Beeskee Trainee Engineer

    Messages:
    46
    Did the oxygen issues get fixed?
     
  25. Cassius Faux Apprentice Engineer

    Messages:
    175
    That teaser was the best. As for the wheels fix, anyone know if the separate wheels(That you can just place on the side of your vehicle as a spare tire) follow the same physics and collisions as the wheels attached to axles?
     
  26. severedsolo Trainee Engineer

    Messages:
    15
    Doesn't look like it =/ I just loaded up my survival world, and my vents are still refusing to depressurise into an empty tank.

    Having said that - that is a huge list of fixes, and alot of my other issues are on that list, so I can't complain too much.

    I can work around this one at least.
     
  27. Lithorn Trainee Engineer

    Messages:
    50
    Love the patches but I'm experiencing some weirdness.

    Drill rotational sound is fine, until it comes in contact with the asteroid to which it then sputters a drill hitting/eating sound every second or so instead of consistent sound. Works fine ore wise.
    My game, despite auto save being off, is now locking up every so often and the mods I have did not do this in the previous update though I did enable Pirate drones. (Maybe thats the cause of the random lockups? Drive is SSD in near perfect condition) I'll try doing a plain test with this.
    I am also experiencing weird graphics on low distance settings (I like mah fps), seems like the textures don't like to stay loaded until I get closer (I don't mean they look bad (Other than gold being fuzzy), but HUGE chunks of XXX becomes stone once I get close enough)) and I often see holes in the textures
     
  28. Martinineter Senior Engineer

    Messages:
    2,253
    I love those fixes, can't wait for planets to come. These steps sure are going in the right direction
     
  29. Commander Rotal Master Engineer

    Messages:
    4,979
    There are SO MUCH BIGGER ships with twice and more blocks than the Tapping had the last time she had crash issues. I don't know where the block limit lies but i never even came close. Not when a 300k block ship works but my 190k ship crashes.

    Also i don't mind that i have low FPS, i just want back to the numbers i already had before the Week Of Hell. At least the UPS are firmly above 60. Feels very fluid, considering the FPS.
     
    • Like Like x 1
  30. DivineWrath Junior Engineer

    Messages:
    531
    I'm glad to help when I can. Just keep in mind that some of us need to take a break here and there. I can't play your game all the time, and other games do show up to catch my interest.
     
Thread Status:
This last post in this thread was made more than 31 days old.