Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 01.112 - Ore in rocks

Discussion in 'Change Log' started by Drui, Dec 10, 2015.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Devon_v Senior Engineer

    Messages:
    1,602
    It's not necessarily the map, it could be a single object. Sometimes things go a little weird on a new patch. The patch before this one threw one of my ships away at maximum speed. The thing made it over 200,000m before I noticed it was missing. Many patches ago the crashed red ship violently ejected itself from the asteroid. I also had a strange problem last week that SEToolbox resolved by deleting my astronaut and making a new one.

    Can you get space master mode working in single player? If you cycle through ships and junk you might find something glitching out that is the cause.
     
    • Agree Agree x 1
  2. PhoenixTheSage Junior Engineer

    Messages:
    677
    What are you talking about? Lol wow, you didn't even understand the line you quoted...AND you don't know what a strawman argument means.
    I'm outta here, cause now is the point where you argue for the sake of arguing.
     
    • Funny Funny x 1
  3. Jas Apprentice Engineer

    Messages:
    443
    development or patch releases arent focused on multiplayer atm over to fix gamebreaking bugs, so i cant understand all this ... bha
     
  4. JustBurn Trainee Engineer

    Messages:
    60
    It's more like a complete joke really... there's dozens of really good bug tracking tools around, why KEEN are using forums!? It kinda works (as a poor's man solution) but it's very inefficient.

    I've used Arma3 Bug Tracker to post a certain bug , not only they were able to merge reports with same issue but also they fixed that bug in less than a week, now that is efficiency!
     
    • Informative Informative x 2
  5. Kham Apprentice Engineer

    Messages:
    478
    Any mention of what today's hotfix resolved? Hoping it was the constant crashing introduced, but no notes.
     
  6. wd56 Apprentice Engineer

    Messages:
    147
    Hey Keen is there any reason you no longer provide detailed changelogs to every update/hot fix you send out? You guys used to do a great job detailed all changes in past logs, what's changed now?
     
  7. Stardriver907 Master Engineer

    Messages:
    3,368
    Wow, that was interesting. Appears it's actually called Mantis Bug Tracker. Gonna make a suggestion to Keen.
     
  8. Nemesismax Trainee Engineer

    Messages:
    89
    Have any of you figured out what that ninja hotfix was all about?
     
  9. DivineWrath Junior Engineer

    Messages:
    531
    Recycling and rebuilding hand tools worked for me. Solved some problems. I'm glad I read the forums before freaking out.

    Earlier, I was having trouble with crashes when I was using my hand tools to do mining. It seemed like it would happen when my drill was picking up ore (by pointing it at the ore when active). I also found that it often wouldn't display the right tool, showing a red t1 drill instead of the yellow t2 drill. After the latest patch, it also crashed when I tried using a t2 grinder. I think that adding stuff to my engineer's inventory was a the problem with those tools. I was going to report the problem but then I saw on the forums (this thread) that recycling the hand tools and remaking them would fix the problem. An easy decision considering that one of the new rocks with ore happened to spawn near my base and had contained some silver that I couldn't find, so I was able to go to t3 hand tools. It worked.
     
    Last edited: Dec 11, 2015
    • Informative Informative x 1
  10. Patton 2 Trainee Engineer

    Messages:
    20
    Camera zoom had finally been fixed after the hotfix.
     
    • Informative Informative x 1
  11. wd56 Apprentice Engineer

    Messages:
    147
    DAmn I must have been slow, I just realized you were being sarcastic...

    smh...switching off the internet....
     
  12. GrinderFurax Trainee Engineer

    Messages:
    14
    Where can I find this tool?
     
  13. DiggaTron Trainee Engineer

    Messages:
    44

    Did you just compare KSH to BIS? Wonder what BIS's bug tracking looked like a decade ago, and minus over 100 employees.
     
  14. GrinderFurax Trainee Engineer

    Messages:
    14
    Ok I installed Setoolbox, what can I do to see if something is worrying our save?
     
  15. entspeak Senior Engineer

    Messages:
    1,744
    Ask your save where on the doll it was touched. ;)
     
    • Funny Funny x 4
  16. TenTonBlue Trainee Engineer

    Messages:
    94
    Well ive noticed around the very base of the tree you still cant build blocks but about the upper half where all of the leaves are you can build whatever you want. Once it respawns it looks a bit funny, otherwise no issues ive seen thus far.
     
    • Informative Informative x 1
  17. Neeneko Trainee Engineer

    Messages:
    63
    Hrm. Is anyone else getting strange new lighting after this patch?

    I just tried it out and am getting some kind of semi transparent sheet around spotlights that are rendering them kinda hard to see through.
     
  18. DevilDog2098 Trainee Engineer

    Messages:
    14
    Mantis actually is a royal pain in the butt to implement because of everything it has to tie into. We used to use it at work but it took more time to implement and actually use than it was worth. As far as the user side it would be an absolute nightmare just because of everything that is involved in creating a ticket. Keen would probably end up spending more time explaining how to use it than they would actually fixing bugs.
     
    • Informative Informative x 1
  19. strtz Trainee Engineer

    Messages:
    1
    Does anyone else experience alot of game crashes in multi/single player and horrible desync since the last update?

    also i`m still falling through the planet, going into asteroids so i dont think these have been actually fixed.....
     
  20. Neeneko Trainee Engineer

    Messages:
    63
    Plus, if nothing else, they probably already have their own internal system, so if they were going to have a second, more exposed one, they would get more miliage out of one that integrates with whatever they are already using.
     
    • Agree Agree x 1
  21. AlchemicalAgent Apprentice Engineer

    Messages:
    113
    Sort all objects by distance and see if anything is much farther away than it should be.
    You can also look for a lot of small-mass grids in the same spot that may be parts of a collision.
     
    • Agree Agree x 1
  22. NewGAMEMASTER Apprentice Engineer

    Messages:
    120
    Since when do mined rocks float if you mine the voxels under them ???
    (They've been lain there for a while)
    Sry for my bad english
     
    • Funny Funny x 1
  23. rexxar Senior Engineer

    Messages:
    1,532
    The fact remains that the SE server can only utilize one core's worth of resources. If you have a four core processor, SE will use ~25% total processor resources. Whether or not execution is confined to a single core or spread out is up to your system. In your case, the load is being spread across all cores. I don't know enough about threading to tell you why this happens, only that it does.

    This is a long-standing issue, and the cause of pretty much all DS performance issues. We just have to hope that Keen implements multicore processing in the new netcode.
     
    • Agree Agree x 1
  24. Sir Arthur Wellesley Trainee Engineer

    Messages:
    9
    SIGH...PROJECTORS?!
     
    • Agree Agree x 1
    • Disagree Disagree x 1
  25. Two Apprentice Engineer

    Messages:
    300
    Yes, if you are blind it is a smooth and fitting solution. Otherwise it is the most simplest and crude workaround that was possibly applicable aside from shutting down multiplayer all together.
     
    • Disagree Disagree x 1
  26. gimmilfactory Junior Engineer

    Messages:
    523
    I've been waiting for this to be fixed since they introduced them.
     
  27. TEEN Trainee Engineer

    Messages:
    4
    what added in friday hotfix? where changelog list?
     
  28. Ulfsark Master Engineer

    Messages:
    3,057
    yeah, what about them?
     
  29. papista221 Trainee Engineer

    Messages:
    4
    For me, it was problem only on Linux Server which i try to.... But on Windows Server its ok!
     
    • Disagree Disagree x 1
  30. Jas Apprentice Engineer

    Messages:
    443
    i think they added alteast 2 things: (but not sure if its were present in the first .112 update)
    Camera zoom fixed
    Speed displayed in HUD fixed
     
    • Like Like x 1
    • Informative Informative x 1
Thread Status:
This last post in this thread was made more than 31 days old.