Welcome to Keen Software House Forums! Log in or Sign up to interact with the KSH community.
  1. You are currently browsing our forum as a guest. Create your own forum account to access all forum functionality.

Update 01.128 - New Animation System

Discussion in 'Change Log' started by Drui, Mar 31, 2016.

Thread Status:
This last post in this thread was made more than 31 days old.
  1. Sjonnieloper Trainee Engineer

    Messages:
    14
    yay, we can do the moonwalk...

    Aggain very dissapointed...

    Earth atmosphheric thrusters seem to have lost 30% of theyre power, every time the load changes the inirtia dampeners crash me to the ground, basicly broke all my small welding grinding and mining vehicles..

    I hope you guys fix this in the bugfix of tomorow,

    Cuz if ya dont, ill stop playing this ^&*&^^%#$@$!
     
    • Agree Agree x 3
    • Funny Funny x 2
  2. Fus Apprentice Engineer

    Messages:
    247
    I get the feeling that some original progammers left and the new guys are struggling.
     
    • Agree Agree x 7
  3. AriesFirewind Trainee Engineer

    Messages:
    11
    THis update was yesterday literaly crushing my game...lander to be precise. And it keep doing that anytime I tried to touch single window or spare armour for recycle . In second I touched it, I literaly made huge hole in ship and destroyed good part of mashines...Awsome update guys. I actualy created my forum account here just so I can complain. Bought this early Access game a week ago...and I can tell you it is my last early Access I bought. Now I literaly can't play planet survival wich I like, due to my lander being wrecked on First attempt of recycling it. I mean will it happen when I start to build my main mobile base? I thik I would go beserk if that happens. Ow yea..and my game keep crashing EVERY single time I exited map I was playing on.
    Not to mention that when I severed large thruster pylons to recycle engine on the ground...damn thing vanished...and so all Resources!

    If this "update" was April 1st joke..Well let me tell you guys.. It is not funny to make jokes with another people's cash and free time they meant to spen with game they paid and actualy enjoyed. I don't wan't to dramatize but It does ruin my belive in any future game...I have other things to spend my cash on...

    TO short this.. Please fix it...asap!
     
    • Agree Agree x 1
  4. The MoSS 2 Apprentice Engineer

    Messages:
    159
    But I don't see any cooling :-D
     
    • Funny Funny x 1
  5. Hemp Plan[e]t Apprentice Engineer

    Messages:
    157
    i hope game get's simspeed like after 1.126 with todays hotfix ;)
     
    • Disagree Disagree x 1
  6. g4borg Apprentice Engineer

    Messages:
    271
    I can't agree with your standpoint due to several reasons

    So I still do agree, it is not their responsibility as long as they dont take it. But it is ours to point out, which decision would be wiser.
     
    Last edited: Apr 1, 2016
    • Agree Agree x 1
    • Friendly Friendly x 1
  7. Hemp Plan[e]t Apprentice Engineer

    Messages:
    157
    when u will fix the autopilot? Autodocking is still unpossible and the ships are stucking
     
    • Disagree Disagree x 1
    • Funny Funny x 1
  8. mikeloeven Senior Engineer

    Messages:
    1,162
    New animation system essentially breaks all Animation mods permanently.

    I spent the better part of yesterday posting bug reports for broken animations in a verity of mods. On one of the comment pages I got a reply from Darth Biomech that was more than a bit disturbing. If it's accurate than there is no future for mods that require custom animations

    [​IMG]

    Apparently the only way to modify animations in the new system is to replace the entire character animation system which renders all mods with custom animations mutually exclusive. No animation mod can coexist with with another.

    Sorry for blowing the whistle here but this is a major disaster for modding and a completely idiotic thing for keen to do

    In a single update keen has taken us from space age back to the stone age

    [​IMG]
     
    Last edited: Apr 1, 2016
    • Informative Informative x 8
    • Funny Funny x 6
    • Agree Agree x 2
  9. Aurex Trainee Engineer

    Messages:
    87
    Would love to try out this new patch, but game is still crashing as per my bug report. It's been 4 weeks now.
     
  10. -dc- Trainee Engineer

    Messages:
    3
    Any news when MP will be playable again (thrusters, animations)?
    I've noticed actually that thrusters more or less works fine but only horizontal, if I want to move straight vertical it rather goes down slowly instead of up. When I point up but with some angle I can push forward and that's the only way to go up right now. Tested on planet with jetpack. Not sure is that for all thrusters but people keep whining because of crashed ships.

    Is it done on purpose that simspeed takes effect on character movement? It feels like slowmotion with simspeed 0.6 :| quite annoying.
     
  11. DeltaDestiny Apprentice Engineer

    Messages:
    100
    Great, i'm eagerly awaiting the performance fixes still.
     
  12. combatsmithen Trainee Engineer

    Messages:
    47
    Well hey! This patch broke more than it fixed! Sim speed is even lower than before. It was .3-.4 before the patch, now its .2 and below. Earth's gravity is like the moon when you jump, running at a grand total speed of 1.6 m/s. Tried landing the atmospheric lander. Intertia dampeners are on. Waiting for engines to kick in. They never did. Then SPLAT! At the last 10 seconds I tried manually thrusting to avert smashing. The engines didn't even FIRE AT ALL! They just sat idle! Keen. I hope you release a hotfix for all this, because I don't want to wait another week to try and hope that bugs are fixed. Get everyone working on fixing bugs BEFORE adding new things like animations! Oh yeah. 1 more bug. The log generating issue still isn't fixed and that is causing sim speeds to drop even more! It may have gotten worse! This is just my 2 cents on this patch.

    P.S. ATMO THRUSTERS DONT WORK AT ALL

    P.P.S third time posting this to see if it will get any recognition
     
    • Funny Funny x 1
  13. mikeloeven Senior Engineer

    Messages:
    1,162
    Also release a hotfix for the broken animation system

    I dont care how much better the system is it's useless if multiple animation mods can no longer coexist
     
    • Agree Agree x 2
  14. Ronin1973 Master Engineer

    Messages:
    4,964
    I suspect that someone loaded some ancient versions of the .sbc files and that broke some... stuff...

    The elite stuff isn't functional, atmos are nerfed by 30% after they got a bump by 30% a few weeks ago. There's just too much that changed for no reason.
     
    • Agree Agree x 1
    • Informative Informative x 1
  15. bronxae Apprentice Engineer

    Messages:
    135
    "- removed DX9 and WinXP support" ..... <insert image of battlecruiser giving 20 gun salute here>, its sad to see it go but this will remove a lot of stress on the devs so they can focus on the dx11 issues. Sometimes in order for progress to be made, somethings have to die off.
     
    • Agree Agree x 2
  16. Natu Trainee Engineer

    Messages:
    1
    inventory bug !!!!
     
  17. GT500 Trainee Engineer

    Messages:
    63
    Did you just post 4 month old screen shots :)

    Take new Screen Shots with adjusted lights and if you are still having problems, share you save and perhaps we can tell you what is going on. DX11 does not do that for me unless I have lighting intensity through the roof.
     
  18. heartlessdeath Trainee Engineer

    Messages:
    41
    What? Lol
     
  19. lostjounin Trainee Engineer

    Messages:
    45
    Not sure if the hotfix was released yet but did I miss some announcement somewhere where they decided to stop posting the fixes on the original update post at the beginning of the thread? It can't take more than 15 seconds to edit and post the hotfix notes... lazy much?
     
  20. Hemp Plan[e]t Apprentice Engineer

    Messages:
    157
    the hotfix is out? :woot:
     
    • Disagree Disagree x 1
    • Late Late x 1
  21. -dc- Trainee Engineer

    Messages:
    3
    I didn't notice anything.
     
  22. Pouaichh Trainee Engineer

    Messages:
    2
    The best April fools joke would be that a dev or mod drop a "fix released"
     
  23. Riph Trainee Engineer

    Messages:
    40
    I gotta agree with GT500 here. DX11 has always been a graphics and performance boost for me. Everything looks better, and faster in DX11. Whatever's wrong with your rig to produce that screenshot is awful, but it's not happening to me.

    Edit: Running a single GTX 970
     
  24. TheNudeNerd Trainee Engineer

    Messages:
    74
    Hotfix looks to be out, just got an update.
     
  25. Daddsterc0347 Trainee Engineer

    Messages:
    67
    I dont know if it is because of an old save or what, but I have an issue where I grind down a gun turret and suddenly there are -29bazillion computers. Anyone else see this?
     
  26. Potter Apprentice Engineer

    Messages:
    496
    The bug report forum is littered with these reports. Phand has said we should expect a hotfix for it today.
     
  27. Lt. Yankee Apprentice Engineer

    Messages:
    296
    That's why we got hotfix
     
    • Disagree Disagree x 1
    • Funny Funny x 1
  28. Hemp Plan[e]t Apprentice Engineer

    Messages:
    157
    i can't see a difference, why they never note their hotfixes?
     
    • Disagree Disagree x 1
  29. Echillion Senior Engineer

    Messages:
    1,334
    @Drui hotfix notes please?
     
  30. Potter Apprentice Engineer

    Messages:
    496
    I hope negative mass computers and plates has been fixed. Loading to test now!
     
    • Agree Agree x 1
Thread Status:
This last post in this thread was made more than 31 days old.